Bug 101442 - Hyperlink is terribly dated vocabulary
Summary: Hyperlink is terribly dated vocabulary
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.3.0 target:5.4.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2016-08-10 20:29 UTC by Björn Michaelsen
Modified: 2017-01-04 12:48 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Michaelsen 2016-08-10 20:29:32 UTC
The 1990ies are over and nobody speaks about "hyperlinks" anymore. This EasyHack to replace "hyperlink" in the UI with the simple "link" where it doesnt introduce ambiguity. The latter is universally understood these days.

code pointers:
cui/source/dialogs/hyperdlg.src
http://opengrok.libreoffice.org/search?q=hyperlink&project=core&defs=&refs=&path=&hist=
Comment 1 jani 2016-08-11 06:45:21 UTC
Changing skill to UI, to match the filters. (skillHIG is historic)
Comment 2 Federico Bassini 2016-10-06 12:35:48 UTC
hi, i'm Federico a student of university of Perugia. I work in this bug, it is the first easyhack to learn how is the workflow. Monkey Task!
Comment 3 jani 2016-10-06 13:03:49 UTC
(In reply to Federico Bassini from comment #2)
> hi, i'm Federico a student of university of Perugia. I work in this bug, it
> is the first easyhack to learn how is the workflow. Monkey Task!


It is a good way to start. Welcome I am here to help new people, please have a look at
https://wiki.documentfoundation.org/Development/GetInvolved

and please assign the task to yourself, so we can see you are working on it.
Comment 4 Federico Bassini 2016-10-06 15:00:54 UTC
(In reply to jan iversen from comment #3)
> (In reply to Federico Bassini from comment #2)
> > hi, i'm Federico a student of university of Perugia. I work in this bug, it
> > is the first easyhack to learn how is the workflow. Monkey Task!
> 
> 
> It is a good way to start. Welcome I am here to help new people, please have
> a look at
> https://wiki.documentfoundation.org/Development/GetInvolved
> 
> and please assign the task to yourself, so we can see you are working on it.

i commit the first patch, i'm new and i hope that it's ok... i'm waiting for review
Comment 5 V Stuart Foote 2016-10-08 14:55:38 UTC
Up for review at

https://gerrit.libreoffice.org/#/c/29573/
Comment 6 Commit Notification 2016-10-08 21:21:41 UTC
Federico Bassini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a1297fc2df243d765ffb14f18bbdde158459b9f4

tdf#101442 change "Hyperlink" to "Link" for a modern vocabulary

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Andras Timar 2016-10-09 09:32:41 UTC
The word "link" is overloaded already, you can link Writer text frames so that their contents automatically flow from one frame to another, you can link images instead of embedding them, now we'll introduce a 3rd meaning. In the end 100+ people will spend hours because of this (translators, documentation writers).

Federico, you changed 5 occurrences, 243 to go... Don't forget the help.

timar@timar-x230:~/libreoffice-master/translations/source/hu> git grep -i hyperlink | grep msgid | wc -l
248
Comment 8 V Stuart Foote 2016-10-09 13:07:01 UTC
@Björn, thoughts on retracting and reverting given Andras' bleak assesment?
Comment 9 Yousuf Philips (jay) (retired) 2016-10-09 16:12:50 UTC
With the major office suites (MS, WPS/Kingsoft, WordPerfect) still using Hyperlink, i'm not sure this is a wise change, but atleast some office suites are making the switch (Google Docs, Calligra, iWork).

I'm sure someone will be complaining they cant do Alt + I + H anymore. :D

We also have Edit > Links which needs to be renamed to something more useful and less confusing like 'Embedded Links' or 'Embed Linking'.
Comment 10 Heiko Tietze 2016-10-10 07:20:30 UTC
If we go ahead, the term Link may be used for internal associations (e.g. frame) where Hyperlink means to deal with external data (e.g. web sites or images, the latter is not so nice). But I agree with the concerns. Lot of work, confusions inevitable. Better we discuss each occurrence in detail.
Comment 11 Dave Barton 2016-10-10 07:56:40 UTC
If we are going to concern ourselves with someone's "perceived" notion of antiquated, but technically correct, terminology, let's remove other antiquated terms like "Wireless" and "Fidelity" (ie. WiFi).
There is way too much "Bike-shedding" https://en.wikipedia.org/wiki/Law_of_triviality attention given to these kinds Bugzilla reports, when there much more important issues to be resolved.
I say revert the patch and close this issue as "NOT A BUG" or "WON'T FIX".
Comment 12 Commit Notification 2016-10-10 08:40:05 UTC
Federico Bassini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=06dec56d96603026921311c6ddfa41ed6b5879d5

tdf#101442 Change "hyperlink" to "link" for a modern vocabulary

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2016-10-10 08:43:07 UTC
Federico Bassini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=728c7327bd97602a38723553ed044ea4c01d13b2

tdf#101442 Change "hyperlink" to "link"

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Samuel Mehrbrodt (CIB) 2016-10-10 08:58:13 UTC
Sorry I didn't read the comments here before I pushed the last two patches.
Maybe we can bring this up in the Design Hangout on Friday and decide there?
Comment 15 Federico Bassini 2016-10-10 09:03:31 UTC
(In reply to Andras Timar from comment #7)
> The word "link" is overloaded already, you can link Writer text frames so
> that their contents automatically flow from one frame to another, you can
> link images instead of embedding them, now we'll introduce a 3rd meaning. In
> the end 100+ people will spend hours because of this (translators,
> documentation writers).
> 
> Federico, you changed 5 occurrences, 243 to go... Don't forget the help.
> 
> timar@timar-x230:~/libreoffice-master/translations/source/hu> git grep -i
> hyperlink | grep msgid | wc -l
> 248

hi Andras!

thank you to see this bug and help me to resolve this!

while i correct the bug i had a lot of question to what to change and what i unchange...

my mayor question is: i change all of this occurence?
in this occurences there is comments, variables and piece of code... also this i change or not? 

i change only the occurence that the users see...

i want to help for this easyhack!

@Yousuf Philips
@Heiko Tietze
@Dave Barton 

thank all of you!

my questions are:

what is the best way to resolve this?
i change every occurences?
what is the best term for this?

i need your help and i'm happy to help! ;)
Comment 16 Federico Bassini 2016-10-10 09:06:11 UTC
i hope that my english is understandable! sorry for that!
Comment 17 Björn Michaelsen 2016-10-10 10:56:37 UTC
(In reply to Andras Timar from comment #7)
> The word "link" is overloaded already, you can link Writer text frames so
> that their contents automatically flow from one frame to another, you can
> link images instead of embedding them, now we'll introduce a 3rd meaning.

So in common english language, "link" is already understood to mean "hyperlink" -- they are used synonymously by the public. Someone reading "link" these days will assume it to be a hyperlink and be confused if it is not.

Along those lines, if we want to have specific vocabulary, we should have good consistent and specific names for links that are NOT hyperlinks. Namely "linked text frames" should have a explicit name making clear they are _not_ hyperlinks. As for linked (not embedded) images: Those are hyperlinked images, so they are _not_ a different concept at all.
 
> Federico, you changed 5 occurrences, 243 to go... Don't forget the help.
> 
> timar@timar-x230:~/libreoffice-master/translations/source/hu> git grep -i
> hyperlink | grep msgid | wc -l
> 248

Thats not a valid comparison: Localizations might have their own interpretation of vocabulary (e.g. german uses the Pseudo-Anglicism "Handy" for a mobile phone, while there is no such thing in the source language.

> In the end 100+ people will spend hours because of this (translators,
> documentation writers).

This is why we are a project: to improve LibreOffice.

As such:
1/ This is about the default en-US l10n only, vocabulary of other locales is a decision to be left to the local maintainers. I assume this is fixed with this?
2/ Other locals are out-of-scope for this issue.
3/ As a follow-up using a more specific wording than "link" for links that are not hyperlinks (like the linked text frames) might be considered.
Comment 18 Yousuf Philips (jay) (retired) 2016-10-10 14:04:59 UTC
(In reply to Björn Michaelsen from comment #17)
> As for linked (not embedded) images: Those are hyperlinked
> images, so they are _not_ a different concept at all.

A text link linking to an image and a linked (not embedded) image are two different things and should have distinct text to differentiate them, similar to the incorrectly labeled Edit > Link entry.

Maybe we should use 'Insert as non-Embedded' rather than 'Insert as Linked' in the dialogs, so a user gets to know Embedded and Non-Embedded and then Edit > Link can be changed to Edit > Non-Embedded Files or something like that.
Comment 19 Björn Michaelsen 2016-10-10 15:43:42 UTC
(In reply to Yousuf Philips (jay) from comment #18)
> Maybe we should use 'Insert as non-Embedded' rather than 'Insert as Linked'
> in the dialogs ...

Maybe, please dont discuss this to death here, this is a rather clean cut EasyHack (or was, before it was scopecreeped). Details on this can be discussed on (UNCONFIRMED) bug 103093.

Closing this one as FIXED in the original scope (en-US only). Thank you for your work and patch, Federico!
Comment 20 Stanislav Horacek 2016-10-11 19:22:20 UTC
Reopened - see remaining "Ctrl-click required to follow hyperlinks", "hyperlink" in sw/uiconfig/swriter/ui/tocentriespage.ui and probably more.

This type of "bug" seems to be fixed quickly in a few days, but thorough handling of all its consequences will take years. Also, I am afraid that the ambiguity in terms introduced by the fix outweighs the (maybe) better wording.
Comment 21 Cor Nouws 2016-10-12 07:53:08 UTC
I think first it's needed to apologize to Federico - for him getting involved in this mess.

Do I see it right that this change was not discusses with UX-advice at all?

In any case:

(In reply to Dave Barton from comment #11)
> There is way too much "Bike-shedding"
> https://en.wikipedia.org/wiki/Law_of_triviality attention given to these
> kinds Bugzilla reports, when there much more important issues to be resolved.

+1
Comment 22 jani 2016-10-12 08:22:30 UTC
Sorry settiing ASSIGNED (I understand why REOPENED was used, but it is assigned to a person).

Fedrico, my apologies for the bikeshedding you have seen on this bug this should not have happened. This will be discussed at our coming ESC meeting.

We announce new easyHack in our weekly ESC meeting, and the minutes are sent to our development mailing list, so if someone disagrees that is the time to complain.

I hope you are still in the mood to supply more patches.

thanks for your work.
Comment 23 Federico Bassini 2016-10-12 09:10:19 UTC
@jan,@Cor

thanks to you! don't worry about the bikeshedding! i'm happy to help and i have to learn a lot of things, the important for is do the things good! 

@Stanislav Horacek 
in a while i change this two occurence...

it's right workflow?
i mean... when someone found "hyperlink" comment this bug and i change 
or it is better search and found everythings?

i'll wait the review!
Comment 24 Commit Notification 2016-10-12 09:19:29 UTC
Federico Bassini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a4df89e0fafb3b2991a57c506f137367a117f355

tdf#101442 "hyperlink" to "link" - other words change

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Andras Timar 2016-10-15 07:23:48 UTC
Hi Federico,

Let me document how you can find all occurrences of 'hyperlink' in the UI, it's the detailed explanation of my comment 7. 

First of all, I assume you have the source tree checked out. 
1. make l10ntools.all
2. make translations
3. cd workdir/pot
4. grep -r msgid * | grep -v help | tr -d '_' | tr -d '~' | grep -i hyperlink
   a. you grep for en-US strings
   b. you ignore help for the time being
   c. you remove _ and ~ characters which are markers for access keys
   d. you grep for the word hyperlink

As of now, it gives 17 occurrences. One of them is not to be replaced, it is the HYPERLINK spreadsheet function in formula module. You can open each pot file, and find the hyperlink word. For example:
    vi sw/uiconfig/swriter/ui.pot
You will find:
    #. cEgTe
    #: notebookbar_groups.ui
    msgctxt ""
    "notebookbar_groups.ui\n"
    "hyperlink\n"
    "label\n"
    "string.text"
    msgid "Hyperlink"
    msgstr ""
Now you know, that you have to replace this string in sw/uiconfig/swriter/ui/notebookbar_groups.ui. 

If you have time, you can go for the help, too. You will get 211 hits in helpcontent2 and swext (providing that you configured LibreOffice building --with-help, and you have the helpcontent2 submodule).
grep -r msgid * | grep help | tr -d '_' | tr -d '~' | grep -i hyperlink
Comment 26 Heiko Tietze 2016-10-15 09:28:41 UTC
(In reply to Andras Timar from comment #25)
> Now you know, that you have to replace this string in
> sw/uiconfig/swriter/ui/notebookbar_groups.ui. 

This place of "Hyperlink" is part of a menu button list, which is labeled "Links" as the generic term for Hyperlink, Footnote, Endnote, Bookmark, and Cross-Reference. We would also need to change the title into "References", for instance.

Great how-to, Andras!
Comment 27 Federico Bassini 2016-10-17 10:19:25 UTC
(In reply to Andras Timar from comment #25)
> Hi Federico,
> 
> Let me document how you can find all occurrences of 'hyperlink' in the UI,
> it's the detailed explanation of my comment 7. 
> 
> First of all, I assume you have the source tree checked out. 
> 1. make l10ntools.all
> 2. make translations
> 3. cd workdir/pot
> 4. grep -r msgid * | grep -v help | tr -d '_' | tr -d '~' | grep -i hyperlink
>    a. you grep for en-US strings
>    b. you ignore help for the time being
>    c. you remove _ and ~ characters which are markers for access keys
>    d. you grep for the word hyperlink
> 
> As of now, it gives 17 occurrences. One of them is not to be replaced, it is
> the HYPERLINK spreadsheet function in formula module. You can open each pot
> file, and find the hyperlink word. For example:
>     vi sw/uiconfig/swriter/ui.pot
> You will find:
>     #. cEgTe
>     #: notebookbar_groups.ui
>     msgctxt ""
>     "notebookbar_groups.ui\n"
>     "hyperlink\n"
>     "label\n"
>     "string.text"
>     msgid "Hyperlink"
>     msgstr ""
> Now you know, that you have to replace this string in
> sw/uiconfig/swriter/ui/notebookbar_groups.ui. 
> 
> If you have time, you can go for the help, too. You will get 211 hits in
> helpcontent2 and swext (providing that you configured LibreOffice building
> --with-help, and you have the helpcontent2 submodule).
> grep -r msgid * | grep help | tr -d '_' | tr -d '~' | grep -i hyperlink

Thank you so much Andras for the How-to...

i follow your suggest and i change the occurences...
but i don't change this files:

sw/uibase/utlui/navipi.src
sd/souce/ui/app/string.src
sc/source/ui/navipi/navipi.src

because the msgid is "insert as hyperlink" and there is already one "insert as link".
i change this anyway?

@Heiko
i change alse "Links" in "Resources"

i'll wait yours suggest and the review!

for the help i'll work...
Comment 28 Heiko Tietze 2016-10-17 10:50:29 UTC
(In reply to Federico Bassini from comment #27)
> i change alse "Links" in "Resources"

"Resources" works perfectly for me. Great work, Frederico!
Comment 29 Adolfo Jayme 2016-10-22 17:01:59 UTC
I won’t be applying any of these changes to the Spanish translation. “Hyperlink” is a PRECISE word, not an OUTDATED one. The whole rationale behind this change is ridiculous.
Comment 30 Luke 2016-10-28 19:48:38 UTC
It seems we're moving forward with this change. If we must change URL links from hyperlink to link, shouldn't we first come up with a new name for internal use of link frames and images? Otherwise how do you know if it's a URL link or an internal link. Maybe we could call internal links, chains instead? 

How does 'chain frame' sound? Others have suggested clarifying when it's not a hyperlink. But I think it's better to just use a different term.

Overall, I think replacing a specific, well defined term with a broad colloquial terms is a bad idea. For example, I know people that use LibreOffice as primitive HTML generator. For those users, this change could make thing confusing. We should have one term that is reserved for making hyperlinks when exported.
Comment 31 Björn Michaelsen 2016-10-31 13:32:16 UTC
(In reply to Luke from comment #30)
> ... shouldn't we first come up with a new name for ...

As said in comment #19:

(In reply to Björn Michaelsen from comment #19)
> Maybe, please dont discuss this to death here, this is a rather clean cut
> EasyHack (or was, before it was scopecreeped). Details on this can be
> discussed on (UNCONFIRMED) bug 103093.

You are referred to discuss design beyond what was in this EasyHack originally in bug 103093, *NOT* here. Please leave this one _only_ to mentoring help on the original task (as provided by e.g. Andras), not for new/related ideas. Thanks.

As Andras brought up the additional occurrences in comment #25, I leave to him when to close this issue.
Comment 32 jani 2016-10-31 15:23:07 UTC
(In reply to Björn Michaelsen from comment #31)
> (In reply to Luke from comment #30)
> > ... shouldn't we first come up with a new name for ...
> 
> As said in comment #19:
> 
> (In reply to Björn Michaelsen from comment #19)
> > Maybe, please dont discuss this to death here, this is a rather clean cut
> > EasyHack (or was, before it was scopecreeped). Details on this can be
> > discussed on (UNCONFIRMED) bug 103093.
> 
> You are referred to discuss design beyond what was in this EasyHack
> originally in bug 103093, *NOT* here. Please leave this one _only_ to
> mentoring help on the original task (as provided by e.g. Andras), not for
> new/related ideas. Thanks.
> 
> As Andras brought up the additional occurrences in comment #25, I leave to
> him when to close this 


Pardon me, and shoot me later, with my mentoring hat on, I have decided to remove this from the easyhack list. Anybody who disagree feel free to bring it up in the next ESC MEETING.

bjoern@ without my mentoring hat on, I agree with you and am sorry to do this kind of overruling, which I trust you know I do not do frequently. 

Looking forward to be shoot thursday, but my de ision stands.
Comment 33 Commit Notification 2016-12-23 12:59:20 UTC
Federico Bassini committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b6aad6de12df9534e82f5a8ef8184cac77e5c6b4

tdf#101442 - "hyperlink" to "link"

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 34 Luke 2016-12-23 22:03:20 UTC
This bug has been very poorly handled. We have made no progress on Bug 103093, and now removed all references to hyperlink.

I could see the argument of having context menu's be link for brevity and for clarity the actual dialog box use hyperlink and internal link. Instead, all references to hyperlink has been removed and the internal links have not been renamed. This was a terrible UX decision. 

We have replaced a specific, well defined term with a broad colloquial term with multiple meanings and multiple uses within our software. And now we have just removed all clarifying references so the users has to rely on past experience and context. All we have done is made the software more confusing.
Comment 35 Luke 2016-12-23 22:18:35 UTC
I forgot to add that this was all based on a flawed premise that hyperlink is dated. As a verb, possibility. As a noun, it is not. Take a look at this recent news story:

http://www.mondaq.com/IsleofMan/x/547856/Copyright/Can+Hyperlinks+Infringe

Note how link is only used here after 5 occurrences of 'hyperlink'. And when 'link' finally used it's within a sentence that has already used'hyperlink' once. As an abbreviation it's fine. But without either a URL or a some mention of hyperlink for clarity, all we have done is made the software more confusing.
Comment 36 Björn Michaelsen 2016-12-23 23:13:50 UTC
Frankly, I dont know why this bug is still open as per comment 31:

(In reply to Björn Michaelsen from comment #31)
> (In reply to Luke from comment #30)
> As Andras brought up the additional occurrences in comment #25, I leave to
> him when to close this issue.

@Andras: Can you please close this whack-a-mole for good finally, or provide direction here (or better still: to close this trainwreck and do a follow-up)?
Comment 37 jani 2016-12-24 07:47:44 UTC
(In reply to Björn Michaelsen from comment #36)
> Frankly, I dont know why this bug is still open as per comment 31:
> 
> (In reply to Björn Michaelsen from comment #31)
> > (In reply to Luke from comment #30)
> > As Andras brought up the additional occurrences in comment #25, I leave to
> > him when to close this issue.
> 
> @Andras: Can you please close this whack-a-mole for good finally, or provide
> direction here (or better still: to close this trainwreck and do a
> follow-up)?

Before I have to defend more patches (I just abandoned the recent patch, with a explanation to the new contributor), I change status on this patch.

Anybody who reopens this patch, please check with the ESC.
Comment 38 steve -_- 2016-12-24 11:19:28 UTC Comment hidden (me-too)