Bug 103132 - LibreLogo Linebreaks are artificially added when executing __translate__() via the menu button
Summary: LibreLogo Linebreaks are artificially added when executing __translate__() vi...
Status: RESOLVED DUPLICATE of bug 100941
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-11 19:14 UTC by Andreas
Modified: 2016-11-27 19:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Modified LibreLogo.py (78.06 KB, text/x-python)
2016-10-11 19:14 UTC, Andreas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas 2016-10-11 19:14:04 UTC
Created attachment 127952 [details]
Modified LibreLogo.py

When executing __translate__() in LibreLogo.py via the LibreLogo 
"Wizard"-menu button 

Linebreaks are artificailly added to the Logo source code.

resonsible lines in __translate__() seem to be

395:# convert to paragraphs
396: _dispatcher__(".uno:ExecuteSearch", (__getprop__("SearchItem.SearchString", r"\n"), __getprop__("SearchItem.ReplaceString", "\n"), \


removing the last '\n':
396: _dispatcher__(".uno:ExecuteSearch", (__getprop__("SearchItem.SearchString", r"\n"), __getprop__("SearchItem.ReplaceString", ""), \

removes the 'added' linebraks.

But then __translate__() does not add a page break as before.

The compact source code of LibreLogo.py make it a bit hard to trace the problem.

Could you pleas contact the author??

Thanks

  Andreas
Comment 1 Julien Nabet 2016-11-27 19:52:03 UTC
It's been fixed from 5.2.0 so if you give a try to last stable LO version 5.2.3, it should be ok.

*** This bug has been marked as a duplicate of bug 100941 ***