Download it now!
Bug 100941 - LibreLogo: "magic wand" icon inserts incollect '\n' characters instead of paragraph breaks
Summary: LibreLogo: "magic wand" icon inserts incollect '\n' characters instead of par...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.0
Keywords: regression
: 72653 103132 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-07-16 01:03 UTC by Naruhiko Ogasawara
Modified: 2016-11-27 19:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Naruhiko Ogasawara 2016-07-16 01:03:55 UTC
Step to reproduce.

1) create new Writer file
2) "Edit" > "Search and Replace" > "Other options", check off "Regular expression" 
3) type:
----
fd 100
rt 90
----
4) click "magic wand" icon

Expected.
----
FORWARD 100
RIGHT 90
----

Actual.
----
\nFORWARD 100\nRIGHT 90
----


NOTE:

1) If "Regular expression" in "Search and Replace" checked, works fine
2) The problems seems the following pyuno code(LibreLogo.py: L394-397) change a behavior by UI settings:
----
    # convert to paragraphs
    __dispatcher__(".uno:ExecuteSearch", (__getprop__("SearchItem.SearchString", r"\n"), __getprop__("SearchItem.ReplaceString", r"\n"), \
        __getprop__("Quiet", True), __getprop__("SearchItem.Command", 3), __getprop__("SearchItem.StyleFamily", 2), \
        __getprop__("SearchItem.AlgorithmType", 1), __getprop__("SearchItem.RowDirection", 1), __getprop__("SearchItem.SearchFlags", 65536)))
----
Comment 1 Takeshi Abe 2016-07-16 14:29:45 UTC
Reproduced on Debian jessie:
Version: 5.2.0.2
Build ID: a7567a46e5d2953c320b13eb88a3981c4f9bd1e0
CPU Threads: 4; OS Version: Linux 3.16; UI Render: default; 
Locale: ja-JP (en_US.UTF-8)

This issue does not happen with LibO 5.1.4, so seems a regression.
Comment 2 Commit Notification 2016-07-18 09:59:54 UTC
Takeshi Abe committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b1a6d157683b8182089ed5854179c8da8c416304

Resolves: tdf#100941 LibreLogo: replace literal '\n' with newline

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2016-07-18 10:04:09 UTC
Takeshi Abe committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3881ea57892b78dcbc52d46a22616ac72bd4c335&h=libreoffice-5-2

Resolves: tdf#100941 LibreLogo: replace literal '\n' with newline

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2016-07-19 07:13:17 UTC
Takeshi Abe committed a patch related to this issue.
It has been pushed to "libreoffice-5-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f2c389abadd5af629d89f96909a98cc04e7679c&h=libreoffice-5-2-0

Resolves: tdf#100941 LibreLogo: replace literal '\n' with newline

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Julien Nabet 2016-11-27 19:52:03 UTC
*** Bug 103132 has been marked as a duplicate of this bug. ***
Comment 6 Julien Nabet 2016-11-27 19:59:01 UTC
*** Bug 72653 has been marked as a duplicate of this bug. ***