Bug 72653 - LibreLogo: ABC button creates paragraph marks
Summary: LibreLogo: ABC button creates paragraph marks
Status: RESOLVED DUPLICATE of bug 100941
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-12 23:22 UTC by Gilvan Vilarim
Modified: 2016-11-27 19:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Librelogo creates extra blank paragraphs (100.36 KB, image/png)
2014-01-08 21:16 UTC, Gilvan Vilarim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gilvan Vilarim 2013-12-12 23:22:35 UTC
1 - Create a new document in Writer and activate Logo toolbar
2 - change current paragraph language to Portuguese-Brazil
3 - click on the ABC button (with a magic wand)

Each time commands are translated, Logo creates paragraphs marks after each command.

Things like:
FORWARD 30
RIGHT 90
BACK 40

become:
FORWARD 30

RIGHT 90

BACK 40


and then:
FORWARD 30


RIGHT 90


BACK 40

I guess Logo should not do that. I could not test in other languages.

[]s
Comment 1 Gilvan Vilarim 2013-12-12 23:24:02 UTC
Of course, my sample commands are in English, but Logo correctly correct them to portuguese. The issue is about extra paragraph marks.
Comment 2 retired 2013-12-29 12:30:18 UTC
Gilvan: Any chance you can attach a small screencast showing this behavior?

Also which Operation system and LO version are you using?

Is this bug still valid / reproducible with the latest pre-release 4.2.0.1: http://www.libreoffice.org/download/pre-releases/

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED . Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 3 Gilvan Vilarim 2014-01-08 21:16:26 UTC
Created attachment 91708 [details]
Librelogo creates extra blank paragraphs
Comment 4 Gilvan Vilarim 2014-01-08 21:21:21 UTC
This behavior continues to happen in LO 4.2.0.1
Id. : 7bf567613a536ded11709b952950c9e8f7181a4a

OS: Windows 7 64-bit Home Premium

See print screen attached (with 3 extra blank paragraphs after each command)

1 - Create a new document in Writer and activate Logo toolbar
2 - change current paragraph language to Portuguese-Brazil
3 - type commands in each line (just examples)
3 - click on the ABC button (with a magic wand)

Each time commands are translated, Logo creates paragraphs marks after each command.

Things like:
FORWARD 30
RIGHT 90
BACK 40

become:
PARAFRENTE 30

PARADIREITA 90

PARATRÁS 40

(translation is ok, but blank lines are created each time you click on the magic wand button in Logo toolbar)

[]s
Comment 5 László Németh 2014-05-22 14:09:37 UTC
Could you check in LibreOffice 4.2.4, or with a new text (copying text with CR characters may result this kind of problem)?
Comment 6 Gilvan Vilarim 2014-05-23 19:20:04 UTC
Hello. This bug persists in Libreoffice 4.3 beta1.

The behavior is always the same. It doesn't matter ir you paste a text or type it from the scratch.
See the LibreLogo sample below, after 2 clicks on the magic wand button (tested on Brazilian portuguese).
There is a progressive paragraph marks insertion: the first click creates 1 mark between the commands, the second creates 3, the third creates 7, the fourth 15, and so on:



MUDARCORDALETRA “VERDE”



ROTULAR “LIBRE”



USARNADA



PARATRÁS 30



GRUPO [



	MUDARCORDAPINTURA QUALQUER



	CÍRCULO 40



	MUDARCORDALETRA “PRETO”



	ROTULAR “LOGO”



	PARAESQUERDA 180



	PARAFRENTE 20



	USARLÁPIS



	MUDARCORDOLÁPIS QUALQUER



	MUDARESPESSURADOLÁPIS 1



	PARAFRENTE 40



	REPETIR 20 [



		PARAFRENTE CONTVEZES*2



		PARADIREITA 90



	]



]



USARNADA POSICIONAR QUALQUER USARLÁPIS
Comment 7 pierre-yves samyn 2014-05-25 11:04:47 UTC
Hi

I reproduce on windows 7/64 & Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

Also reproduce with Version: 4.3.0.0.beta1
Build ID: 2e39c7e59c8fc8b16a54c3d981dceef27fb0c07f

I set status to New, thank you for reporting.

Regards
Pierre-Yves
Comment 8 QA Administrators 2015-06-08 14:42:07 UTC Comment hidden (obsolete)
Comment 9 Gilvan Vilarim 2015-06-10 23:36:43 UTC
Hil. The bug persists in LibreOffice 5.0 Beta1 in pt-br language.

Tested on Windows 8.1 pt-br.

Best regards,
Gilvan.
Comment 10 Julien Nabet 2015-12-05 18:40:31 UTC
On pc Debian x86-64 with master sources updated today, I tried to reproduce but Turtle does the draw and lines aren't translated in Portuguese.
Perhaps I missed something.
Comment 11 Gilvan Vilarim 2016-04-29 19:54:59 UTC
Hello guys. The bug persists in version 5.1. Tested on Windows 7/10 with Brazilian portuguese localization.

Best regards,
Gilvan.
Comment 12 Andreas 2016-07-16 01:36:40 UTC
still like  Gilvan Vilarim on 2013-12-12 23:22:35 UTC did:

On Windows 10 Home 64 bit and AMD A8-3500M APU 1.5 GHz with AMD GPU
and 

Libre Office 5.1.4.2 (x64)

Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
Threads CPU : 4; Version de l'OS :Windows 6.19; UI Render : par défaut; 
Locale : fr-FR (de_DE)


1 - Create a new document in Writer and activate Logo toolbar
2 - change current document and LibreOffice language to French
3 - click on the ABC button (with a magic wand)

Each time commands are translated, Logo creates paragraphs marks 
after each command and adds non neccessary new lines.

Things like:
FORWARD 30
RIGHT 90
BACK 40

become:
AVANCE 30

DROITE 90

RECULE 40

and after a second click:
AVANCE 30



DROITE 90



RECULE 40
Comment 13 Julien Nabet 2016-11-27 19:59:01 UTC
It's been fixed from 5.2.0, so give a try to last stable LO version 5.2.3

*** This bug has been marked as a duplicate of bug 100941 ***