Bug 103142 - FILESAVE, FILEOPEN: No embedded sound in presentations saved in .ppt format
Summary: FILESAVE, FILEOPEN: No embedded sound in presentations saved in .ppt format
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Phil Davis
URL:
Whiteboard:
Keywords: filter:ppt
Depends on:
Blocks: Media PPT
  Show dependency treegraph
 
Reported: 2016-10-12 04:02 UTC by Phil Davis
Modified: 2020-06-09 14:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample presentation with audio (666.29 KB, application/vnd.oasis.opendocument.presentation)
2016-10-25 04:01 UTC, Phil Davis
Details
Presentation with unplayable Audio saved in PPT format (165.00 KB, application/vnd.ms-powerpoint)
2016-10-25 04:03 UTC, Phil Davis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Davis 2016-10-12 04:02:48 UTC
Steps to reproduce:

1) Create a new presentation in Impress.
2) Create one or more slides.
3) On one of the slides (the first one is fine), Insert->Audio or Video...
4) Choose an audio file on your computer. (I chose an MP3 format)
   The file is shown as an embedded object on the slide.
5) Preview the slideshow to see that the sound plays on that slide.
6) Save the presentation as a .ppt file.
7) Preview the slideshow again to see that the sound still plays on that slide.
8) Close and reopen the .ppt file.
9) Preview the slide show.

What is expected to happen:  
The embedded sound plays on the specified slide as it is supposed to.

What actually happens:
The embedded sound appears as an object on the slide, but with a "?" image. No sound plays.

Note: If the sound is specified using Slide Transition, Sound chooser, then it saves OK in PPT format and plays fine.

So this is slightly different to bug 44223, where both the embedded sound and slide transition sound methods do not save in PPTX format.
Comment 1 Buovjaga 2016-10-24 12:39:19 UTC
Please attach an example presentation in ODP format, which we can then save as PPT.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 Phil Davis 2016-10-25 04:01:07 UTC
Created attachment 128228 [details]
Sample presentation with audio

This is a presentation in LibreOffice format with a single slide that has some MP3 audio that plays fine. It was created using LibreOfice 5.2.2.2
Comment 3 Phil Davis 2016-10-25 04:03:42 UTC
Created attachment 128229 [details]
Presentation with unplayable Audio saved in PPT format

This is the previous file, now saved as PPT format. When opened in LibreOffice Impress, the embedded audio on slide 1 shows with a "?". When running the slide show, no audio plays.
Comment 4 Xisco Faulí 2016-10-25 11:25:15 UTC

*** This bug has been marked as a duplicate of bug 44223 ***
Comment 5 Luke 2019-02-04 18:35:59 UTC
Not Dupe of Bug 44223. Both description and title refer to OOXML / PPTX. This bug is about PPT.
Comment 6 Aron Budea 2020-06-09 10:55:59 UTC
As far as I can see PowerPoint doesn't save embedded media in PPT files:
“The media clips inserted or upgraded in this version of PowerPoint will be saved as Pictures.”
https://support.office.com/en-us/article/compatibility-checker-in-powerpoint-f9b3ac30-cfca-4f0b-bc4e-2229906e7fc4

Is anyone able to confirm or disprove with PowerPoint?
Comment 7 Buovjaga 2020-06-09 14:35:30 UTC
(In reply to Aron Budea from comment #6)
> As far as I can see PowerPoint doesn't save embedded media in PPT files:
> “The media clips inserted or upgraded in this version of PowerPoint will be
> saved as Pictures.”
> https://support.office.com/en-us/article/compatibility-checker-in-powerpoint-
> f9b3ac30-cfca-4f0b-bc4e-2229906e7fc4
> 
> Is anyone able to confirm or disprove with PowerPoint?

You are right! Tested with PP 2013 and it even warned that the media file will be saved as an image. Closing.