Bug 44223 - FILESAVE, FILEOPEN: No sound in presentations saved in .pptx format
Summary: FILESAVE, FILEOPEN: No sound in presentations saved in .pptx format
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: filter:ppt, filter:pptx
: 74379 (view as bug list)
Depends on:
Blocks: PPTX PPT
  Show dependency treegraph
 
Reported: 2011-12-28 08:28 UTC by rfvuhbtg
Modified: 2019-03-14 18:14 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample PPTX with animation and transition sound (62.23 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-10-13 19:08 UTC, Luke
Details
PPT format correctly imported (126.00 KB, application/vnd.ms-powerpoint)
2018-10-13 19:12 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rfvuhbtg 2011-12-28 08:28:38 UTC
Steps to reproduce:

1)  Create a new presentation in impress.
2)  Create one or more slides.
3)  On one of the slides (the first one is fine), click on Slide Transition in the sidebar then click on the Sound drop down selector.
4)  Choose a sound to play on that slide, either a built-in sound or choose "Other Sound" and pick an audio file on your computer.
5) Preview the slideshow to see that the sound is now playing on that slide.
6) Save the presentation as a .pptx file then close and reopen it.

What is expected to happen:  
The sound plays on the specified slide as it is supposed to.

What actually happens:
There is no sound on that slide.

Note that the sound plays just fine if the presentation is saved as a .odp or .ppt file.
Comment 1 Cor Nouws 2011-12-28 15:08:28 UTC
Hi,

Thanks for reporting. I can confrim this.

Saving as PPT does preserve the attached sound
Saving as PPTX does not.

Trying to attach sound after reopnening the saved PPTX, does not seem to work ..

Better not save as PPTX is the solution :-) 
If opening works fine, we are already lucky, IMNSHO.
Comment 2 A (Andy) 2013-03-24 19:44:01 UTC
reproducible with LO 4.0.1.2 (Win7 Home, 64bit)

@Thorsten: Could this maybe be an issue for you?
Comment 3 vulcain 2014-01-30 11:11:06 UTC
Duplicate of bug 67544 ??
Comment 4 QA Administrators 2015-07-18 17:42:49 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2016-09-20 10:18:05 UTC Comment hidden (obsolete)
Comment 6 Phil Davis 2016-10-12 03:37:59 UTC
Tested and bug confirmed with LibreOffice 5.2.2.2 on Windows10.
After saving as PPTX, the sound selection in "slide transition" is still shown with the correct sound file.
But after closing and then re-opening the PPTX file, the sound selection shows "no sound".

Similarly, start with an Impress file:
1) Insert, "Audio or Video..."
2) Select an audio file (I selected an MP3 format Audio file)
3) The file shows as an embedded object on the slide
4) Save as PPTX
5) Play the slide show, the sound plays along with the relevant slide - good.
6) Close LibreOffice Impress
7) Open the PPTX file
The embedded sound object does not appear on the slide, and it does not play.

So it seems that embedded audio objects are not being saved into PPTX files.

Note: I received a PPTX file with embedded audio from an associate who uses MS PowerPoint. The embedded audio in the file was seen and played correctly with LibreOffice Impress. So Impress is capable of reading embedded audio in PPTX files.

I added some audio to other slides and it all worked for me in "real time". Then after saving, closing and re-opening, all the audio was gone - confirming my conclusion that embedded audio objects are not being saved to PPTX files.
Comment 7 Xisco Faulí 2016-10-25 11:25:15 UTC
*** Bug 103142 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2016-10-25 11:26:58 UTC
*** Bug 74379 has been marked as a duplicate of this bug. ***
Comment 9 Phil Davis 2017-05-11 15:28:18 UTC
Tested this again just now on V5.3.3.2 on Windows10
The problem is still the same as reported last year.
Comment 10 Michael Meeks 2017-10-02 08:04:06 UTC
IIRC you did some work wrt. preserving these Kendy (?) =)
Comment 11 uf1wfitd6bmi 2018-06-14 15:51:52 UTC
As of June 2018, the Bug still persists (Checked with V 6.0.4.2). Please Check (Hint: In the exported pptx file, there is missing the link to the "media" file in the slides file  AND the media file itself in the "media"-Folder within the odp-file)
Comment 12 Jan Holesovsky 2018-06-18 08:13:20 UTC
I've fixed the bug 106867 that was for videos, but the audio uses a different markup I'm afraid :-(
Comment 13 Jan Holesovsky 2018-06-18 08:17:53 UTC Comment hidden (obsolete)
Comment 14 Xisco Faulí 2018-06-19 13:25:40 UTC
(In reply to Jan Holesovsky from comment #13)
> To help solving this bug, can anyone attach a pptx presentation created in
> PowerPoint that has some sound? - so that we can implement the preservation
> of that...

What about attachment 93222 [details] from bug 74379 or the attachments in bug 103142 ?
Comment 15 Luke 2018-10-13 19:08:33 UTC
Created attachment 145684 [details]
Sample PPTX with animation and transition sound

This should play a wind as an animation and clapping as a transition.
Comment 16 Luke 2018-10-13 19:12:18 UTC
Created attachment 145685 [details]
PPT format correctly imported
Comment 17 Luke 2018-10-13 20:09:41 UTC
Plain inserted audio like attachment 145688 [details], already works for PPTX. We are missing the logic to tie it to the animations and transitions.
Comment 18 Commit Notification 2019-02-04 00:04:16 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/8a1321362a0229a25869e4e3d0422a5a51c5b5be%5E%21

tdf#44223 oox: import embedded media stream.

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2019-02-04 00:16:45 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/6b6c0b120f3275be6bd9dbb26480f8f1df355e00%5E%21

tdf#44223 allow slideshow to play embedded media.

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Luke 2019-02-04 18:43:24 UTC
Mark,
Looking good. Slide transition sounds and custom sounds are now imported. 

Still need to work on importing animation sound and the roundtrip so that the sounds can be opened in Powerpoint. Currently after a roundtrip, only custom sounds play in PowerPoint. Thanks Mark!
Comment 21 Commit Notification 2019-03-04 13:33:27 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d98d3e2a0bc087ec9157e8e32e9f0ea4207d36e2%5E%21

tdf#44223: Export the audio of effects and transitions.

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Luke 2019-03-05 02:38:27 UTC
Mark,
Getting there. Slide transition sounds are now roundtripping perfectly! And Animation sounds are now imported. However, when you roundtrip attachment 145684 [details], the animation sound,"wind.wav" is lost. 

Also, PowerPoint will not play the audio in the roundtripped version of attachment 145688 [details] (inserted custom audio).

Should I file a new bug report or you do want to continue to track them here?
Comment 23 Mark Hung 2019-03-06 11:12:32 UTC
(In reply to Luke from comment #22)
> Mark,
> Getting there. Slide transition sounds are now roundtripping perfectly! And
> Animation sounds are now imported. However, when you roundtrip attachment
> 145684 [details], the animation sound,"wind.wav" is lost. 
> 
> Also, PowerPoint will not play the audio in the roundtripped version of
> attachment 145688 [details] (inserted custom audio).
> 
> Should I file a new bug report or you do want to continue to track them here?

Hi Luke,

Yes, please open a new bug report for PowerPoint playing. It is also preferred to open new bug reports for different file types. I'll set this bug to resolve fixed.
Comment 24 Luke 2019-03-14 18:14:10 UTC
I reported the roundtrip Animation sounds problem under Bug 123909.

The issue with PowerPoint not playing roundtripped custom audio, will hopefully be fixed by Bug 120690.