Bug 106867 - Videos do not get saved when saving in PPTX, and invalid file produced
Summary: Videos do not get saved when saving in PPTX, and invalid file produced
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:6.0.0
Keywords: filter:pptx
: 80128 107028 (view as bug list)
Depends on:
Blocks: PPTX-Corrupted
  Show dependency treegraph
 
Reported: 2017-03-30 08:32 UTC by aoellerer
Modified: 2017-09-07 07:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
testpresentation (391.12 KB, application/vnd.oasis.opendocument.presentation)
2017-03-30 08:36 UTC, aoellerer
Details
testvideo (374.64 KB, video/mp4)
2017-03-30 08:37 UTC, aoellerer
Details
Test PPTX (created in PowerPoint) (665.92 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-08-17 22:29 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aoellerer 2017-03-30 08:32:56 UTC
Description:
I created an impress presentation with an included video, when I saved it as odp everything went normal, but when I saved it as pptx and reopened it the video was gone. This happened with mp4, mpeg and wmv

Steps to Reproduce:
1.Create Presentation with video
2.Save Presentation as pptx
3.Close Presentation
4.Open Presentation

Actual Results:  
Video is gone

Expected Results:
Video is still there as left


Reproducible: Always

User Profile Reset: No

Additional Info:
I tested it on newest fedora and ubuntu lts version.
It does not happen when saving to ppt


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 aoellerer 2017-03-30 08:36:18 UTC
Created attachment 132274 [details]
testpresentation
Comment 2 aoellerer 2017-03-30 08:37:00 UTC
Created attachment 132275 [details]
testvideo
Comment 3 Buovjaga 2017-03-30 09:06:51 UTC
Reproduced.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+ (x64)
Build ID: 8681bd32d778585fc0da8f42a77aeb58cbae4308
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-03-29_04:04:20
Locale: fi-FI (fi_FI); Calc: CL

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 4 Xisco Faulí 2017-04-08 20:12:37 UTC
*** Bug 107028 has been marked as a duplicate of this bug. ***
Comment 5 Aron Budea 2017-08-17 22:14:00 UTC
*** Bug 80128 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2017-08-17 22:29:20 UTC
Created attachment 135632 [details]
Test PPTX (created in PowerPoint)

Not only the video is not saved into PPTX, the file produced by LO is not a valid PPTX. Attaching a valid PPTX created in PP for testing.
Comment 7 Commit Notification 2017-09-06 12:47:04 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e64ebbb7ac530f82bf26a67fed0e1d22b254ff93

tdf#106867: Implement pptx export of AnimationNodeType::COMMAND.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-09-06 12:48:24 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2f07a533ed7b52fb0420e6f0a98f42019dcf185f

tdf#106867: Import target for commands in PPTX.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-09-07 05:01:56 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cbcffbaee204e9dfbdc2125dda73e36d77e9b844

tdf#106867: Export videos in PPTX.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2017-09-07 05:02:05 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d1159136ae25b437d874e0fba7f0f13651049b6

tdf#106867: Write also the extended markup to fully support embedded videos.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-09-07 05:03:25 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4aabc5164d2a0d84e22fb3f6f66e020a8df6899a

tdf#106867: Unit test for the export of embedded videos.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Jan Holesovsky 2017-09-07 07:25:48 UTC
Fixed now.