Bug 103248 - 100% CPU usage when creating new document after sleep
Summary: 100% CPU usage when creating new document after sleep
Status: RESOLVED DUPLICATE of bug 103126
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-15 17:47 UTC by Telesto
Modified: 2016-10-29 08:28 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Apple Instruments Time Profile (3.99 MB, application/zip)
2016-10-17 20:58 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-10-15 17:47:59 UTC
Description:
If my Macbook Air (tested with: Yosemite, El Capitan, MacOS Sierra) goes to sleep and i have plenty of writer documents opened (for example 14) with LO version 4.4.0.1 (or higher) (with a stored (stock) User Profile), on resume LibreOffice Writer will function normally until the point where I create a New Document. CPU will go up to 100% for one or more minutes depending on the number of opened documents and the used LO version; with the LO 5 a little bit worse than the LO 4.4 series. When the CPU spike ends everything is back to normal; opening a new documents will take a few seconds. The proces will repeat itself after every Mac nap.

The problem doesn't occur if:
- the affect LO version is used in the first run (no saved profile)
- in Yosemite, El Capitan, MacOS Sierra with Libreoffice 4.3.7.2 (and lower versions: not tested)
- in Mavericks

The affected system is a MacBook Air 11" Early 2014.

Steps to Reproduce:
1. Use a Mac with MacOS Yosemite, El Capitan, MacOS Sierr;  No user profile
2. Start LibreOffice Writer for the first time (to generate a user profile)
3. Close Libreoffice (CMD+Q)
4. Start Libreoffice Writer again
5. Create plenty blank documents (14 or more)
6. Put your computer to sleep (Choose Sleep from the Apple menu; Click Sleep after pressing the power key; Close the lid of a portable Mac)
7. Wait 10 seconds or more (just in case)
8. Wake Mac again
7. Enter password (security setting)
9. Create a new document (CMD + N) or click new document in the menu bar
10. A new document will show up, but isn't responding. CPU usage spikes to 100%.

Actual Results:  
LibreOffice is unresponsive and CPU usage is around 100% for one or more minutes depending on the number of opened documents.

Expected Results:
LibreOffice is responsive


Reproducible: Always

User Profile Reset: YES

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-10-17 20:58:04 UTC
Created attachment 128052 [details]
Apple Instruments Time Profile

Time Profile for opening a New Writer Document after sleep with 12 documents open before sleep
Comment 2 Alex Thurgood 2016-10-19 13:23:46 UTC
This has already recently been reported, I shall try and find it again.
Comment 3 Alex Thurgood 2016-10-19 13:25:10 UTC

*** This bug has been marked as a duplicate of bug 103126 ***