Bug 103126 - 100% usage when creating new document after sleep and OSX Dock in autohide mode
Summary: 100% usage when creating new document after sleep and OSX Dock in autohide mode
Status: RESOLVED DUPLICATE of bug 103571
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, regression
: 103248 112092 (view as bug list)
Depends on:
Blocks: MacOS-Performance
  Show dependency treegraph
 
Reported: 2016-10-11 16:05 UTC by Telesto
Modified: 2018-01-25 08:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Mac system report (58.50 KB, text/plain)
2016-10-11 16:13 UTC, Telesto
Details
Mac spindump (6.50 KB, text/plain)
2016-10-11 16:14 UTC, Telesto
Details
Screenshot Instrument Time Profiler results (393.51 KB, image/jpeg)
2016-10-19 16:09 UTC, Telesto
Details
Screenshot Instrument Time Profiler results (645.24 KB, image/png)
2016-10-19 18:54 UTC, Telesto
Details
Instruments Partial expanded memory allocation LO 5.2.2.2 with Sierra 10.12 (94.66 KB, text/csv)
2016-10-30 12:04 UTC, Telesto
Details
Instruments memory allocation LO 5.2.2.2 with Sierra 10.12 (3.44 MB, text/csv)
2016-10-30 13:11 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-10-11 16:05:27 UTC
Description:
When I create a New Writer Document at some point after my Macbook Air (MacOS Sierra Gold Master) did go to sleep with multiple writer-documents opened up (+/-12), at the moment the new document CPU usage pikes to 100% for +/- 5 minutes. 
After that everything is back to normal. I can create new Documents (without CPU spikes) as long as my Macbook didn't sleep again. 

Steps to Reproduce:
1. Use MacOS Sierra (maybe El Captain works to)
2. Start Libreoffice Writer
2. Create 12 blank documents
4. Put your computer to sleep (by choosing Sleep from the Apple menu)
3. Wake Mac again
4. Create a new document (CMD + N) or click new document in the menu bar
5. A new document will show up, but CPU usage pikes to 100%. 


Actual Results:  
100% CPU usage for 5 minutes

Expected Results:
100 CPU usage for few seconds


Reproducible: Always

User Profile Reset: NO

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-10-11 16:13:54 UTC
Created attachment 127949 [details]
Mac system report
Comment 2 Telesto 2016-10-11 16:14:53 UTC
Created attachment 127950 [details]
Mac spindump
Comment 3 Telesto 2016-10-11 19:19:20 UTC
My description is quite horrible; retry:
When I open a few writer documents (+/-12), and let the Macbook Air (MacOS Sierra Gold Master) go to sleep (suspend), on resume LibreOffice Writer will function normally until the point where I create a New Document. At that point CPU usage pikes to 100% for 1 or more minutes (sometimes 5), depending on the number of documents in use (and maybe their complexity?) After this CPU spike everything is back to normal, until the Macbook goes to sleep again.
Comment 4 Alex Thurgood 2016-10-12 07:38:26 UTC
(In reply to telesto from comment #0)
> Description:
> When I create a New Writer Document at some point after my Macbook Air
> (MacOS Sierra Gold Master) did go to sleep with multiple writer-documents
> opened up (+/-12), at the moment the new document CPU usage pikes to 100%
> for +/- 5 minutes. 
> After that everything is back to normal. I can create new Documents (without
> CPU spikes) as long as my Macbook didn't sleep again. 
> 
> Steps to Reproduce:
> 1. Use MacOS Sierra (maybe El Captain works to)
> 2. Start Libreoffice Writer
> 2. Create 12 blank documents
> 4. Put your computer to sleep (by choosing Sleep from the Apple menu)
> 3. Wake Mac again
> 4. Create a new document (CMD + N) or click new document in the menu bar
> 5. A new document will show up, but CPU usage pikes to 100%. 
> 
> 


No repro for me with Sierra OSX 10.12, Macbook Pro, core i7, 16Gb RAM and LO 5212.
Opened 12 blank Writer documents in succession, then put Mac to sleep. On waking Mac, I was asked for my password (security setting) which I entered, and then I immediately pressed CMd-N to open a new blank Writer document. No noticeable slow down or beach ball activity, the blank document was displayed virtually instantaneously.
Comment 5 Alex Thurgood 2016-10-12 07:42:37 UTC
No repro either using the same steps on Sierra OSX 10.12 Mac-mini mid-2010, Intel Core 2 Duo, 4Gb RAM.

Cmd-N to open a 13th blank document caused no noticeable slowdown and certainly no beach ball.
Comment 6 Alex Thurgood 2016-10-12 08:09:04 UTC
@telesto :

we almost certainly need more information about how to reproduce the problem. Please provide as much information as you can :

- hardware spec and screen/monitor hardware
- sample documents that trigger the problem
- network loaded files or local hard disk ?
- any anti-virus running in background (or other processor/memory hungry programs)?
- any accessibility tools running ?
Comment 7 Alex Thurgood 2016-10-12 08:09:42 UTC
@telesto :

Also try resetting your user profile and re-testing
Comment 8 Telesto 2016-10-12 11:40:40 UTC
@AlexThurgood
I think I found the specific cause of the problem.

Steps to Reproduce:
1. Use MacOS Sierra (maybe El Captain works to)
2. Open System Preferences from the Apple menu and choose “Dock”
3. Check the box for “Automatically hide and show the Dock” by clicking the checkbox next to it
4. Start Libreoffice Writer
5. Create 12 blank documents
6. Put your computer to sleep (by choosing Sleep from the Apple menu)
7. Wake Mac again
8. Create a new document (CMD + N) or click new document in the menu bar
9. A new document will show up, but isn't responding. CPU usage spikes to 100%.
Comment 9 Alex Thurgood 2016-10-12 13:04:33 UTC
I ahd to open 13 blank documents before I could reproduce the problem, but I can confirm this on

Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
Threads CPU : 2; Version de l'OS :Mac OS X 10.12; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group


@telestro : thanks for your help
Comment 10 Alex Thurgood 2016-10-12 13:05:52 UTC
This is similar to some of the other OSX-specific context-switching bugs.
Comment 11 Alex Thurgood 2016-10-19 13:25:10 UTC
*** Bug 103248 has been marked as a duplicate of this bug. ***
Comment 12 Telesto 2016-10-19 16:09:00 UTC
Created attachment 128074 [details]
Screenshot Instrument Time Profiler results
Comment 13 Telesto 2016-10-19 18:54:33 UTC
Created attachment 128080 [details]
Screenshot Instrument Time Profiler results
Comment 14 Telesto 2016-10-30 12:04:51 UTC
Created attachment 128357 [details]
Instruments Partial expanded memory allocation LO 5.2.2.2 with Sierra 10.12
Comment 15 Telesto 2016-10-30 13:11:15 UTC
Created attachment 128359 [details]
Instruments memory allocation LO 5.2.2.2 with Sierra 10.12
Comment 16 Alex Thurgood 2018-01-24 16:21:53 UTC
*** Bug 112092 has been marked as a duplicate of this bug. ***
Comment 17 Telesto 2018-01-25 08:39:50 UTC

*** This bug has been marked as a duplicate of bug 103571 ***