Bug Hunting Session
Bug 103273 - LibreOffice does not understand the resolution information of Photoshop Elements files
Summary: LibreOffice does not understand the resolution information of Photoshop Eleme...
Status: RESOLVED DUPLICATE of bug 52598
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-17 07:40 UTC by Dirk Munk
Modified: 2017-11-12 17:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of a Photoshop Elements jpg file (46.34 KB, image/jpeg)
2016-10-17 07:40 UTC, Dirk Munk
Details
dpi information in header (47.46 KB, image/png)
2017-11-12 17:26 UTC, Dirk Munk
Details
dpi information in header (47.40 KB, image/png)
2017-11-12 17:27 UTC, Dirk Munk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Munk 2016-10-17 07:40:24 UTC
Created attachment 128037 [details]
Example of a Photoshop Elements jpg file

I use Photoshop Elements to edit photos and other pictures, since LibreOffice is not meant for this kind of work, as is pointed out in the manuals.
Inserting a jpg file produced by Photoshop Elements however is always a pain, LibreOffice assumes the 96dpi resolution setting of my screen, and the picture usually has a 300dpi resolution setting. So I always get the wrong size of the picture, very annoying.
I recently inserted a jpg file from another source, and was amazed to see it had the right size, and LibreOffice reported a 360dpi resolution setting.
So it seems LibreOffice doesn't understand the resolution settings in the JPG file headers produced by Photoshop Elements.
I assume this is a general problem in LibreOffice, but for the record I'm experiencing the problem in Writer, and I'm using Photoshop Elements 14 on Windows 10 64 bit.
I have attached an example file.
Comment 1 Buovjaga 2016-10-28 19:24:55 UTC
Do you by any chance use this in PS Elements: File >  Export > Export As > JPG
Just found this thread about Export losing metadata as it is still a work in progress feature: https://forums.adobe.com/thread/2097485
Comment 2 Dirk Munk 2016-10-28 20:03:36 UTC
No, I've never used the export function, I only use the File > Save as function. When I open the example file again, it will show me the correct 300 dpi resolution, so the resolution information is in the file header.
Comment 3 Buovjaga 2016-10-28 20:19:45 UTC
Ok. I confirmed.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha1+
Build ID: 6dc8f25ecf676a2e4d1a1018b729fef4096df8e7
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on October 28th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 4 Dirk Munk 2017-02-12 12:40:31 UTC
Not much progress on solving this problem? It has to do with the way the headers of the file are handled. The proper information is there, but Libreoffice can't find it so to speak. Should be too difficult to fix......
Comment 5 Dirk Munk 2017-02-12 12:41:43 UTC
should = shouldn't of course :-)
Comment 6 Buovjaga 2017-02-12 12:50:22 UTC
Well, I don't know how to help.. maybe get involved in your local community https://www.facebook.com/libreofficenl/ (events etc.) and finally bribe some local developer with beers to fix it.
Comment 7 Dirk Munk 2017-02-12 16:45:26 UTC
I'm not saying you have to do this, but I suppose their are people responsible for this part of Libreoffice. I assume people or groups of people are responsible for certain parts of Libreoffice, in this case the handling of graphics.
Comment 8 Buovjaga 2017-02-12 16:49:34 UTC
(In reply to Dirk Munk from comment #7)
> I'm not saying you have to do this, but I suppose their are people
> responsible for this part of Libreoffice. I assume people or groups of
> people are responsible for certain parts of Libreoffice, in this case the
> handling of graphics.

No, nobody is responsible for anything. Responsibility only arises, if someone makes an offer to pay for a fix and a company accepts the offer.
Comment 9 Dirk Munk 2017-11-12 13:13:20 UTC
This is not a minor problem, this is a big problem. I found another bug report from 2012 where the same problem is reported. 

This problem prevents you from producing high quality documents. When a photograph has been edited with something like photoshop or an other similar program, you can not enter it in a Writer document in high resolution. Preparing books etc. becomes impossible!!

It is a minor problem for someone who has knowledge on graphics. Please fix it!!
Comment 10 Buovjaga 2017-11-12 16:28:40 UTC
(In reply to Dirk Munk from comment #9)
> This is not a minor problem, this is a big problem. I found another bug
> report from 2012 where the same problem is reported. 

What is this report?
Comment 11 Dirk Munk 2017-11-12 17:01:30 UTC
Bug 52598
Comment 12 Buovjaga 2017-11-12 17:05:37 UTC

*** This bug has been marked as a duplicate of bug 52598 ***
Comment 13 Dirk Munk 2017-11-12 17:26:03 UTC
Created attachment 137696 [details]
dpi information in header
Comment 14 Dirk Munk 2017-11-12 17:27:10 UTC
Created attachment 137697 [details]
dpi information in header
Comment 15 Dirk Munk 2017-11-12 17:34:41 UTC
I have added two information windows of IrFanView, showing detailed information about a jpg picture. The difference between the two is the the dpi setting, and the resulting change in print size in cm / inch. The picture itself wasn't changed at all, just the dpi setting. The problem is that Writer doesn't always understand the dpi setting, and replaces it by the dpi setting of the screen, resulting in a picture with the wrong size in the document. Changing the size of the picture in Writer will result in a low resolution picture, and that is not the intention.
Comment 16 Dirk Munk 2017-11-12 17:38:34 UTC
I don't mind if this bug is marked as a duplicate, but when I added a comment in the other bug, no one reacted. When I changed something here, I did get reactions.