Download it now!
Bug 103361 - Rendering bug with symbols misplacement
Summary: Rendering bug with symbols misplacement
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.1.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 103360 (view as bug list)
Depends on: HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-20 18:56 UTC by Fallen Phoenix
Modified: 2018-01-28 05:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
document with issue (29.13 KB, application/vnd.oasis.opendocument.text)
2016-10-20 18:58 UTC, Fallen Phoenix
Details
Screenshot of bad rendering in System::Object (6.22 KB, image/png)
2016-11-02 12:55 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fallen Phoenix 2016-10-20 18:56:17 UTC
You can see issue in the code sections of attached document, an article copy-pasted from CodeProject web-site. Character ":" sometimes draws in one cell together with next letter character.

First occurrence:
System::Object ^x = gcnew System::Object();

Screen shot: http://pic.imghost.pro/big/2016/1020/d0bfc12b296e8b60e9303b0f67b2dbaa_886418d093c07bbabef424cafd4f561e.png

It seems fixes if I create new document and copy-paste content into it, but if it happens, i think it still bug.
Comment 1 Fallen Phoenix 2016-10-20 18:58:24 UTC
Created attachment 128103 [details]
document with issue
Comment 2 Julien Nabet 2016-10-20 19:53:22 UTC
*** Bug 103360 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2016-11-02 12:55:03 UTC
I confirm. It sometimes renders OK, like if you zoom in and out.

Seems to render fine the first time on 5.0.2

The markup is:
<text:p text:style-name="P6">System::<text:span text:style-name="T15">Object</text:span> ^x = <text:span text:style-name="T13">gcnew</text:span> System::<text:span text:style-name="T15">Object</text:span>();</text:p>

Win 7 Pro 64-bit Version: 5.3.0.0.alpha1+
Build ID: 4b4abb73fcd7f2802e73102b3e7c30face8d309c
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: old; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-10-31_02:54:50
Locale: fi-FI (fi_FI); Calc: group

Versio: 5.0.2.2 (x64)
Käännöksen ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Maa-asetus: fi-FI (fi_FI)
Comment 4 Buovjaga 2016-11-02 12:55:43 UTC
Created attachment 128437 [details]
Screenshot of bad rendering in System::Object
Comment 5 Aron Budea 2016-12-17 05:12:37 UTC
Does this still occur with 5.3beta2?
Comment 6 Buovjaga 2016-12-17 10:37:53 UTC
Now I can't get the problem to appear.

Fallen Phoenix: can you test with 5.3 beta2? http://dev-builds.libreoffice.org/pre-releases/win/x86_64/LibreOfficeDev_5.3.0.0.beta2_Win_x64.msi

Set to NEEDINFO.
Change back to NEW, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Version: 5.4.0.0.alpha0+
Build ID: ba6b35fc68a01aff72b39eb7809bacb326068668
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-13_06:07:39
Locale: fi-FI (fi_FI); Calc: group
Comment 7 Fallen Phoenix 2016-12-17 11:54:14 UTC
I dont see that glitch in beta version, but there another simle rendering. If it possible to turn on normal ClearType support there?
Comment 8 Fallen Phoenix 2016-12-17 11:55:32 UTC
I dont see that glitch in beta version, but there another simle rendering. If it possible to turn on normal ClearType support there?
Comment 9 Buovjaga 2016-12-17 15:24:09 UTC
(In reply to Fallen Phoenix from comment #8)
> I dont see that glitch in beta version, but there another simle rendering.
> If it possible to turn on normal ClearType support there?

Please open a new reports for any other problems.

Maybe I will actually set this to FIXED as it seems to be because of the Harfbuzz engine.