Bug Hunting Session
Bug 103385 - Inconsistent measurement units in "Page" sidebar panel
Summary: Inconsistent measurement units in "Page" sidebar panel
Status: RESOLVED DUPLICATE of bug 129267
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Page Measurement-Units
  Show dependency treegraph
 
Reported: 2016-10-21 13:00 UTC by Dave Barton
Modified: 2019-12-10 10:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Inconsistent Margin Dimensions (5.93 KB, image/png)
2016-10-21 13:00 UTC, Dave Barton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Barton 2016-10-21 13:00:51 UTC
Created attachment 128127 [details]
Inconsistent Margin Dimensions

It's been 50+ years since I had to go through the mental gymnastics of converting antiquated imperial measurements into the international metric system.

Version: 5.3.0.0.alpha1 (x64)
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 8; OS Version: Windows 6.1; UI Render: default; 
Locale: en-AU (en_AU); Calc: group

Set locale units of measure to metric.
Open a Writer document and the new sidebar "Page" panel/deck.
By default my page size appears as A4 (21 x29.7 cm)
The margins selection list shows 3 imperial dimensions and some indeterminate dimension names.

Requests:
1) Recognize the user's locale and offer metric or imperial margin dimensions accordingly.
2) Give some definitive numeric meaning to dimension names such as "Narrow, Wide, etc." Better still, replace them with the actual dimensions that will be applied.
Comment 1 Thomas Hackert 2016-10-21 13:23:28 UTC
Hello Dave, *,
thank you very much for reporting this bug :)

I can confirm your bug with

OS: Debian Testing AMD64 (so setting "Hardware" to "All")
LO: Version: 5.3.0.0.alpha1
Build-ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU-Threads: 4; BS-Version: Linux 4.5; UI-Render: Standard; VCL: gtk2; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

, so setting the status to "New"

Have a nice afternoon
Thomas.
Comment 2 QA Administrators 2018-07-25 02:40:13 UTC Comment hidden (obsolete)
Comment 3 Caolán McNamara 2019-12-10 10:19:31 UTC

*** This bug has been marked as a duplicate of bug 129267 ***