Bug 103397 - Function TRANSPOSE misses an example
Summary: Function TRANSPOSE misses an example
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Joel Madero
URL: https://help.libreoffice.org/Calc/Arr...
Whiteboard: target:5.3.0
Keywords: difficultyBeginner, easyHack, skillDesign
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2016-10-22 00:03 UTC by Dennis Roczek
Modified: 2017-02-14 08:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Two screenshots related with transpose (16.17 KB, application/vnd.oasis.opendocument.graphics)
2016-10-26 14:32 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Roczek 2016-10-22 00:03:43 UTC
maybe selfexplanation, but... we do not list any example in that case. :-(
Comment 1 Joel Madero 2016-10-23 20:37:50 UTC
Really easy issue to resolve: http://opengrok.libreoffice.org/xref/help/source/text/scalc/01/04060107.xhp

Example can be based on any of the other examples in the same file.
Comment 2 Joel Madero 2016-10-25 04:28:13 UTC
I'm just about done with this.
Comment 3 Joel Madero 2016-10-26 03:06:04 UTC
Thoughts: http://imgur.com/a/oD3sU
Comment 4 Heiko Tietze 2016-10-26 14:32:00 UTC
Created attachment 128288 [details]
Two screenshots related with transpose

If you're looking for input from the design team you could CC the ux-advice mailing list; only skilldesign (that I was searching for) is not effective.

My two cents anyway: It took me a while to figure out what it means. Typically I transpose per paste special dialog and expect row and col exchanged. The image looks like a 5x3 matrix transposed to 3x5 and I couldn't follow. The reason to my misunderstanding is obviously that you add column headers (A...D) and row titles (1..x). If you mark those per grey background it is much easier to understand.
Regarding design I would make the columns a little bit wider, perhaps squared or use text. And an example with before/after with the formula at the connector is perfect, IMHO. Feel free to use or modify what I attached.

Regarding the text it is not necessary to have a range selected, at least this part is unclear and wouldn't be helpful for me. Most relevant information is to press shift+enter, however. And I wonder how to not lock the range after transposing it. Looks like only via copy/paste special, which could be stated in the help. (And lead to the enhancement request to have this option with the command.)
Comment 5 Commit Notification 2016-11-08 19:02:39 UTC
Joel Madero committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=578e1e320daaa82b2d3b8c0eeea84bf704967939

tdf#103397 - added example for Transpose function
Comment 6 jani 2016-11-11 11:46:35 UTC
Seems solved