Bug 103488 - Filesave: grey line that exists in master slide but is not visible on fileopen is wrongfully visible in slide when saved as PPTX
Summary: Filesave: grey line that exists in master slide but is not visible on fileope...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pptx
Depends on:
Blocks: 42753
  Show dependency treegraph
 
Reported: 2016-10-25 10:58 UTC by Timur
Modified: 2019-05-07 09:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example slide1.pptx (65.49 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-10-25 10:58 UTC, Timur
Details
Example slide1.PDF saved in MSO (154.38 KB, application/x-force-download)
2016-10-25 11:00 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2016-10-25 10:58:05 UTC
Description:
Looking at attachment 114355 [details] from Bug 90237, I extracted slide 1 here which has multiple filesave bugs. 
This bug is about another grey line which is added (in the upper half of the slide) when it's saved as PPTX and reopen (RT).

I notice that in OO, fileopen was very wrong, better but not good in LO 3.3. Somewhere around LO 3.5 fileopen went OK. Not a regression. Fileopen is OK now with 5.3 master, while filesave as pptx is still not correct. 

Steps to Reproduce:
1. Save as PPTX
2. Open in LO or MSO

Actual Results:  
another grey line added 

Expected Results:
only the original grey line present


Reproducible: Always

User Profile Reset: 

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Comment 1 Timur 2016-10-25 10:58:40 UTC
Created attachment 128239 [details]
Example slide1.pptx
Comment 2 Timur 2016-10-25 11:00:05 UTC
Created attachment 128240 [details]
Example slide1.PDF saved in MSO
Comment 3 Xisco Faulí 2016-10-25 11:19:58 UTC
Confirmed in

Version: 5.3.0.0.alpha0+
Build ID: 8974b0fafb18f9dd3f2c0e175a3255b80e4c249e
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

and

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 4 QA Administrators 2018-05-04 02:40:22 UTC Comment hidden (obsolete)
Comment 5 Timur 2018-05-04 14:53:58 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2019-05-05 03:30:25 UTC Comment hidden (obsolete)
Comment 7 Timur 2019-05-06 08:21:17 UTC
Repro 6.3+. 
Steps to Reproduce:
1. Open in LO attachment 128239 [details] PPTX
2. Save as PPTX
3. Open saved in LO or MSO and see another grey line
Comment 8 Regina Henschel 2019-05-06 12:57:25 UTC
The line exists in the original pptx file too. It is "Straight Connector 9" on "Retrospect Slide Master". That is the master slide, which is the base master slide in PowerPoint.
Comment 9 Timur 2019-05-07 09:32:27 UTC
Thank you. Filesave problem because line is wrongfully visible when RT PPTX opens either with LO or MSO.