Bug Hunting Session
Bug 90237 - Considerable loss of formatting of presentation created with PowerPoint
Summary: Considerable loss of formatting of presentation created with PowerPoint
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-25 21:38 UTC by Rogério Brito
Modified: 2016-10-25 16:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Document before changes in LibreOffice (5.43 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-03-25 21:38 UTC, Rogério Brito
Details
Document after changes in LO 4.4.2 (5.46 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-03-25 21:40 UTC, Rogério Brito
Details
Document after changes in LO 5.1+ nightly (5.46 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-06-18 17:05 UTC, Timur
Details
Document after only a "Save As" with LO 5.0 beta 3 (without touching it) (5.42 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-06-18 17:47 UTC, Rogério Brito
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rogério Brito 2015-03-25 21:38:44 UTC
Created attachment 114355 [details]
Document before changes in LibreOffice

Hi.

First of all, I am a super novice using Buzilla and I am sure that I filed this with the incorrect components/categories.

What I am using here is Debian's (experimental branch) version 1:4.4.2~rc1-1 on an amd64 computer (even though I suspect that the architecture may not be at fault here).

The actual bug report starts below.

--- 

I have to work with some people that all use Microsoft PowerPoint to create our presentations for our lectures. We are a team of a local University and I am apparently the only person of the team that uses a non-Windows setup (in fact, I don't even have Microsoft Office at my disposal).

When editing one of the presentations/lectures to fix errors, I unfortunately get a completely different looking document, even if I only delete a space in one of the pages.

I attach here both the "before" and the "after" documents, so that they can be compared.

I don't know if there is anything that I could do to workaround this issue so that I can continue with my work while LibreOffice improves.


Thanks for any help,

Rogério Brito.
Comment 1 Rogério Brito 2015-03-25 21:40:50 UTC
Created attachment 114356 [details]
Document after changes in LO 4.4.2
Comment 2 Rogério Brito 2015-03-25 21:46:26 UTC
Some additional information: I seem to recall that the first time I noticed this problem I was using Debian's prepackaged version of 4.3.x, before I tried upgrading to the version in the experimental branch (4.4.x).

Again, if there is any extra information that I can provide, please let me know.


Thanks,

Rogério Brito.
Comment 3 A (Andy) 2015-03-25 22:46:10 UTC
Reproducible with LO 4.4.1.2, Win 8.1

Steps to Reproduce:
1. Open the attached Before Presentation
2. Insert a space at any place in the subtitle of slide 1
3. Save this file as a pptx, close and reopen it


Result:

On all slides: 
- the red background colour is greyed
- above the red bar at the bottom the line colour is changed from red to blue
- a grey line is added in the upper half of the slides
- the background colours of all tables are changed

Slide 1:  
- the spacing of the title is changed from 0.5pt to 0.0pt (-> FORMAT -> CHARACTER -> tab POSITION)
- the spacing of the subtitle is changed from 2.0pt to 0.0pt
- the font size of the subtitle is changed from 16.7 to 24

Slide 2:
- on the left bar the line spacing is changed to 0.00cm (-> FORMAT -> PARAGRAPH -> tab INDENTS & SPACING)
- the numbering indent is changed
- a red bar at the bottom is added

Slide 3:
- the line spacing is changed to 0.00cm (-> FORMAT -> PARAGRAPH -> tab INDENTS & SPACING)

Slide 5:
- the indent of the text is changed
- the background colour of the formula is changed from red to blue
Comment 4 Timur 2015-05-11 17:06:06 UTC
Please bear in mind that it's highly unlikely that any bugs reported like this, "multiple problems with file", will be fixed.
Each issue should be reported separately, after a search for already reported bugs. If bugs don't exist, they should be reported separately, even if they happen with the same file. 
Bug also shouldn't be confirmed like this, one-for-all.
Please, test in recent versions such as LO 4.4.3.2 and current development version from http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/. 
Also, it should be determined for each problem whether it's fileopen (from pptx) or filesave (to pptx) problem.
Comment 5 Timur 2015-06-18 10:38:25 UTC
(In reply to A (Andy) from comment #3)
> Reproducible with LO 4.4.1.2, Win 8.1
I change back to Unconfirmed for more detailed bug triage.
Comment 6 Timur 2015-06-18 17:05:15 UTC
Created attachment 116632 [details]
Document after changes in LO 5.1+ nightly
Comment 7 Rogério Brito 2015-06-18 17:34:23 UTC
Dear Timur,

(In reply to Timur from comment #4)
> Please bear in mind that it's highly unlikely that any bugs reported like
> this, "multiple problems with file", will be fixed.

Sure, my report is not quite specific, I understand that. But I'm a little lost when filing the bug here, as I see that LibreOffice has many components and I don't really know where they belong.

Also, I'm not really sure if, say, changes in the size of the fonts is one separate bug from the change in the colors *or* if they are distinct bugs (among other things that happen with this document once we edit it).

> Please, test in recent versions such as LO 4.4.3.2

I can confirm that the problem exists with LO 4.4.4~rc1-1 (precompiled version from Debian's unstable distribution). I will test with LO 5.0 from Debian's experimental distribution.

> and current development version from
> http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/.

For my case, that would be:

http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@46-TDF/

(I don't have windows, fortunately or unfortunately).

> Also, it should be determined for each problem whether it's fileopen (from
> pptx) or filesave (to pptx) problem.

Opening doesn't seem to be a problem.

I have not tried saving the document without changing it (I can try it right now).

The problem does definitely appear when I change a single character (say, I insert a space in "PHP", producing "PH P" and then changing that back to "PHP") and save it.

In fact, at least with the versions that I tested, I don't really need to remove the character. Just keeping it as "PH P" and saving the document already changes the formatting a lot.

Which information more would be needed? I don't really know how to give more detailed/"atomic" instructions of when the loss of formatting happens, but I can surely try it.


Thanks a lot for your guidance,

Rogério Brito.
Comment 8 Rogério Brito 2015-06-18 17:46:15 UTC
Hi, Timur and others.

Some extra information below.

(In reply to Rogério Brito from comment #7)
> (In reply to Timur from comment #4)
> > Please, test in recent versions such as LO 4.4.3.2
> 
> I can confirm that the problem exists with LO 4.4.4~rc1-1 (precompiled
> version from Debian's unstable distribution). I will test with LO 5.0 from
> Debian's experimental distribution.

Just tested with LO 5.0 (actually, 5.0.0~beta3-1 from Debian's experimental) and simply invoking a "Save as...", *without* touching the document otherwise (not even a single character) already incurs in this considerable loss of formatting.

Once again, thanks for your help,

Rogério.
Comment 9 Rogério Brito 2015-06-18 17:47:29 UTC
Created attachment 116635 [details]
Document after only a "Save As" with LO 5.0 beta 3 (without touching it)
Comment 10 Timur 2015-06-18 17:52:21 UTC
It's quite OK to use Linux version from http://dev-builds.libreoffice.org/.
As I wrote, first it should be determined for each problem whether it's fileopen (from pptx) or filesave (so called roundtrip, to pptx) problem.
Then, if something is OK with that version (or vice versa) you may test with other version, such as LO 5.0 beta and 4.4.4 to see what was already backported and write it here.
Then, each remaining issue should be searched for in the already reported bugs. 
Only if not found, they should be reported separately, and changes in the size of the fonts is a separate from changes in the colors etc.
Comment 11 tommy27 2015-08-11 06:03:44 UTC
@Rogerio
please follow Timur advices and post separate bug report for each of the issues you find in that file (after a search for potential duplicates)
and post links of the new bugs in the See Also field

so set status to NEEDINFO
Comment 12 Xisco Faulí 2016-10-10 11:25:43 UTC Comment hidden (obsolete)
Comment 13 Rogério Brito 2016-10-24 20:19:10 UTC
Hi, people.

I sincerely don't know what else to provide as information about this problem.

The steps that I follow are simply:

1 - download the first document that I attached (which I labeled as "Document before changes in LibreOffice")
2 - open it with Impress
3 - just save as with another name
4 - click that you want to keep it in Microsoft's format <--- this is a critical step
5 - close the original document
6 - open the copy that you saved as

You will see that a lot of things have changed. Fortunately, I discovered this before I had people complaining at me.

To be more precise, I don't know how to dump the data structures that libreoffice read from the original document (while things were in memory) and dump what those data structures contain right before they hit the disc.

I note here that a step that is important to give me the loss of formatting that I'm seeing is telling LibreOffice to keep the document in Microsoft's pptx format (step 4).

For completeness, I am using Debian's version 1:5.2.2~rc2-2 on an amd64 computer, but I have seen this bug since before I reported it.

Please, *do* help me get a better bugreport, since the issue is so macro that I don't know how to break it into smaller pieces.


Thanks,

--
Rogério Brito : rbrito@{ime.usp.br,gmail.com} : GPG key 4096R/BCFCAAAA
http://cynic.cc/blog/ : github.com/rbrito : profiles.google.com/rbrito
DebianQA: http://qa.debian.org/developer.php?login=rbrito%40ime.usp.br
Comment 14 Rogério Brito 2016-10-24 20:23:17 UTC
Since I could detect that the problem occurs when I use Microsoft's format (but not ODF), I decided to go ahead and change the status of the bug to UNCONFIRMED from NEEDINFO, as mentioned by the instructions when submitting the previous comment.

I hope that I didn't make anything wrong.
Comment 15 Timur 2016-10-25 11:01:59 UTC
Rogério, no need to comment further as you don't add new value. 
This bug should not be confirmed and should be marked as Invalid. 
But, triaging it may open some new bugs, as I did for Bug 98650 and Bug 103488. 
Problem is that there are many similar problems with colors, indent, and so on.
Comment 16 Timur 2016-10-25 13:00:46 UTC
Color seems to be in Bug 103478. I'll report text size also. 
And so on. I close as Invalid. Further bug reports are welcomed to "See Also", but only after the search.
Comment 17 Timur 2016-10-25 15:15:18 UTC
On all slides: 
- the red background colour is greyed -> Bug 103478
- above the red bar at the bottom the line colour is changed from red to blue -> Bug 103478 
- a grey line is added in the upper half of the slides -> Bug 103488
- the background colours of all tables are changed -> ? looks OK to me

Slide 1:  
- the spacing of the title is changed from condensed 0.5pt to 0.0pt (-> FORMAT -> CHARACTER -> tab POSITION) -> ? looks OK to me
- the spacing of the subtitle is changed from expanded 2.0pt to 0.0pt -> ? looks OK to me, with spacing 2pt
- the font size of the subtitle is changed from 16.7 to 24 -> Bug 95953 

Slide 2:
- on the left bar the line spacing is changed from before 12pt and after 2pt to 0.00cm (-> FORMAT -> PARAGRAPH -> tab INDENTS & SPACING) -> didn't search so far
- the numbering indent is changed -> bullet indent? looks OK to me
- a red bar at the bottom is added ->  ? looks OK to me

Slide 3:
- the line spacing is changed to 0.00cm (-> FORMAT -> PARAGRAPH -> tab INDENTS & SPACING) -> didn't search, same as in slide 2

Slide 5:
- the indent of the text is changed -> that's Bug 98650
- the background colour of the formula is changed from red to blue -> again Bug 103478, color in shape