Bug Hunting Session
Bug 80340 - FILEOPEN: Table changes format in PPTX format
Summary: FILEOPEN: Table changes format in PPTX format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other All
: medium normal
Assignee: Yogesh Bharate
URL:
Whiteboard: BSA target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-21 18:23 UTC by Christian
Modified: 2015-05-12 09:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
the original PPT file (94.06 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-06-21 18:23 UTC, Christian
Details
this shows how the file appears in LO after change text height, save and re-openeing (156.37 KB, image/png)
2014-06-21 18:25 UTC, Christian
Details
this is how it should look like (167.42 KB, image/png)
2014-06-21 18:26 UTC, Christian
Details
this is how it shows up in LO after opening (no changes) (142.45 KB, image/png)
2014-06-21 18:26 UTC, Christian
Details
this is the LO saved (broken) file (32.07 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2014-06-21 18:27 UTC, Christian
Details
testcase RT file open in LO (278.36 KB, image/png)
2015-03-24 06:52 UTC, Yogesh Bharate
Details
preview of testcase file saved and open in LO 5.0 (63.78 KB, image/png)
2015-05-11 14:08 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2014-06-21 18:23:09 UTC
Created attachment 101499 [details]
the original PPT file

Problem description: 
When a pptx is saved and is later opened the format of a embedded table changed. The background color is wrong and the text height is wrong.
Steps to reproduce:
1. open testcase.pptx
2. select the empty cells in the embedded table
3. change text height to 8pt
4. save as .pptx
5. open file again


Current behavior:
6. => the format of the table changed to blue background

Expected behavior:
- the format should not change after save and re-open again
- when openeing the first time the text hight in the first row is wrong, too. Compare with in_MS_PPT.png
Operating System: Fedora
Version: 4.2.4.2 release
Comment 1 Christian 2014-06-21 18:25:30 UTC
Created attachment 101500 [details]
this shows how the file appears in LO after change text height, save and re-openeing
Comment 2 Christian 2014-06-21 18:26:10 UTC
Created attachment 101501 [details]
this is how it should look like
Comment 3 Christian 2014-06-21 18:26:49 UTC
Created attachment 101502 [details]
this is how it shows up in LO after opening (no changes)
Comment 4 Christian 2014-06-21 18:27:21 UTC
Created attachment 101503 [details]
this is the LO saved (broken) file
Comment 5 Christian 2014-06-21 18:30:07 UTC
Comment on attachment 101500 [details]
this shows how the file appears in LO after change text height, save and re-openeing

note the blue background in the tabel cells!
Comment 6 Tim Lloyd 2014-06-24 08:32:57 UTC
Confirmed. Fedora 20 and 4.2.5.2

Opened Christian's original document (the first link in this report) and selected all empty cells on the left of the text (ie. under "Key Activity"). I changed text height to 8pt as advised.

Save, close, reopen. ALL cells in the table have a blue background and I note that the column numbers 10-14 are displayed differently - 1 on top of 0, 1 on top of 1, etc.
Comment 7 Timur 2014-11-11 21:20:44 UTC
Looks like a duplicate of Bug 62255. But there are more details here. Please verify.
Comment 8 A (Andy) 2015-03-20 18:08:10 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 9 Yogesh Bharate 2015-03-23 12:29:50 UTC
*** Bug 48047 has been marked as a duplicate of this bug. ***
Comment 10 Yogesh Bharate 2015-03-24 06:52:17 UTC
On Latest build of LibreOffice on Ubuntu.
- the table background color did not changes to blue when we open the roundtripped file in LO.

Build ID :
Version: 4.5.0.0.alpha0+
Build ID: ed877b582473ebd7d0a7f8cb346eee2756c58032
Locale: en_IN

- PFA screenshot of roundtrip file open in LO.
(File name - RT-File-Open-in-LO.png)

- After RT, table border is loss, we will create separate issues for this (export issue).
Comment 11 Yogesh Bharate 2015-03-24 06:52:49 UTC
Created attachment 114293 [details]
testcase RT  file open in LO
Comment 12 Timur 2015-05-11 14:08:02 UTC
Created attachment 115496 [details]
preview of testcase file saved and open in LO 5.0

Please bear in mind that it's highly unlikely that any bugs reported like this, "multiple problems with the file", will be fixed.

AFAIK, here we have:
- table background changed to blue: duplicate of Bug 62255, seems like fixed in 5.0;
- table content wasn't properly displayed, probably due to narrow column width: also seems like fixed in 5.0;
- table border lost: Yogesh wrote he would create a separate issue for this, which is fine (but please write the new bug number here or in See also);
- row hight too big: either an existing or a new bug.

I kindly ask to report each issue separately, after a search for already reported bugs.
Please check listed bugs for updated information on specific problems. 

(In reply to Yogesh Bharate from comment #9)
> *** Bug 48047 has been marked as a duplicate of this bug. ***
This is not correct for 2 reasons:
- later bug should be marked as a duplicate of an earlier bug;
- that bug is also "multiple problems" bug, and should be marked as "WorksForMe" in this case, if some issues are solved and remaining issues are reported separately.
Comment 13 Timur 2015-05-11 15:10:45 UTC
- table border lost: Yogesh already fixed that in Bug 90190 and Bug 90672 - very nice.
- row hight too big: looks like a duplicate of Bug 48047.

I suggest this bug be closed as "WorksForMe" and, as written, listed bugs checked for updated information on specific problems.
Comment 14 Timur 2015-05-11 17:16:50 UTC
Finally, here we have:
- table background changed to blue: duplicate of Bug 62255, seems like fixed in 5.0;
- table content wasn't properly displayed, probably due to narrow column width: also seems like fixed in 5.0, probably by Yogesh in Bug 90223;
- table border lost: Yogesh already fixed that in Bug 90190 and Bug 90672 - very nice.
- row hight too big: looks like a duplicate of Bug 48047.

I'll mark as "WorksForMe" because some issues are solved in the current development version from http://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/. 
Remaining issues are reported separately and listed bugs should be checked for updated information on specific problems.
Comment 15 Commit Notification 2015-05-12 09:27:28 UTC
yogesh.bharate001 committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4f2c8194f485b1527fb4f4dfe23ce804937f1f9c

tdf#80340: Table changes format in PPTX format

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.