Bug 136956 - CRASH: Undoing merge cell
Summary: CRASH: Undoing merge cell
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.3 target:7.0.6
Keywords: haveBacktrace
Depends on:
Blocks: ImpressDraw-Tables Undo-Redo
  Show dependency treegraph
 
Reported: 2020-09-22 14:59 UTC by Xisco Faulí
Modified: 2021-04-11 19:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: crashreport.libreoffice.org/stats/crash_details/5ff699f6-8648-411a-b5ac-0eba090ae998


Attachments
bt with debug symbols (8.57 KB, text/plain)
2020-10-02 20:09 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-09-22 14:59:58 UTC
Steps to reproduce:
1. Open Impress
2. Insert a table ( the whole table is selected )
3. Merge Cells
4. Undo

-> Crash

reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 121771e37f7e2de41cd5643475861062bf25627b
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-09-22 15:00:28 UTC
Also reproduced in

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)
Comment 2 MM 2020-09-22 17:54:05 UTC
Confirmed on windows 10 x64 with Version: 6.4.6.2 (x64)
Build ID: 0ce51a4fd21bff07a5c061082cc82c5ed232f115
CPU threads: 12; OS: Windows 10.0 Build 19041; UI render: default; VCL: win

crashreport.libreoffice.org/stats/crash_details/5ff699f6-8648-411a-b5ac-0eba090ae998
Comment 3 Timur 2020-09-23 10:14:23 UTC
No repro LO 4.4.0. 
(Xisco, you may have already known that, not sure why not marked regression, please make sure that it you write "Repro in 5.0" if it means "no repro in 4.4", or you didn't test further.)
Crash is critical. Not usually used, but High for regression.
Comment 4 Timur 2020-09-23 10:29:46 UTC
One tedious bibiset in 5.0.

d0f5b98dd1dbbec35c5d8c01b0c92ba6edb96c53 is the first bad commit
Date:   Wed May 27 22:59:00 2015 +0800

    source-hash-4f2c8194f485b1527fb4f4dfe23ce804937f1f9c
    previous source-hash-7ff58e1a8965606a9fb45153a377b84593746420
    
    commit 4f2c8194f485b1527fb4f4dfe23ce804937f1f9c
    Author:     yogesh.bharate001 <yogesh.bharate@synerzip.com>
    AuthorDate: Fri Mar 20 20:37:52 2015 +0530
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Tue May 12 09:26:38 2015 +0000
    
        tdf#80340: Table changes format in PPTX format
    
        Problem:
        - If the PPTX contains embedded table i.e copied from excel, when we open it in
        impress it row height increase due to this table format changes.
        - Table contents empty row i.e without text, then row height increase because
        text height is added also added for empty row.
    
        Solution:
        - Added check whether row contents text or not.

Single commit. 
synerzip is not active anymore.
Comment 5 Timur 2020-09-23 10:34:57 UTC
Interesting that Xisco fixed bug 91762, regression from the same commit.
Comment 6 Xisco Faulí 2020-10-02 08:46:03 UTC
I don't think this is a regression from the commit mentioned. In previous versions like

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

LibreOffice also crashes if redoing the undo.

Besides, the fix in https://cgit.freedesktop.org/libreoffice/core/commit/?id=4f2c8194f485b1527fb4f4dfe23ce804937f1f9c was reverted in https://cgit.freedesktop.org/libreoffice/core/commit/?id=13d4398820ded5914f635757865e258db2db2b57.
Still crashing if both commit are reverted
Comment 7 Julien Nabet 2020-10-02 20:09:04 UTC
Created attachment 166046 [details]
bt with debug symbols

Here's a bt retrieved on pc Debian x86-64 with master sources updated today.
Comment 8 Aron Budea 2020-10-14 02:43:13 UTC
(In reply to Xisco Faulí from comment #6)
> LibreOffice also crashes if redoing the undo.
Already in 3.3.0.
Comment 9 Commit Notification 2021-03-16 14:25:07 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f3f7cc53efda828af8897fa45fa2a8f18cf3b48b

tdf#136956 reorder undo actions in removeColumns

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-03-17 10:01:47 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/eeeb3a422e25c22201e1325154f1913df3942f2a

tdf#136956 reorder undo actions in removeColumns

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2021-03-17 20:23:08 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d47afb54ed3e37be7216b5f2e3943f1ab7bdb84f

tdf#136956 reorder undo actions in removeColumns

It will be available in 7.0.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2021-03-23 08:06:19 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5262a9e88037decc26da84e7fa62f2955d4cdb85
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Mark Hung, thanks for fixing this issue!! I'll create a follow-up ticket for the incorrect table size after undo. Closing as VERIFIED FIXED
Comment 13 Xisco Faulí 2021-03-23 08:12:22 UTC
(In reply to Xisco Faulí from comment #12)
> @Mark Hung, thanks for fixing this issue!! I'll create a follow-up ticket
> for the incorrect table size after undo. Closing as VERIFIED FIXED

Done in bug 136956