Download it now!
Bug 136949 - It shows unnessesary border lines in Impress table's merged cells
Summary: It shows unnessesary border lines in Impress table's merged cells
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2020-09-22 08:58 UTC by Roman Kuznetsov
Modified: 2020-09-24 08:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (21.33 KB, application/vnd.oasis.opendocument.presentation)
2020-09-22 08:59 UTC, Roman Kuznetsov
Details
Screenshot with a problem (left - 7.0, right - 7.1) (28.72 KB, image/png)
2020-09-22 09:04 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2020-09-22 08:58:09 UTC
Description:
It shows unnessesary border lines in Impress table's merged cells

Steps to Reproduce:
1. Open file from attach in 7.1 version
2. Look at merged cells with text "Выравнивание в ячейке" (see a screenshot)


Actual Results:
It shows unnessesary border lines in Impress table's merged cells

Expected Results:
It doesn't show unnessesary border lines in Impress table's merged cells


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 52a49f9e480ca03e231cfda82640a928393131c9
CPU threads: 4; OS: Windows 10.0 Build 18362; UI render: default; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded
Comment 1 Roman Kuznetsov 2020-09-22 08:58:40 UTC
No repro in 7.0.0.1 => regression
Comment 2 Roman Kuznetsov 2020-09-22 08:59:08 UTC
Created attachment 165761 [details]
Example file
Comment 3 Roman Kuznetsov 2020-09-22 09:04:42 UTC
Created attachment 165762 [details]
Screenshot with a problem (left - 7.0, right - 7.1)
Comment 4 Roman Kuznetsov 2020-09-22 09:06:05 UTC
It doesn't matter enabled/disabled Skia
Comment 5 Timur 2020-09-22 09:24:11 UTC
8fe5819bdd2b9e578e0b49ae5778aafe19666476 is the first bad commit
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Jul 29 23:21:22 2020 +0200

    source sha:2b19cd84f10552c438dace0a4c52a70ccd440369
    previous source sha:5ad17c85dc93973c0cbb1d633b9eed144f0677de

commit	2b19cd84f10552c438dace0a4c52a70ccd440369	[log]
author	nd101 <Fong@nd.com.cn>	Sat May 09 11:45:25 2020 +0800
committer	Miklos Vajna <vmiklos@collabora.com>	Wed Jul 29 12:03:34 2020 +0200
tree	8aa6e793074cf336b115f4c06f543aacb92e4cf5
parent	5ad17c85dc93973c0cbb1d633b9eed144f0677de [diff]

tdf#115753 fix table border missing when there are merged cells
Comment 6 Timur 2020-09-22 09:27:29 UTC
Without looking at code, based on https://bugs.documentfoundation.org/show_bug.cgi?id=115753#c7, looks like it should be reverted and that bug reopen.
Comment 7 Timur 2020-09-22 09:54:47 UTC Comment hidden (obsolete)
Comment 8 Xisco Faulí 2020-09-22 10:05:27 UTC
(In reply to Timur from comment #7)
> Xisco, this is a major issue. Without further ado, please revert now. 
> Another steps: make a table, merge some cells - you can't, seen if you try
> to set borders.

This is only happening in master, please be patient and give some room to the developer to fix it. if the status is the same in 2 months, then we can consider to revert it
Comment 9 Timur 2020-09-22 10:22:42 UTC
This is not Normal importance per Description but High per Comment 7 because merge cannot be used at all in table.
Comment 10 Xisco Faulí 2020-09-22 15:05:46 UTC
(In reply to Timur from comment #9)
> This is not Normal importance per Description but High per Comment 7 because
> merge cannot be used at all in table.

oh right, so merge cells no longer works in Impress.
1. Open impress
2. Insert a table
3. select 2 cells
4. Merge cells

-> Nothing happens
Comment 11 Roman Kuznetsov 2020-09-22 15:11:24 UTC
(In reply to Xisco Faulí from comment #10)
> (In reply to Timur from comment #9)
> > This is not Normal importance per Description but High per Comment 7 because
> > merge cannot be used at all in table.
> 
> oh right, so merge cells no longer works in Impress.
> 1. Open impress
> 2. Insert a table
> 3. select 2 cells
> 4. Merge cells
> 
> -> Nothing happens

You are wrong. Cell merging works, you just still can see border between it. Look at my screenshot and you'll see that a text is aligned in merged cells and border is above the text
Comment 12 Xisco Faulí 2020-09-22 15:17:47 UTC
yep, you are right, it's fine when exported and reopened in MSO or an older version of LibreOffice
Comment 13 Xisco Faulí 2020-09-22 16:45:38 UTC
Proposal for a revert in https://gerrit.libreoffice.org/c/core/+/103187
Comment 14 nd101 2020-09-23 03:09:19 UTC
(In reply to Roman Kuznetsov from comment #11)
> (In reply to Xisco Faulí from comment #10)
> > (In reply to Timur from comment #9)
> > > This is not Normal importance per Description but High per Comment 7 because
> > > merge cannot be used at all in table.
> > 
> > oh right, so merge cells no longer works in Impress.
> > 1. Open impress
> > 2. Insert a table
> > 3. select 2 cells
> > 4. Merge cells
> > 
> > -> Nothing happens
> 
> You are wrong. Cell merging works, you just still can see border between it.
> Look at my screenshot and you'll see that a text is aligned in merged cells
> and border is above the text

Thanks for submitting the bug. We will investigate.
Comment 15 Commit Notification 2020-09-23 11:18:06 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7ccd8928acbb5a27d9b9f44b09b7575757981e8a

tdf#136949: Revert "tdf#115753 fix table border missing when there are merged cells"

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2020-09-24 08:24:08 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1e0ac737e620a6a3e5c54021c77f299e89e3a9ef

tdf#136949: sd_layout_tests: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.