Bug 115753 - FILEOPEN: PPT: Some borders are missing on tables
Summary: FILEOPEN: PPT: Some borders are missing on tables
Status: RESOLVED DUPLICATE of bug 135843
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, filter:ppt, regression
Depends on:
Blocks: Regressions-borderline
  Show dependency treegraph
 
Reported: 2018-02-15 16:33 UTC by Xisco Faulí
Modified: 2022-03-03 09:09 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sample (14.50 KB, application/vnd.ms-powerpoint)
2018-02-15 16:33 UTC, Xisco Faulí
Details
sample 2 (11.00 KB, application/vnd.ms-powerpoint)
2018-02-15 16:33 UTC, Xisco Faulí
Details
comparison MSO 2010 and LibreOffice 6.1 (9.25 KB, image/png)
2018-02-15 16:34 UTC, Xisco Faulí
Details
The first example file in 7.3 bibisect master (59.45 KB, image/png)
2022-03-03 09:07 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-02-15 16:33:03 UTC
Created attachment 139926 [details]
sample

Steps to reproduce:
1. Open attached document

Observed behaviour: Some borders are missing. See attached image

Reproduced in

Version: 6.1.0.0.alpha0+
Build ID: 48d3ff5c498f8f186d4ee72871af379010403442
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2018-02-15 16:33:47 UTC
Created attachment 139927 [details]
sample 2

another file affected by the same problem
Comment 2 Xisco Faulí 2018-02-15 16:34:33 UTC
Created attachment 139928 [details]
comparison MSO 2010 and LibreOffice 6.1
Comment 4 Armin Le Grand 2018-10-27 17:25:29 UTC
Cannot really see the PPt files, MSPpt does not load neither repair them. Where are they from, created with which program?
Looks the same (bad) in 6.1, but better in 5.4. Will need to have a look, mode data import and creation should not have changed at all, my changes only modified the visualization.
Comment 5 QA Administrators 2019-10-28 03:29:55 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2019-10-28 10:11:39 UTC
Still reproducible in

Version: 6.4.0.0.alpha1+
Build ID: c4d760b9edf0399955d30a0dfbe5f7b1b1ed37cb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 nd101 2020-05-06 08:24:08 UTC
Commenting out a single line of code in viewcontactoftableobj.cxx with comment of "if merged, set so at CellBorderArray ..." seems to fix the problem. I will submit a patch for review
Comment 9 Commit Notification 2020-07-29 10:04:03 UTC
nd101 committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2b19cd84f10552c438dace0a4c52a70ccd440369

tdf#115753 fix table border missing when there are merged cells

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2020-08-10 09:33:44 UTC Comment hidden (obsolete)
Comment 11 Commit Notification 2020-09-23 11:18:13 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7ccd8928acbb5a27d9b9f44b09b7575757981e8a

tdf#136949: Revert "tdf#115753 fix table border missing when there are merged cells"

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Roman Kuznetsov 2020-10-02 12:50:49 UTC
set back to NEW
Comment 13 Gabor Kelemen (allotropia) 2022-03-03 09:07:44 UTC
Created attachment 178628 [details]
The first example file in 7.3 bibisect master

The borders appear correctly in 7.3 since:

https://git.libreoffice.org/core/+/35b179b88330e1e94980192c598f23661e2757f9

commit 35b179b88330e1e94980192c598f23661e2757f9	[log]
author	Gülşah Köse <gulsah.kose@collabora.com>	Wed Jan 05 13:03:14 2022 +0300
committer	Xisco Fauli <xiscofauli@libreoffice.org>	Tue Jan 11 09:56:07 2022 +0100

tdf#135843 Fix the missing border handling

Also works correctly with the second example file.
Comment 14 Gabor Kelemen (allotropia) 2022-03-03 09:09:07 UTC
Thanks 	Gülşah for fixing this!

*** This bug has been marked as a duplicate of bug 135843 ***