Bug 103496 - Exporting as PDF a 1-bit image corrupts the image
Summary: Exporting as PDF a 1-bit image corrupts the image
Status: RESOLVED DUPLICATE of bug 103051
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-10-25 14:26 UTC by mail
Modified: 2016-12-29 15:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Uncorrupted image in BMP file (14.26 KB, image/bmp)
2016-10-25 14:28 UTC, mail
Details
Uncorrupted image in LibreOffice Writer file (10.36 KB, application/odt)
2016-10-25 14:29 UTC, mail
Details
Corrupted image in PDF file (2.09 KB, application/pdf)
2016-10-25 14:30 UTC, mail
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mail 2016-10-25 14:26:08 UTC
Description:
I have a 1-bit (that is with color depth of 1 bit per pixel) bitmap image inside a document in LibreOffice Writer, I export the document as a PDF file, I open the PDF file and the image is corrupted.

Steps to Reproduce:
1. Create a 1-bit image.
2. Insert the image in a document in LibreOffice Writer.
3. Export the document as a PDF file.
4. Open the PDF file and see that the image is corrupted.

Actual Results:  
Image corrupted.

Expected Results:
Imaged uncorrupted.


Reproducible: Always

User Profile Reset: No

Additional Info:
I can provide example files.


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 mail 2016-10-25 14:28:28 UTC
Created attachment 128249 [details]
Uncorrupted image in BMP file
Comment 2 mail 2016-10-25 14:29:42 UTC
Created attachment 128250 [details]
Uncorrupted image in LibreOffice Writer file
Comment 3 mail 2016-10-25 14:30:55 UTC
Created attachment 128251 [details]
Corrupted image in PDF file
Comment 4 Julien Nabet 2016-10-25 15:18:22 UTC
I'm pretty sure it's a dup.
You can wait for 5.2.4 or give a try to a daily master (see http://dev-builds.libreoffice.org/daily/master/)

*** This bug has been marked as a duplicate of bug 103051 ***
Comment 5 Antonio Faoro 2016-12-29 15:24:04 UTC
*** Bug 104961 has been marked as a duplicate of this bug. ***