Download it now!
Bug 103569 - Export: PDF File name not Saved Properly
Summary: Export: PDF File name not Saved Properly
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2016-10-29 05:01 UTC by wcmozart
Modified: 2016-10-29 10:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wcmozart 2016-10-29 05:01:28 UTC
Description:
I generate a PDF file from Writer. I open the pdf file for viewing [or it is automatically opened]. The File name is NOT displayed in the document TAB ; instead the name of the template file used in creating the document is displayed in the document TAB ; I have to go into the PDF file's 'Document Properties', 'Document Info' panel and RESET the document's TITLE to get the proper file name to display in the PDF tab

Steps to Reproduce:
1.produce a file in Writer using a template, and export to pdf
2.open pdf in a pdf-viewer
3.look at the name in the document's tab which is displayed in the pdf viewer
4. this should be the same as the documents file name
5 the name appearing is the name of the template used for the file

Actual Results:  
see above

Expected Results:
the name in the documents tab should be the documents file name 


Reproducible: Always

User Profile Reset: No

Additional Info:
this is an extremely annoying bug since it makes it impossible to have more than one pdf file open for viewing in any pdf viewer since ALL OPEN FILES will have the SAME name in the document TAB .. this error is also present in OpenOffice [has the same code base, almost] .. it necessitates going in and changing the title of EVERY PDF FILE one produces


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2783.2 Safari/537.36 OPR/40.0.2296.0 (Edition developer)
Comment 1 Xisco Faulí 2016-10-29 09:34:40 UTC
Confirmed in

Version: 5.3.0.0.alpha1
Build ID: f4ca1573fcf445164c068c1046ab5d084e1b005f
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Cor Nouws 2016-10-29 10:01:13 UTC
Hi, this is by design - it displays the document property Title (File > Properties..)