Download it now!
Bug 103586 (RESOLVED-WORKSFORME) - Assigning shortcuts to macro in context LibreOffice (not a module) does not work anymore
Summary: Assigning shortcuts to macro in context LibreOffice (not a module) does not w...
Status: RESOLVED WORKSFORME
Alias: RESOLVED-WORKSFORME
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2016-10-30 14:36 UTC by AndreHasekamp
Modified: 2018-03-15 14:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Macro to illustrate the problem (275 bytes, text/plain)
2016-10-30 14:36 UTC, AndreHasekamp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description AndreHasekamp 2016-10-30 14:36:07 UTC
Created attachment 128361 [details]
Macro to illustrate the problem

For several months now, shortcuts to macro activation do not work anymore. Quite annoying.

In Bugzilla I could not find this bug. Bug 103297 looks somewhat similar, but I am talking about LibreOffice documents, not Microsoft .doc documents. Strange that this bug has not been reported yet. Now, with the latest ArchLinux LibreOffice still 5.1.6.2.0+ (5.1.6.2 ArchLinux build-1) just released and the problem not solved, I write this bug report. Of course the problem might only occur under ArchLinux, it might not happen under another Linux distribution or Windows, but I can only verify under ArchLinux, updated until the moment this bug was submitted.

With this bug report I have included an extremely simple macro to illustrate. Please install it and assign a shortcut as follows:

Tools | Customize | press LibreOffice top right | functions | LibreOffice Macros | user | Standard | Test | HelloWorld

Assign e.g. Alt-A (I always assign a shortcut containing the Alt key on a US keyboard layout) and do Modify.

Then open a new LibreOffice text document and press Alt-A. Nothing happens. Fortunately, the macro runs when you do

Tools | Macros | Run Macro | My Macros | Standard | .....

Under LibreOffice fresh 5.2.2.2.0+ (Build ID 5.2.2-2) the situation is different, but not any better in this context. There, after assigning the shortcuts to scripts, when you press a shortcut key combination, the corresponding script of the main toolbar is activated.

At the moment, on my machines, ArchLinux runs kernel version 4.8.4-1-ARCH #1 SMP PREEMPT. LibreOffice still runs on 2 PCs, LibreOffice fresh on a third PC.

Kind regards,
Andre Hasekamp.
Comment 1 Cor Nouws 2016-11-14 22:58:08 UTC
Hi André,

(In reply to AndreHasekamp from comment #0)

> Tools | Customize | press LibreOffice top right | functions | LibreOffice
> Macros | user | Standard | Test | HelloWorld

I can confirm that assigning a macro to a short cut in the LibreOffice context doesn't work in 4.0.6.2 and not in a recent daily.
It does work in 3.3.0.4 > Regression.

In the context Writer (module that I tried) assigning the macro to a short cut does work.

Version: 5.3.0.0.alpha1+
Build ID: 2559ab66fd2976df54fc7d66bac5b7c0f7c23370
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-14_07:10:35
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 2 AndreHasekamp 2016-12-18 14:21:20 UTC
In the meantime we are at:

LibreOffice still 5.1.6.2.0+ (ArchLinux: 5.1.6.2 ArchLinux Build-4). Not much different from the LibreOffice still version I used for the original bug description.

and

LibreOffice fresh 5.2.3.3 (ArchLinux Build 5.2.3-4)

Linux kernel 4.8.13-1-ARCH

Unfortunately the issues I have with the shortcut assignments to macros are still the same. LibreOffice still behaves differently from LibreOffice fresh in this respect. See original bug description.

Kind regards,
Andre Hasekamp.
Comment 3 AndreHasekamp 2017-02-05 16:56:11 UTC
Archlinux is now at the following package versions for LibreOffice: LibreOffice still (since today) has version 5.2.5.1, build 5.2.5-1 and LibreOffice fresh has the same version number (this may be an Archlinux decision).

Yes, the macro shortcuts have improved, but we're not there yet. Upon pressing a macro shortcut combination, my macro is now activated, but in addition the corresponding shortcut for the LibreOffice menu is also activated, so that a LibreOffice menu pops up while my macro is executed.

Kind regards,
Andre Hasekamp.
Comment 4 QA Administrators 2018-03-07 03:41:12 UTC Comment hidden (obsolete)
Comment 5 AndreHasekamp 2018-03-15 14:50:29 UTC
Yes, the bug is still present.

But I do not want to load you people with more work than absolutely necessary.

The problem described under Comment 3 still exists today in as well LibreOffice Still as LibreOffice Fresh (ArchLinux always uses latest versions). The bypass is very simple but irritating.

Although I'm virtually convinced that in an early version of LibreOffice (I don't even know what version anymore) the problem described in Comment 3 did not exist, I do not have those early versions of LibreOffice anymore, so I cannot prove anything.

Therefore, especially  in the light of your Comment 4, it seems unreasonable to claim this bug any longer. So I changed the status to RESOLVED-WORKSFORME.

On this PC runs LibreOffice Still. The information from Help | About is:

Version: 5.4.5.1
Build ID: 5.4.5-1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: nl-NL (en_US.UTF-8); Calc: group

Thank you for all the good work you people are doing on LibreOffice. It is a great program.

Kind regards,
Andre Hasekamp.