Download it now!
Bug 103653 - Help->About click-able git hash to help QA.
Summary: Help->About click-able git hash to help QA.
Status: RESOLVED DUPLICATE of bug 103654
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-02 15:46 UTC by Michael Meeks
Modified: 2016-11-02 15:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2016-11-02 15:46:35 UTC
In our help->about dialog we present this:

Build ID: f19f88a0d49859eb714711cac72793f09f5f7d5c

It would be far better to have a link instead which goes to:

https://gerrit.libreoffice.org/gitweb?p=core.git;a=log;h=f19f88a0d49859eb7

we could also happily halve the length of the git hash, it doesn't need to be so long I think.

Code is in:

cui/source/dialogs/about.cxx

And we build the version string and put it into a single label:

    m_pVersion->SetText(GetVersionString());

That label is fetched from a UI config file here:

cui/uiconfig/ui/aboutdialog.ui

Which talks of a GtkTextView which is really:

vcl/source/window/builder.cxx-        xWindow = VclPtr<VclMultiLineEdit>::Create(pRealParent, nWinStyle);

a VclMultiLineEdit. Unfortunately this widget is not really capable
of including a hyperlink that we can just click.

We could include a FixedHyperlink widget in place of the first-line BuildID - which might work well. See:

include/vcl/fixedhyper.hxx

You'll need to put that into the glade as a "GtkLinkButton"

Hopefully that will make it easier to quickly see what is in a build.

Thanks !
Comment 1 Buovjaga 2016-11-02 15:53:01 UTC

*** This bug has been marked as a duplicate of bug 103654 ***