Bug 103654 - Help->About click-able git hash to help QA.
Summary: Help->About click-able git hash to help QA.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Arnold Dumas
URL:
Whiteboard: target:5.4.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
: 103653 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-02 15:46 UTC by Michael Meeks
Modified: 2020-04-28 16:19 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2016-11-02 15:46:35 UTC
In our help->about dialog we present this:

Build ID: f19f88a0d49859eb714711cac72793f09f5f7d5c

It would be far better to have a link instead which goes to:

https://gerrit.libreoffice.org/gitweb?p=core.git;a=log;h=f19f88a0d49859eb7

we could also happily halve the length of the git hash, it doesn't need to be so long I think.

Code is in:

cui/source/dialogs/about.cxx

And we build the version string and put it into a single label:

    m_pVersion->SetText(GetVersionString());

That label is fetched from a UI config file here:

cui/uiconfig/ui/aboutdialog.ui

Which talks of a GtkTextView which is really:

vcl/source/window/builder.cxx-        xWindow = VclPtr<VclMultiLineEdit>::Create(pRealParent, nWinStyle);

a VclMultiLineEdit. Unfortunately this widget is not really capable
of including a hyperlink that we can just click.

We could include a FixedHyperlink widget in place of the first-line BuildID - which might work well. See:

include/vcl/fixedhyper.hxx

You'll need to put that into the glade as a "GtkLinkButton"

Hopefully that will make it easier to quickly see what is in a build.

Thanks !
Comment 1 Buovjaga 2016-11-02 15:53:01 UTC
*** Bug 103653 has been marked as a duplicate of this bug. ***
Comment 2 Arnold Dumas 2016-12-07 09:17:15 UTC
Working on it
Comment 3 Commit Notification 2016-12-10 21:31:40 UTC
Arnold Dumas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cc02097495f95967f8f06c364dfa6a8949132868

tdf#103654: Make git hash clickable in the About dialog

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 m.a.riosv 2016-12-11 13:27:23 UTC
I really like this new option. A great help for QA

But we have an issue now, that's not possible to select and copy the version information. Very useful to add on the bug's reports.
Comment 5 steve -_- 2016-12-11 23:36:58 UTC
+1 what mario says. While the idea is nice, copy pasting from about is my standard routine to get that info into BZ when needed as well.

A solution could be to only make the Build-ID section be a link while the complete and other info around is still selectable.

Is it ok to re-open this bug, until a good solution is found and implemented?
Comment 6 Samuel Mehrbrodt (CIB) 2016-12-12 11:18:19 UTC
This bug should be a WONTFIX.
It's not guaranteed that Build-ID contains a git has.
It can be _anything_ since it can be overriden with a configure option. On Ubuntu e.g. it is "1:5.2.2-0ubuntu2".

So I think this should be reverted and closed as WONTFIX.
Comment 7 Commit Notification 2016-12-12 11:44:11 UTC
Michael Meeks committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=079a57802576eb84cc0d26b1d708a727c6b18a2a

Revert "tdf#103654: Make git hash clickable in the About dialog"

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Michael Meeks 2016-12-12 11:49:17 UTC
Hey ho; I'm not -at-all- happy with the comments and approach to an Easy Hack(er) here; how did we loose the relational context ? but lets try to go somewhere positive =)

Arnold - I've reverted temporarily here; sorry about that. I think we should do two things:

a) write a simple git hash recognizer function =) - should be fun: is the string <N> characters long and a pure hex number ? - this will elide the Ubuntu / whatever other madness people put in their version strings.
    + sure we could add -yet-another-configure-option- but that is hard, and we
      have way too many already; and I don't want this easy-hack further
      complicated.

b) use a separate fixedhyper widget underneath the existing VclMultiLineEdit - perhaps with some nice translatable label like: "see commit log" or something ?
    + only show this when a) suggests it is a git hash =)

How does that sound ? sorry to be a pain !

Thanks =)
Comment 9 Arnold Dumas 2016-12-12 19:08:36 UTC
I now understand that my patch improved the workflow for some people, but also made things worse for others. I will work on the proposal from Michael, which looks like a good compromise in my opinion.
Comment 10 jani 2017-01-23 08:21:10 UTC
A polite ping still working on this issue ?
Comment 11 Arnold Dumas 2017-01-24 08:14:06 UTC
Yes I'm currently working on it
Comment 12 m.a.riosv 2017-01-24 12:49:11 UTC
Thanks in advance Arnold.
Comment 13 Commit Notification 2017-01-30 09:48:10 UTC
Arnold Dumas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c7e1c9dc63a5986fc70fd86f36c8755b6c2a1f98

tdf#103654: Make git hash clickable in the About dialog

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 m.a.riosv 2017-02-01 00:54:15 UTC
Thanks so much Arnold. :)
Verified.
Version: 5.4.0.0.alpha0+
Build ID: 2670ca3fc597decae78499d1397539668eb84e5e
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-31_05:32:46
Locale: es-ES (es_ES); Calc: CL