Bug Hunting Session
Bug 103670 - EDITING: inserting 3D models doesn't work, *.gltf files are not recognized and can only view 3D models created with earlier versions of LO
Summary: EDITING: inserting 3D models doesn't work, *.gltf files are not recognized an...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 3D-Model
  Show dependency treegraph
 
Reported: 2016-11-03 05:44 UTC by Bastián Díaz
Modified: 2017-12-20 07:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Files (1.95 MB, application/zip)
2016-11-03 05:56 UTC, Bastián Díaz
Details
Test files for Insert->3d Object in Impress (49.36 KB, application/zip)
2017-10-27 08:25 UTC, Nithin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2016-11-03 05:44:17 UTC
Description:
Trying to create a new presentation with a 3D model, I noticed that open dialog (insert|object|3D Model), don't shows *.gltf files and also to insert *.dae files or *.kmz files, only is displayed an image with a question mark.

The only detailed information is in this blog: https://zolnaitamas.blogspot.cl/2014/08/3d-models-in-impress-libreoffice-43.html

According to the blog, this behavior can be caused by not having support for OpenGL 3.0, however, try on different computers 3D model not seem to have been inserted. In reviewing the document structure with an archive manager in the "models" folder is only a JSON and PNG file, which makes me think that the conversion of collada2gltf is not working.
In addition, it is possible to properly view 3D models created with earlier versions of LO (4.3.x).

Steps to Reproduce:
1. Open Impress
2. Insert a 3D model (insert|object|3D Model)
3. Select a collada file (reference: https://3dwarehouse.sketchup.com/model.html?id=6bf2ec1ddbf1a7c26c62613dc2544d22

* Alternatively, you can try opening test files that include the model of the "duck" or "monster".

Actual Results:  
When you insert a 3D model (*.dae or *.kmz), only one image is displayed with a question mark

Expected Results:
You can successfully insert a 3D model with the currently supported formats.


Reproducible: Always

User Profile Reset: No

Additional Info:
I tried many different files from web pages like:
• https://3dwarehouse.sketchup.com/https://github.com/KhronosGroup/glTF/tree/master/sampleModelshttp://tf3dm.com/http://www.turbosquid.com/


User-Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Comment 1 Bastián Díaz 2016-11-03 05:56:14 UTC
Created attachment 128462 [details]
Test Files

LO version: Version: 5.2.2.2
Build ID: 8f96e87c890bf8fa77463cd4b640a2312823f3ad
CPU Threads: 2; OS Version: Linux 4.8; UI Render: default;

OpenGL version string: 3.0 Mesa 12.0.3
Comment 2 Xisco Faulí 2016-11-12 11:14:03 UTC Comment hidden (obsolete)
Comment 3 Bastián Díaz 2016-11-12 11:37:15 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-05-31 10:51:40 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-06-28 12:34:52 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2017-06-28 15:17:55 UTC
Ok, setting to NEW
Comment 7 Buovjaga 2017-06-28 15:19:09 UTC
Btw. I get this in the terminal when opening Untitled 1.odp with the human brain:
/tmp/lu7226h4snrn.tmp/lu7226h4snrq.tmp/lu15528z3ifv1.json(93): expected ']' or ','
Comment 8 Nithin 2017-10-27 08:19:21 UTC
Facing the same problem Converted a file to both Collada and Json format using an online converter. This one -> http://www.greentoken.de/onlineconv/ 

The converted files when Inserted in Impress shows only a Question Mark in a box.
Comment 9 Nithin 2017-10-27 08:25:34 UTC
Created attachment 137314 [details]
Test files for Insert->3d Object in Impress