Bug 103730 - New Layout Engine : file display different on Windows and Linux
Summary: New Layout Engine : file display different on Windows and Linux
Status: RESOLVED DUPLICATE of bug 55469
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-11-05 18:53 UTC by madmalkav
Modified: 2016-11-09 11:11 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
File on Windows (152.27 KB, image/png)
2016-11-05 18:54 UTC, madmalkav
Details
File on Linux (233.19 KB, image/png)
2016-11-05 18:54 UTC, madmalkav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description madmalkav 2016-11-05 18:53:58 UTC
Description:
This file doesn't display the same in Windows and Linux with the new Layout Engine:

https://github.com/madmalkav/apuntes-japones-EOI/blob/master/Apuntes%20de%20japones.odt

It uses two different fonts: Yu Gothic UI Light fronm Windows and KanjiStrokeOrders.

As you can see on the screenshots, what renders OK in one page in Linux takes more space in Windows.

Steps to Reproduce:
Open the file in different OS.

Actual Results:  
Files displays differently.

Expected Results:
Files displays the same way.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36
Comment 1 madmalkav 2016-11-05 18:54:27 UTC
Created attachment 128520 [details]
File on Windows
Comment 2 madmalkav 2016-11-05 18:54:48 UTC
Created attachment 128521 [details]
File on Linux
Comment 3 Khaled Hosny 2016-11-05 22:13:19 UTC
To get the same layout you need the exact same fonts, if you install the same fonts on both systems, specify them explicitly in the document and still get different results then this is indeed a bug.
Comment 4 m.a.riosv 2016-11-05 22:28:35 UTC
There is a document's property to embed the font with the file
Menu/File/Properties - Font
in this way the file can be compared with the same font.
Comment 5 madmalkav 2016-11-05 23:44:09 UTC
Seems like the fonts were already embedded but that wasn't worked ok, so I tried the following things:

Remove the embedded fonts and open the file in both OS. Result is as in the screenshots I attached before.

Embed the fonts again on one OS and open in the other. Result, again, is as in the screenshot I attached before. By the way, the file size doing this on Windows is about 4.1MB, doing it on Linux 2.3Mb. Weird...

I also tried to remove the Yu Gothic UI Light and KanjiStrokeOrders fonts from Linux. It always uses the substution font even if the proper font was embedded on the file.

I can't do exactly the same test on Windows as Yu Gothic is a system font and I can't remove it, but it uses substitution font for KanjiStrokeOrders.

So, my conclusions are:

- The different layout is indeed an issue.
- The embedding fonts options isn't working as it should, either.
Comment 6 Khaled Hosny 2016-11-06 00:12:46 UTC
What about plain old copying the fonts and installing them? If you are still getting font fallback (italic font name), then no identical layout can be expected.

If embedded fonts do not work, then this is a different bug and should be reported separately.
Comment 7 madmalkav 2016-11-06 00:21:24 UTC
(In reply to Khaled Hosny from comment #6)
> What about plain old copying the fonts and installing them? If you are still
> getting font fallback (italic font name), then no identical layout can be
> expected.
> 
> If embedded fonts do not work, then this is a different bug and should be
> reported separately.

The fonts where already installed from the beggining and available in all the tests sans the last ones. There is a clear difference between what is displayed when the fonts are installed and when not. When the font is installed, it is clear the LibreOffice is using the same font in both OS but adding more space above the chars in Windows. This is exactly the same behaviour as in older versions without the old layout engine.

About embeded fonts not working, yeah, I agree it is a different bug and I have to open it as soon as I can test it a little more.
Comment 8 Khaled Hosny 2016-11-06 00:32:03 UTC
(In reply to madmalkav from comment #7)
> adding more space above the chars in Windows. This is exactly the same
> behaviour as in older versions without the old layout engine.

OK, so this is a duplicate of bug 55469 then. Can you attach the document shown in the screenshots.

*** This bug has been marked as a duplicate of bug 55469 ***