Bug Hunting Session
Bug 98269 - FORMATTING: Different spacing with Japanese ruby text between WIN and LINUX
Summary: FORMATTING: Different spacing with Japanese ruby text between WIN and LINUX
Status: RESOLVED DUPLICATE of bug 55469
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: HarfBuzz
Blocks: Font-Rendering CJK
  Show dependency treegraph
 
Reported: 2016-02-29 11:04 UTC by Andrea
Modified: 2016-11-09 13:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example text (50.53 KB, application/vnd.oasis.opendocument.text)
2016-02-29 11:04 UTC, Andrea
Details
kanji e Furigana spacing LINUX (46.57 KB, application/pdf)
2016-11-07 11:20 UTC, Andrea
Details
kanji e Furigana spacing WINDOWS (48.90 KB, application/pdf)
2016-11-07 11:21 UTC, Andrea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrea 2016-02-29 11:04:11 UTC
Created attachment 123073 [details]
example text

The same document (especially with many Japanese Furigana) is different between Windows and Linux if using japanese fonts.
It may depend on the spacing between kana and furigana (or between japanese and Occidental fonts) different in different OS.
It's version independent.
Pagination is compromised.

Please ask me for any info you may need.
Andrea

Example attached.
Comment 1 Buovjaga 2016-03-17 11:30:52 UTC
See this discussion thread: https://lists.freedesktop.org/archives/libreoffice/2016-March/073509.html
It should get fixed with a unified font rendering backend.
Comment 2 Andrea 2016-03-17 12:32:04 UTC
That is?
I apologize.
Its a little too technical for my knowledge.
Sorry.
Comment 3 Buovjaga 2016-03-17 14:41:30 UTC
(In reply to Andrea from comment #2)
> That is?
> I apologize.
> Its a little too technical for my knowledge.
> Sorry.

The dream is to get font rendering on Windows done with Freetype + Harfbuzz.
Comment 4 Andrea 2016-03-18 09:50:56 UTC
In my humble opinion on linux the mix kana-furigana-romaji is best handled by libreoffice on linux than on windows.

Make dreams come true.

Best wishes.
Comment 5 Volga 2016-08-25 07:41:00 UTC
W3C Working Group Note “Requirements for Japanese Text Layout” has an good example on this that you can catch up with.

https://www.w3.org/TR/jlreq/#ruby_and_emphasis_dots
Comment 6 Khaled Hosny 2016-11-04 13:45:12 UTC
The bug description is very general, can you be more specific about the differences you are seeing, an whether you have all the fonts used in the document on both systems or not.
Comment 7 Andrea 2016-11-07 08:54:09 UTC
Let's try.
I think the problem is related to spacing between furigana and kanji in ruby texts.
This spacing is different depending on operative systems, so the same document is formatted differently causing unconformity (paragraphs divided in 2 pages when opening on WindowsOS) if the document is open on windows or GNU/Linux. 
I'm using the same fonts in both systems (HGSeikaishotaiPRO).

Don't know how to be more specific.
Comment 8 Khaled Hosny 2016-11-07 11:03:06 UTC
What I’m looking for is something like in the 1st pages, in like N foo and bar are spaced differently. For someone who does not know Japanese, I had absolutely no idea where to look for differences in the page.
Comment 9 Andrea 2016-11-07 11:13:39 UTC
Need to create a pdf.
Please wait.

Many many thanks
Comment 10 Andrea 2016-11-07 11:20:42 UTC
Created attachment 128545 [details]
kanji e Furigana spacing LINUX

File created on LINUX and opened on LINUX
Comment 11 Andrea 2016-11-07 11:21:53 UTC
Created attachment 128546 [details]
kanji e Furigana spacing WINDOWS

File created on LINUX and opened on WINDOWS
Comment 12 Khaled Hosny 2016-11-07 16:20:59 UTC
Thanks, so this looks like another instance of bug 55469.
Comment 13 Andrea 2016-11-09 11:01:32 UTC
*** Bug 55469 has been marked as a duplicate of this bug. ***
Comment 14 Timur 2016-11-09 11:10:24 UTC
Andrea, it's later that should be marked as a duplicate.
Comment 15 Khaled Hosny 2016-11-09 13:18:58 UTC
Does it really matter! The other bug is older and have more information than this one.

*** This bug has been marked as a duplicate of bug 55469 ***