Bug Hunting Session
Bug 103745 - horizontal stretching is broken in Math formula
Summary: horizontal stretching is broken in Math formula
Status: RESOLVED DUPLICATE of bug 100746
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-11-06 22:43 UTC by Regina Henschel
Modified: 2016-11-13 14:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-11-06 22:43:28 UTC
Write formulas like

widevec {P_0 P_1}
widehat {P_0 P_1}
{x+y+z} overbrace {}
{x+y+z} underbrace {}

They are no longer horizontal stretched in Version: 5.3.0.0.alpha1+
Build ID: 32bdc5097013e7efd9c85e1b8df697880e66e925
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-04_23:30:30
Locale: de-DE (de_DE); Calc: single

To see, how it should be rendered use Version: 5.3.0.0.alpha1+
Build ID: 8a796410ec8f440b4163b15b928347c499da7a8f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-20_23:07:21
Locale: de-DE (de_DE); Calc: group
Comment 1 V Stuart Foote 2016-11-06 23:28:46 UTC
On Windows 10 Pro 64-bit (1607) en-US with
Version: 5.3.0.0.alpha1+
Build ID: 32bdc5097013e7efd9c85e1b8df697880e66e925
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-04_23:30:30
Locale: en-US (en_US); Calc: CL

Confirmed. The HarfBuzz based common layout with OpenGL rendering also is clipping the glyphs (e.g. the glyphs scale larger than the calculated box holding the node).
Comment 2 Khaled Hosny 2016-11-08 15:13:50 UTC

*** This bug has been marked as a duplicate of bug 103725 ***
Comment 3 V Stuart Foote 2016-11-13 14:23:12 UTC

*** This bug has been marked as a duplicate of bug 100746 ***