Bug 103784 - FORMATTING: latin text shifts to the left in vertical mode
Summary: FORMATTING: latin text shifts to the left in vertical mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Khaled Hosny
URL:
Whiteboard: target:5.3.0
Keywords:
: 103850 (view as bug list)
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-11-08 15:07 UTC by Mark Hung
Modified: 2016-11-28 09:22 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file. (9.82 KB, application/vnd.oasis.opendocument.text)
2016-11-08 15:07 UTC, Mark Hung
Details
Screenshot 5.2.1.2 v.s 5.3.0.0alpha1 (13.39 KB, image/png)
2016-11-08 15:09 UTC, Mark Hung
Details
2nd test (31.00 KB, image/png)
2016-11-26 14:19 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Hung 2016-11-08 15:07:31 UTC
Created attachment 128572 [details]
Sample file.
Comment 1 Mark Hung 2016-11-08 15:09:44 UTC
Created attachment 128573 [details]
Screenshot 5.2.1.2 v.s 5.3.0.0alpha1
Comment 2 Xisco Faulí 2016-11-08 15:59:28 UTC
Confirmed in

Version: 5.3.0.0.alpha1+
Build ID: 8dc495c93239739629683bb29e4110f5c57c94f0
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

only when SAL_USE_COMMON_LAYOUT=1 is enabled.
Comment 3 Volga 2016-11-12 14:11:33 UTC
OK I think LO 5.2.1.2 get the right alignment for them. I also made a comparison between LODev 5.3 and Firefox in bug 103850, I think Firefox also performanced correct.
Comment 4 Commit Notification 2016-11-15 23:08:29 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84f644eee78106f01486098d446d9163b62927eb

tdf#103784: Shift the upright glyphs like old code

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Volga 2016-11-17 04:13:01 UTC
*** Bug 103850 has been marked as a duplicate of this bug. ***
Comment 6 Volga 2016-11-22 08:39:01 UTC
It would be much better if Chinese charaters align with ascenders within vertical text. See the sample:
https://userscloud.com/tqvelmv274wt
Comment 7 Volga 2016-11-26 14:19:28 UTC
Created attachment 129032 [details]
2nd test

This problem seems appearing to me again on 5.3.0 beta1

Version: 5.3.0.0.beta1
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: zh-CN (zh_CN); Calc: group
Comment 8 Volga 2016-11-28 09:22:46 UTC
(In reply to Volga from comment #7)
> Created attachment 129032 [details]
> This problem seems appearing to me again on 5.3.0 beta1

I know what’s happened. When I use the same font size for Latin texts, I get the proper text alignments. But when I use Cardo font for Latin, the problem appearing again. See attachment 129064 [details]