Bug 103789 - Remote Files Add Service fails for SSH or Windows Share - save as Network Fails
Summary: Remote Files Add Service fails for SSH or Windows Share - save as Network Fails
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CMIS
  Show dependency treegraph
 
Reported: 2016-11-08 18:43 UTC by David C. Rankin
Modified: 2021-03-10 04:05 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
error dialog on attempted 'save as' (8.74 KB, image/png)
2016-11-08 18:43 UTC, David C. Rankin
Details
top screenshot showing 100% CPU use while 'save as' dialog open (140.52 KB, image/png)
2016-11-08 18:44 UTC, David C. Rankin
Details
Popup error when creating "SSH" remote service (2.83 KB, image/png)
2017-09-28 09:27 UTC, Eric
Details
Edit Remote File Service, OK grayed out (3.98 KB, image/png)
2017-09-28 09:28 UTC, Eric
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David C. Rankin 2016-11-08 18:43:16 UTC
Created attachment 128586 [details]
error dialog on attempted 'save as'

5.1.6.2 on Archlinux

'Remote Files' Add Service fails for simple SSH or Windows Shares (smb). Attempting to define a service for SSH or Windows Shares access to local network server fails in KDE Frameworks 5.27. This effectively prevents any meaning use or 'save as' of a libreoffice document to local network locations.

Additionally, attempting to save as Network causes a race condition causing soffice-bin to take 100% of the CPU while the 'save as' dialog is open.

I have attached screenshots of the error dialog and the top CPU usage.
Comment 1 David C. Rankin 2016-11-08 18:44:17 UTC
Created attachment 128587 [details]
top screenshot showing 100% CPU use while 'save as' dialog open
Comment 2 Xisco Faulí 2017-06-19 12:32:35 UTC
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 Eric 2017-09-27 14:32:24 UTC
I am using Libre Office 5.3.2 on Slackware Linux, and I still can't create an SSH remote-file service.

Whatever options I put into the option window, all I get is a popup that says something like "no such file" (I'm not at home right now, so I can't get the exact message).  I can see from my logs that there is no attempt to connect to the remote host.

When I try to edit the service, I have only two lines I can type in (again, I'm not home to recreate the exact window), and the "OK" button is greyed out.

I can successfully delete the service.

Please tell me (as specifically as you can) what further info I can provide.
Comment 4 Eric 2017-09-28 09:27:22 UTC
Created attachment 136576 [details]
Popup error when creating "SSH" remote service

When I try to create an SSH Remote Files service, I immediately get this pop-up error.
Comment 5 Eric 2017-09-28 09:28:33 UTC
Created attachment 136577 [details]
Edit Remote File Service, OK grayed out

When I try to edit the Remote Files service entry, I get this pop-up window.  I can type in both fields, but the OK button is greyed out.
Comment 6 Xisco Faulí 2018-10-19 12:16:31 UTC
Hi David, Eric,
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 7 Nick Leverton 2019-02-25 12:55:09 UTC
Is this a duplicate of #98897 ?  It looks so from the dialogues, but I am hesitant to merge it myself as the CPU usage point is not mentioned in the other BZ entry.
Comment 8 QA Administrators 2019-09-02 09:32:06 UTC Comment hidden (obsolete)
Comment 9 Stin 2019-09-12 15:43:28 UTC
I have a similar issue.  If I try to open a file directly from a GVfsd mount point... Nothing happens. I get the loading notification 'pointer spinner' and a loading splash banner with a progress bar of (what looks like) 10-15%-ish, but Libre Office just exits.  I see nothing in any system logs.

To circumvent this, I created soft links to the GVfsd mount points (as I know they have special characters, which some non-POSIX apps fail with) and tried again. This time, after the progress bar stopped at the same place, I got a 'General input/output error while accessing /home/user/.gvfs/softlinkname/path/filename' error box.

I have made suggestions to the GVfsd team to use more compatible characters in the mount points, which has helped with oper applications, but I don't think that is the issue in this case.

- Libre Office 5.1.6.2

- GVfsd 1.28.2

- OS :
Distributor ID:	Zorin
Description:	Zorin OS 12.4
Release:	12
Codename:	xenial

I will try the latest version of LO and see if anything is different.

Would you like any further information?

Thank you for any help or advice you can give. :)
Comment 10 Stin 2019-09-13 02:01:21 UTC
(In reply to Stin from comment #9)
> I have a similar issue.  If I try to open a file directly from a GVfsd mount
> point... Nothing happens. I get the loading notification 'pointer spinner'
> and a loading splash banner with a progress bar of (what looks like)
> 10-15%-ish, but Libre Office just exits.  I see nothing in any system logs.
> 
> To circumvent this, I created soft links to the GVfsd mount points (as I
> know they have special characters, which some non-POSIX apps fail with) and
> tried again. This time, after the progress bar stopped at the same place, I
> got a 'General input/output error while accessing
> /home/user/.gvfs/softlinkname/path/filename' error box.
> 
> I have made suggestions to the GVfsd team to use more compatible characters
> in the mount points, which has helped with oper applications, but I don't
> think that is the issue in this case.
> 
> - Libre Office 5.1.6.2
> 
> - GVfsd 1.28.2
> 
> - OS :
> Distributor ID:	Zorin
> Description:	Zorin OS 12.4
> Release:	12
> Codename:	xenial
> 
> I will try the latest version of LO and see if anything is different.
> 
> Would you like any further information?
> 
> Thank you for any help or advice you can give. :)

Just got round to installing 6.3.2.1 and it seems to work fine from the 'Open...' dialogue and directly from an SMB share.

Thank you so much, Libre Office developers. :D

I'll shut up, now.
Comment 11 QA Administrators 2021-02-07 04:18:53 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2021-03-10 04:05:09 UTC Comment hidden (spam)