Bug 98897 - Open Remote File - Cannot Connect to Server via SSH
Summary: Open Remote File - Cannot Connect to Server via SSH
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 122157 (view as bug list)
Depends on:
Blocks: Network
  Show dependency treegraph
 
Reported: 2016-03-25 22:40 UTC by Eric
Modified: 2019-06-26 23:17 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric 2016-03-25 22:40:29 UTC
After adding a new SSH connection there is no feedback provided - there is no authentication error etc.  Nothing appears to happen other than the new SSH connection is added and can be seen in the "Service" list pull-down.

Using the "Edit service" pull-down option on the "Add service" button displays the "File Services" dialog, but after entering the same username used when creating the new service the "OK" button is still greyed out.

The SSH server is provided by the OpenSSH Server running under Ubuntu 14.04 Server.
Comment 1 William Geiger 2016-03-26 01:24:22 UTC
I can confirm the same bug on Xubuntu Xenial System 64 bit. I do not know if this is a bug in LO or a configuration issue. New to LO and the documentation is quite sparse on the issue.
Comment 2 William Geiger 2016-03-26 03:21:28 UTC
i found a fix for this:

sudo apt-get install libreoffice-gnome

i don't know why this is not installed by default?

i will checx my logs and see if it was uninstalled somewhere.

i am running a fresh install of xubuntu xenial
Comment 3 MM 2016-03-26 10:09:48 UTC
(In reply to William Geiger from comment #2)
> i found a fix for this:
> 
> sudo apt-get install libreoffice-gnome
> 
> i don't know why this is not installed by default?
> 
> i will checx my logs and see if it was uninstalled somewhere.
> 
> i am running a fresh install of xubuntu xenial

It seems that xenial doesn't install all files of LO, even Base isn't available.
Does the problem still exists if you download and install the whole package manually ?
Comment 4 Adolfo Jayme 2016-03-26 18:51:09 UTC
(In reply to MM from comment #3)
> It seems that xenial doesn't install all files of LO, even Base isn't
> available.

The Ubuntu images don’t contain all the LibreOffice-related packages because of space constraints. Anyway, please take those issues to https://launchpad.net/df-libreoffice, as they are not directly related to the upstream LibreOffice project.
Comment 5 MM 2016-03-26 19:11:17 UTC
(In reply to Adolfo Jayme from comment #4)
> (In reply to MM from comment #3)
> > It seems that xenial doesn't install all files of LO, even Base isn't
> > available.
> 
> The Ubuntu images don’t contain all the LibreOffice-related packages because
> of space constraints. Anyway, please take those issues to
> https://launchpad.net/df-libreoffice, as they are not directly related to
> the upstream LibreOffice project.

Personally, I always download & install manually.
Comment 6 Buovjaga 2016-04-07 09:48:38 UTC
Eric: we need further information from you based on all the comments so far.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 7 Eric 2016-04-07 20:49:42 UTC
I'm not sure what additional information you require?  Let me know and I'll assist.

Note that I am running LibreOffice on the Windows 7 platform, not Linux.

I have just installed LibreOffice version 5.1.1.3 and the problem still persists.

Remote File Type = SSH
----------------------
We have a Linux server running a SSH service.  We can connect to the server from any machine (including a Windows machine) using an SFTP Client and access files - copy, delete, add files etc., so we know that remote SSH works OK.

Adding the same connection details to the "Remote Files" appears to add the service but nothing is shown in the file list.

If I then try to "Edit Service" with the recently added service selected, the pop-up dialog has a blank user name, displays the label, but there are no edit boxes for the the other fields originally entered.  Re-entering the "User" name does not restore the state of the greyed-out "OK" button.



Remote File Type = Google Drive
-------------------------------
Using this option with a valid Google Drive account results in a "The specified device is invalid" error dialog.


Eric
Comment 8 Richard 2016-04-27 20:38:10 UTC
I've observed the same results as Eric when using libreoffice 5.1.2 and attempting to open ssh remote files on both Windows 7 and debian stretch.

Upon adding an ssh connection in "Remote Files", the service is added, but nothing happens -- no file list. This is on both debian stretch and windows 7.

Upon selecting "Edit Service", the pop-up dialog has a blank user name. After entering the username, the OK button is greyed out. It does not appear possible to save the user name.

One of the user comments in bug 98723 suggested installing the libreoffice-gnome package instead of plain 'libreoffice'.  Previously I had installed 'libreoffice' on debian stretch. After installing libreoffice-gnome on debian stretch, opening a ssh remote file results in a pop-up dialog saying 'nonexistent file'.

The file exists, and the ssh service is working, based on tests with scp and ssh.

I would be glad to try to gather more info if anyone can point out info on how to enable debugging logs.
Comment 9 Buovjaga 2016-04-28 05:37:52 UTC
(In reply to Richard from comment #8)
> I would be glad to try to gather more info if anyone can point out info on
> how to enable debugging logs.

https://wiki.documentfoundation.org/QA/BugReport/Debug_Information

On Debian, you install the libreoffice-dbg package.

Did this work in an older version?

NEW per comment 8.
Comment 10 Richard 2016-04-29 22:17:52 UTC
(In reply to Buovjaga from comment #9)
> (In reply to Richard from comment #8)
> > I would be glad to try to gather more info if anyone can point out info on
> > how to enable debugging logs.
> 
> https://wiki.documentfoundation.org/QA/BugReport/Debug_Information
> 
> On Debian, you install the libreoffice-dbg package.
> 
> Did this work in an older version?
> 
> NEW per comment 8.

Older versions had the same issue back to 5.0 at least.
I can try earlier ones as well if needed.

I'll install libreoffice-dbg on debian, and gather more info with --backtrace.

Thanks so much for your help!
Comment 11 Buovjaga 2016-04-30 06:41:54 UTC
Here are instructions for testing older versions (and a link to old version archive): https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 12 QA Administrators 2018-08-25 02:42:44 UTC Comment hidden (obsolete)
Comment 13 Luuk 2019-01-19 13:42:11 UTC
This bug is also here: bug 122157

This bug seems to be 'non linux' (so only exists on windows and/or Apple)

Although some remarks here say that 'libreoffice-dbg' or 'libreoffice-gonme' needs to be installed on linux to get things working.
Comment 14 Buovjaga 2019-01-19 16:55:52 UTC
*** Bug 122157 has been marked as a duplicate of this bug. ***
Comment 15 Craig Harding 2019-01-29 02:45:52 UTC
This happens to me on linux, LO version 5.1.6.2.

I connect to a sftp share by connecting to the share on thunar (xfce). But clicking any odt files in the share does nothing (LO does not even open).

I commented out the 'X-GIO-NoFuse=true' line in my libreoffice-write.desktop file as per (and countless other sites):

https://www.reddit.com/r/libreoffice/comments/3ij405/libreoffice_cannot_open_files_on_a_network/

and it throws a 'General input/output error while accessing' error dialog box when I try to open the same file (or any odt files).

Trying to open the file through command line, I get:

$ libreoffice --writer /run/user/1000/gvfs/sftp\:host\=website.com\,user\=user/home/user/Winter\ Parking.odt 
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
Comment 16 Nick Leverton 2019-02-25 10:46:51 UTC
Symptoms in comments #7 and #8 still apply to LibreOffice 6.0.7.3 on Windows, I am unable to use Remote Files Service to either open or save.
Comment 17 Nick Leverton 2019-02-25 10:49:34 UTC
Ermh that should say "open or save via ssh", apols for the truncated update.

I have removed the "obsolete" tag from this bug accordingly.
Comment 18 Buovjaga 2019-02-25 12:14:49 UTC
(In reply to Nick Leverton from comment #17)
> Ermh that should say "open or save via ssh", apols for the truncated update.
> 
> I have removed the "obsolete" tag from this bug accordingly.

The obsolete tag was added to the comment on purpose so the report would be easier to read. Nothing to do with any supposed obsoleteness of the report itself.
Comment 19 Nick Leverton 2019-02-25 12:50:52 UTC
My apologies for misunderstanding.  When I added the entry, BZ showed me the obsolete tag and said that it was an issue reported on an old version and to re-test on current LO.  This I have done and can confirm that the bug is very much still present, I'm afraid.

If you feel this means it should still get the obsolete tag to help LO triage, then please go ahead and re-add it.  I'm very grateful for all the work the team does so thankyou.
Comment 20 Nick Leverton 2019-02-25 12:53:13 UTC
I can also confirm that the same symptoms, of inability to open a remote SSH service, are still present in LO 6.2.0.3 which I believe is the most current, installed from the official LibreOffice .debs and running on Linux (Debian Jessie x86_64).
Comment 21 Craig Harding 2019-06-26 23:17:07 UTC
When I try to edit the ssh service by doing:

- File->Open Remote File
- Clicking the dropdown 'Service' and choosing my already ssh created connection
- clicking the arrow next to to the right of 'Add Service' drop down and choosing 'Edit Service' while my ssh dropdown is selected.
- A pop up appears with a 'User' and 'Label' fields only. The label has my ssh service label and no username. Currently the OK button is greyed out (just like initial comment and comment 7 and 8.
- if I try to enter in a username, the OK button is still greyed out.

LO Version: 5.1.6.2 on Linux