Bug 103885 - Particular OGG video can't be played in GTK2/GTK3
Summary: Particular OGG video can't be played in GTK2/GTK3
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Media-Playback
  Show dependency treegraph
 
Reported: 2016-11-12 12:01 UTC by Xisco Faulí
Modified: 2022-04-05 13:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-12 12:01:07 UTC
Steps to reproduce:
1. Open attachment 128618 [details] in GTK2
2. Select the video
3. Click on play on the sidebar

Observed behavior: Video isn't played. video is played correctly in GTK3

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 60da087d7e182b58b63d4123c9bd96c82376d450
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 1 Xisco Faulí 2016-11-12 12:21:28 UTC
it looks in GTK3 the video can be played only once
Comment 2 Yousuf Philips (jay) (retired) 2016-11-12 20:06:55 UTC
Confirmed that it shows image preview and doesnt play on gtk2 git build of master or Ubuntu Mate 16.04's LO 5.1.4.2. With git gtk3 backend, it plays only once.

Version: 5.3.0.0.alpha1+
Build ID: d34a8993e3b3200de10d20990d14dc9288d8d6c7
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

With tdf build, it doesnt show the image preview and pressing play opens a new video playback window and the video doesnt play. Closing the playback window and then impress causes LO to hang.

Version: 5.3.0.0.alpha0+
Build ID: 619e74ccb0e97b0ea12ae11c5b36084706d5002e
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-15_02:24:39
Locale: en-US (en_US.UTF-8); Calc: group
Comment 3 MM 2016-11-19 19:44:22 UTC
Also doesn't play on:

Version: 5.2.3.3 (x64)
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 2; OS Version: Windows 6.19; UI Render: default; 
Locale: en-US (en_US); Calc: single

Seeing a big questionmark and nothing happens when pressing play.
So it's not only gtk builds that don't work.
Comment 4 Yousuf Philips (jay) (retired) 2017-04-27 20:31:32 UTC
So i tested the file in VLC and Totem and it played fine. So there must be some issue with that particular ogg video file as the ogg video file i converted with ffmpeg for testing all codecs on various OSes works fine.

https://drive.google.com/open?id=0B6qJrVIa0SAldE0tZG81UHFsWVk

https://wiki.documentfoundation.org/Media_Support/Linux/Video_Tests#Video:_4.3.5-ubuntu
Comment 5 Heiko Tietze 2017-04-28 11:59:28 UTC
When I start the presentation it opens mplayer, which I run on my system as video player.

Version: 5.3.2.2
Build ID: 5.3.2-1
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: en-US (C); Calc: group
Comment 6 QA Administrators 2018-04-29 02:30:28 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2021-03-16 04:28:21 UTC Comment hidden (obsolete)
Comment 8 Timur 2021-08-20 10:56:33 UTC
It plays in my GTK3 but it loads as fullscreen. Similar to bug 134877.
OK in Win, so I mark Lin.
Comment 9 Timur 2022-04-05 13:21:34 UTC
(In reply to Xisco Faulí from comment #1)
> it looks in GTK3 the video can be played only once

Not just once for me, but every 2nd run, with LO 6.0
No repro 7.4+ for me, I close, but please test.