Bug 103919 - Mailmerge e-mail does not send all merged documents
Summary: Mailmerge e-mail does not send all merged documents
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2016-11-14 07:29 UTC by Ferdi
Modified: 2017-10-05 16:34 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Mailmerge window showing difference in sent documents vs. total number of documents (31.12 KB, image/png)
2016-11-21 07:35 UTC, Ferdi
Details
A hack to maybe fix this bug (1.10 KB, patch)
2016-12-14 12:15 UTC, Alex Kempshall
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ferdi 2016-11-14 07:29:05 UTC
When doing a Mail merge for a newsletter, not all mails are sent, although the wizard does create them all. (in any case when saving the documents)
If there is only one recipient No mail is sent, on the mailserver I get a connect from the machine sending them immediately followed by a disconnect, no data is received.
When there are 2 adresses, only the second gets sent, not the first. I see the connect immediately followed by a disconnect of the first one.
If I have 10 mails, only the first 6 are sent, the last four never reach the mailserver (no connection is made)

This is using HTML mailmerge messages, have not tested pdf or ODF sending. Mainly because I need the mails to be HTML.

I run my own mailserver (postscript). If desired I can attach logging from the server showing the connects/disconnects and the document I am trying to send.

The addresses and names in the document are retrieved from an LibreOffice Base database query.
Comment 1 Ferdi 2016-11-14 19:07:18 UTC
Did some more testing, when e-mailing as ODF document, I get only 5 out of ten mails. The order they arrive is also the same every time.
document 1 comes first, then 5, 4, 3, 2, 6 to 10 never get sent.
unfortunately the window that is shown during sending remains to short on screen to be able to read it The numbering on it in the short glimpse that it is seen seems odd though.
Sending as pdf is even worse, only 3 out of 10 mails are sent.
But now when sending HTML, 9 out of 10 get sent.And they are sent in very random order.
This is not very consistent behaviour. In this manner I can just as well send them all manually. And I intent to sent several hundred to all the people that have an subscription to my newsletter so that would be very inconvenient.
Comment 2 Ferdi 2016-11-15 06:42:16 UTC
Just sent out an mailmerge with 130 e-mail adresses. roughly half get sent.
When looking at the dialog showing the progress it displays the text "Sending paused" constantly.
There is a counter in the dialog, counting the number of documents and the number that are sent. When the number of documents counter has reached the total number of documents in the mailmerge, the dialog closes and presumably sending stops. The number of documents sent counter never reaches the total number of documents.
Comment 3 Ferdi 2016-11-21 07:31:55 UTC
(In reply to Ferdi from comment #2)
> Just sent out an mailmerge with 130 e-mail adresses. roughly half get sent.
> When looking at the dialog showing the progress it displays the text
> "Sending paused" constantly.
> There is a counter in the dialog, counting the number of documents and the
> number that are sent. When the number of documents counter has reached the
> total number of documents in the mailmerge, the dialog closes and presumably
> sending stops. The number of documents sent counter never reaches the total
> number of documents.

After carefully looking the above seems to be occurring every time.
The mailmerge should not end when the total number of documents is reached, but when the total number of documents has been sent!
I attached a screenshot, to show the counter and how the number of sent documents are different from the total number of documents.
Comment 4 Ferdi 2016-11-21 07:35:21 UTC
Created attachment 128909 [details]
Mailmerge window showing difference in sent documents vs. total number of documents

Mailmerge stops when total number of documents is reached, should be when number of sent documents equals the total number of documents.
Now only about half of the total number gets sent.
Comment 5 Buovjaga 2016-11-28 20:00:24 UTC
Could you try with 5.3 beta1?

https://wiki.documentfoundation.org/Installing_in_parallel/Linux
http://dev-builds.libreoffice.org/pre-releases/deb/x86_64/LibreOfficeDev_5.3.0.0.beta1_Linux_x86-64_deb.tar.gz

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 6 Ferdi 2016-12-07 06:57:03 UTC
Thanks for the reply, I had a little holiday, so could not test this yet. Will download and install 5.3.0 beta and test with that. I'll post results here.
Comment 7 Ferdi 2016-12-07 18:42:49 UTC
I installed the latest beta and got it running.
Unfortunately I cannot test this problem because in this version it will not connect to any mailserver at all. I find it impossible to sent any mail.

I am using exactly the same settings that work in 5.2.2 but they do not work in 5.3.0

Also tried other smtp servers that I have access to, no luck they all fail with the message below:

LibreOfficeDev could not connect to the outgoing mail server. Check your system's settings and the settings in LibreOfficeDev. Check the server name, the port and the secure connections settings
--
<class 'LookupError'>: unknown encoding: idna, traceback follows
  File "/home/ferdi/Downloads/LibreOfficeDev_5.3.0.0.beta1_Linux_x86-64_deb/DEBS/Install/opt/libreofficedev5.3/program/mailmerge.py", line 106, in connect
    self.server = smtplib.SMTP(server, port,timeout=tout)
  File "/home/ferdi/Downloads/LibreOfficeDev_5.3.0.0.beta1_Linux_x86-64_deb/DEBS/Install/opt/libreofficedev5.3/program/python-core-3.5.0/lib/smtplib.py", line 251, in __init__
    (code, msg) = self.connect(host, port)
  File "/home/ferdi/Downloads/LibreOfficeDev_5.3.0.0.beta1_Linux_x86-64_deb/DEBS/Install/opt/libreofficedev5.3/program/python-core-3.5.0/lib/smtplib.py", line 335, in connect
    self.sock = self._get_socket(host, port, self.timeout)
  File "/home/ferdi/Downloads/LibreOfficeDev_5.3.0.0.beta1_Linux_x86-64_deb/DEBS/Install/opt/libreofficedev5.3/program/python-core-3.5.0/lib/smtplib.py", line 306, in _get_socket
    self.source_address)
  File "/home/ferdi/Downloads/LibreOfficeDev_5.3.0.0.beta1_Linux_x86-64_deb/DEBS/Install/opt/libreofficedev5.3/program/python-core-3.5.0/lib/socket.py", line 689, in create_connection
    for res in getaddrinfo(host, port, 0, SOCK_STREAM):
  File "/home/ferdi/Downloads/LibreOfficeDev_5.3.0.0.beta1_Linux_x86-64_deb/DEBS/Install/opt/libreofficedev5.3/program/python-core-3.5.0/lib/socket.py", line 728, in getaddrinfo
    for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
Comment 8 Ferry Toth 2016-12-07 20:23:27 UTC
I am confirming this for LibO 5.2.2.2 on Ubuntu. I regularly send ~ 80 html formatted messages. 

After upgrading to Ubuntu 16.10 I am getting complaints of people not receiving them. The dialog counts to about 80, making me think that all have actually been sent. A poll among the receivers shows only about half were received.
Comment 9 Cor Nouws 2016-12-09 21:33:43 UTC
I have seen the same problem yesterday in 5.2.x
Comment 10 Ferry Toth 2016-12-11 18:41:59 UTC
I just tried using LibO 5.2.3.2 (aka fresh) from the Libreoffice PPA. I haven't yet polled the receivers but I'm pretty sure the problem still happened.
Just before the sending dialog closed I saw the counter reaching 97 with about half of that actually transferred.
Comment 11 Alex Kempshall 2016-12-14 12:10:21 UTC
I've had this problem. I have a test database with 3 records, only one of them ever gets through.

This is on 5.4.0.0.alpha0+.

I have amended sw/source/ui/dbui/mmoutputtypepage.cxx to put two sleeps in and I now get all 3 messages sent.

Not tried it with more than 3 messages. I shall attach a git diff with my changes.

Hope this helps a developer.
Comment 12 Alex Kempshall 2016-12-14 12:15:45 UTC
Created attachment 129628 [details]
A hack to maybe fix this bug

I would in no way suggest putting sleeps in to solve this bug. This diff is a suggestion to the developers as to where the problem may be. 

I have tested this on Lubuntu 14.04 LTS, Slackware 14.2 64bit and Slackware 14.2 32bit all using freshly compiled 5.4.0.0.alpha0+

Alex
Comment 13 Alex Kempshall 2016-12-30 17:47:44 UTC
The problem appears to be with latency in combination with monitoring the wrong variable.

Currently If I send 63 messages to smtp.gmail.com, Libreoffice gives the appearance of struggling to keep up. It appears to pre-process all the batch of 63 messages quite quickly. In parallel with the pre-processing it sends processed messages to the smtp server this is done at a slow pace. Once it's pre-processed all 63 messages it doesn't wait until all the messages have been sent but just closes the dialog stopping Libreoffice from sending any more messages to smtp.gmail.com. Hence the problem.


If I start an smtp server on my own machine and send the messages to localhost I don't see this problem as the messages have got less distance to travel and keep pace with the pre-processing.

In the past up to and including LO 5.1 the progress dialog was always kept open and had to be closed manually. I have tested a patch that will revert to that behavior. I will submit it to gerret during the week commencing Monday 2nd January 2017.

Alex
Comment 14 Ferdi 2016-12-30 18:30:08 UTC
Thank you Alex! Great work.
Comment 15 Aleksander Kelšin 2017-02-11 14:16:03 UTC
This bug has been around for a while. That's why I keept 5.1.* for now. Today I tried 5.2.5.1 and e-mail is sent just for one record, while other functions (Edit Individual Documents, Save Merged Document and Print Merged Documents) work fine.
Comment 16 Eric 2017-02-18 19:42:44 UTC
Hi,

I can confirm that this bug also happen on Ubuntu 16.04 , LO Version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~xenial1.1
Threads CPU : 12; Version de l'OS :Linux 4.4; UI Render : par défaut; VCL : gtk2; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group


I've turned on debug in mailmerge.py, and it sends the first email and not the others.

Here is the log  :

PyMailServiceProvider init
PyMailServiceProvider create with <Enum instance com.sun.star.mail.MailServiceType ('SMTP')>
PyMailSMTPService init
python version is: 3.5.2 (default, Nov 17 2016, 17:05:23) 
[GCC 5.4.0 20160609]
PyMailSMTPService getSupportedConnectionTypes
PyMailSMTPService connect
ServerName: relay.dommel.be
Port: 25
False
Timeout: <object object at 0x7fda2419b0c0>
ConnectionType: Insecure
PyMailSMTPService isConnected
PyMailSMTPService sendMailMessage
PyMailSMTPService subject: test
PyMailSMTPService from:  Eric Bechet
PyMailSMTPService from:  xxxxxxx@yyy.com
PyMailSMTPService send to: ('bzbz@email.com',)
PyMailSMTPService flavors len: 1
PyMailSMTPService mimetype is: text/plain; charset=UTF-8; format=flowed
('PyMailSMTPService recipients are: ', dict_keys(['bzbz@email.com']))
send: 'ehlo [127.0.1.1]\r\n'
reply: b'250-amber.schedom-europe.net\r\n'
reply: b'250-STARTTLS\r\n'
reply: b'250-PIPELINING\r\n'
reply: b'250 8BITMIME\r\n'
reply: retcode (250); Msg: b'amber.schedom-europe.net\nSTARTTLS\nPIPELINING\n8BITMIME'
send: 'mail FROM:<xxxx@yyy.com>\r\n'
reply: b'250 ok\r\n'
reply: retcode (250); Msg: b'ok'
send: 'rcpt TO:<bzbz@email.com>\r\n'
reply: b'250 ok\r\n'
reply: retcode (250); Msg: b'ok'
send: 'data\r\n'
reply: b'354 go ahead\r\n'
reply: retcode (354); Msg: b'go ahead'
data: (354, b'go ahead')
send: b'MIME-Version: 1.0\r\nContent-Type: text/plain; charset="utf-8"\r\nContent-Transfer-Encoding: quoted-printable\r\nSubject: test\r\nFrom: =?utf-8?q?Eric_Bechet?= <xxx@yy.com>\r\nTo: bzbz@email.com\r\nX-Mailer: LibreOffice 5.3 via Caolan\'s mailmerge component\r\nDate: Sat, 18 Feb 2017 20:39:13 +0100\r\n\r\n=EF=BB=BFBonjour Eric B=C3=A9chet, habitant Montr=C3=A9al.Votre courriel es=\r\nt dsfsdf@fff.be\r\n    =20\r\nHello\r\n\r\n\r\n.\r\n'
PyMailSMTPService isConnected
PyMailSMTPService disconnect
send: 'quit\r\n'
reply: b'250 ok 1487446761 qp 25915\r\n'
reply: retcode (250); Msg: b'ok 1487446761 qp 25915'
data: (250, b'ok 1487446761 qp 25915')
reply: b'221 amber.schedom-europe.net\r\n'
reply: retcode (221); Msg: b'amber.schedom-europe.net'
Comment 17 Jeff Bennett 2017-03-26 21:49:17 UTC
I can confirm that this problem is still present in Version: 5.3.1.2
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

It seems like it tracks "sent" and "created" and as soon as all the documents are created, the dialog closes and no more emails are sent.  This results in ~half the expected emails actually being sent.  Some go out, some do not.

As a further annoyance, the dialog closes so it becomes impossible to see which emails failed.

If the dialog just didn't auto close, I'm guessing all would be well.
Comment 18 Alex Kempshall 2017-03-27 12:02:53 UTC
I did submit a hack for this which was to simply take out the code that closed the dialog. It got rejected because

"
Patch Set 2: Code-Review-2

Sure it fixes the problem, if the user keeps LO open long enough, but you won't get any feedback _when_ that is. With this patch the MailDispatcher thread is simply never stopped.
"

It's been suggested that -

"
The email progress dialog is created using
VclPtr<SwSendMailDialog> pDlg =
VclPtr<SwSendMailDialog>::Create(pButton, *xConfigItem);

And this dialog actually creates and keeps the mail dispatcher alive, as you can see in struct SwSendMailDialog_Impl.

The main problem seems to be the last endDialog(pButton);, which you
removed. As the pDlg has the pButton as a parent, the destruction of the main dialog also closes the progress dlg, which shuts down the dispatcher.

So a quick fix would probably be to make the SwSendMailDialog modal and execute it before the endDialog. This should block closing the MM wizard. I don't know, if it has a way to interact, but I guess it closes when all mails are send.

A better fix would be to change the parent of SwSendMailDialog to something else, so it won't close on MM wizard close, and will still process the mails in the background. So a user can still use LO while the emails are send, but obviously is also able to close LO.
"
Comment 19 Doug Hutcheson 2017-03-31 06:13:41 UTC
(In reply to Jeff Bennett from comment #17)
> I can confirm that this problem is still present in Version: 5.3.1.2
> Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
> CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine:
> new; 

I seem to have hit this problem too, but have only today started to look at email merge for the first time, so have been assuming it was my error.   "8-)

Version: 5.3.1.2
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 8; OS Version: Linux 4.9; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: en-AU (en_AU.UTF-8); Calc: group

I have a test Calc sheet with 12 entries all using my email address and a test Writer document with two merge fields and a little text.

I have set up Writer Mail Merge Email and it tests successfully, so I think that much is working OK (it is set to use my ISP's mail that I use for normal emails).

When I press the 'Send Documents' button, a small dialog pops up for a second and it appears to count up to 12 before closing. Following this, another larger dialog pops up and it seems to be saying the connection has been established and is sending, but it closes before I can read any more.

The result so far has been out of each attempt at sending twelve messages, only one email arrives in my inbox from my ISP.

From the above I conclude 1) my settings are correct and 2) I am hitting the exact bug described here.
Comment 20 Alex Kempshall 2017-04-10 09:45:56 UTC
I've been working from the developers advice and built another patch that addresses this problem.

Still in testing. It does send all messages using the mail merge wizard and also a macro using the mail merge API. So I'm happy with it so far.

I will submit it later this week.
Comment 21 Ferdi 2017-04-10 10:51:47 UTC
(In reply to Alex Kempshall from comment #20)
> I've been working from the developers advice and built another patch that
> addresses this problem.
> 
> Still in testing. It does send all messages using the mail merge wizard and
> also a macro using the mail merge API. So I'm happy with it so far.
> 
> I will submit it later this week.

I really appreciate your work. I am not a programmer. But when mailmerge works like it ought to, will make sending my newsletters to their subscribers much easier.

Much thanks in advance!
Comment 22 KSN 2017-04-11 04:34:13 UTC
(In reply to Alex Kempshall from comment #20)
> I've been working from the developers advice and built another patch that
> addresses this problem.
> 
> Still in testing. It does send all messages using the mail merge wizard and
> also a macro using the mail merge API. So I'm happy with it so far.
> 
> I will submit it later this week.

Thanks very much.  Will make a big difference in our organisation where we send out Payslips as PDF attachments to our employees every month.

Cheers and thanks once again!
Comment 23 Jeff Bennett 2017-04-18 03:44:23 UTC
Not a fix, but a (clumsy) workaround.  I found that if you add a bunch of fake rows to your .ODS the mail-merge will hit all the real addresses before it kills itself.  Essentially, if I want it to mail 20 (real) people, I added an extra 20 rows that sent to "no-one@example.org" causing LO to create 40 total documents.  It generally gets to mail#20 before dying.

Let's hope a real fix comes soon, but at least you can (sort-of) get mail-merge to function.
Comment 24 worms 2017-08-13 14:38:21 UTC
Hello
I have the same problem with the last official version
Version: 5.3.5.2 Build ID: 50d9bf2b0a79cdb85a3814b592608037a682059d
and also with the development version 5.4

The number of documents sent counter never reaches the total number of documents.

Is there any fix  available

I have seen that a possible  workaround was to add X lines with mail adress no-one@example.org
but without been sure that the number of lines is sufficient to send all messages

Regards
Comment 25 Alex Kempshall 2017-08-21 09:58:26 UTC
Hello All

It's still in 

Version: 6.0.0.0.alpha0+
Build ID: 1e3bd9bd15550033ae76012014d631b104ff2008

The last patch I submitted got rejected by Jenkins. The only solution will be to totally unravel the two dialogs which appear to be share a common class. 

Haven't had a look at in since April because of affairs of state, holidays and year end.

I may have a small window of opportunity staring with the second week of September.

I've only ever submitted a couple of patches to LibreOffice so I'm very new to this.

Alex
Comment 26 Bill 2017-08-21 10:21:16 UTC
It is difficult to provide data for the duplication of problems with mail merge as at least two files are needed (the intended recipients and the document to be specialized) together with the mode of duplication. This is hard enough; but it must be even more difficult for the person assigned to investigate the problem. Perhaps a different approach is needed for resolving mail merge problems.
Comment 27 Mamoth 2017-08-24 12:12:41 UTC
Hello.

I have a similar problem with LO 5.4.03 under Linux Mint 17.3, also originally discussed here : https://ask.libreoffice.org/en/question/124765/mail-merge-to-e-mail-only-sends-to-first-recipient/

I have been running tests with a list of 5 documents to produce from the .odt basic document.
The Mail Merge tool produces all documents correctly when I choose to save them as .odt. However, when choosing to send emails, only the first one is being sent.
I have tried switching the order of the lines in my list of addresses, it is always the same result : only the first document is being sent.

I tried with 2 different smtp servers, with the same result. I thought that maybe it was the smtp servers blocking chained sendings but a test with the Mail Merge extension of Thunderbird showed me the smtp server was not the problem (using the same list of adresses).

So it really is LO stopping the email sendings after the first one.
Comment 28 Alex Kempshall 2017-08-24 13:02:11 UTC
MailMerge is supposed to work something like this

1.
the user starts and then completes the Tools->Mail Merge Wizard. Presses the "Finish" button to complete this process.

2.
the user starts the MailMerge process by clicking on the "E-Mail Messages" button on the MailMerge toolbar 

3.
the user is then presented with the "E-Mail merged document"  dialog which is then completed as required. When complete the user will press the "Send Documents" button. This sends the messages to a Dispatcher. 

4.
The "Mail Merge" message box will be presented and will close automatically after a short time.

5.
The "Send E-mail messages" dialog will be presented and will extract the messages from the Dispatcher .
 
6.
Once all the messages have been sent the "E-Mail merged document"  dialog is automatically closed.

7.
After all messages have been posted the "Send E-mail messages" dialog will close automatically.

Unfortunately it doesn't quite work like the above as when the "E-Mail merged document" dialog is closed automatically it also closes the "Send E-mail messages" dialog and the Dispatcher even though there are still messages to post! On my system the "Send E-mail messages" dialog closes after having sent, would you believe, 13 messages out of 63 expected.

I've had a couple of goes at fixing this. Though the fixes have worked for me. I failed to persuade the developers and Jenkins to let the fixes through.

I have another fix that again works for me. Though, I suspect that the automatic validation tool that the developers use will find some issue with it.
Comment 29 Bill 2017-08-25 11:36:22 UTC
(In reply to Alex Kempshall from comment #28)
> MailMerge is supposed to work something like this
> 
> 1.
> the user starts and then completes the Tools->Mail Merge Wizard. Presses the
> "Finish" button to complete this process.
> 
> 2.
> the user starts the MailMerge process by clicking on the "E-Mail Messages"
> button on the MailMerge toolbar 
> 
> 3.
> the user is then presented with the "E-Mail merged document"  dialog which
> is then completed as required. When complete the user will press the "Send
> Documents" button. This sends the messages to a Dispatcher. 
> 
> 4.
> The "Mail Merge" message box will be presented and will close automatically
> after a short time.
> 
> 5.
> The "Send E-mail messages" dialog will be presented and will extract the
> messages from the Dispatcher .
>  
> 6.
> Once all the messages have been sent the "E-Mail merged document"  dialog is
> automatically closed.
> 
> 7.
> After all messages have been posted the "Send E-mail messages" dialog will
> close automatically.
> 
> Unfortunately it doesn't quite work like the above as when the "E-Mail
> merged document" dialog is closed automatically it also closes the "Send
> E-mail messages" dialog and the Dispatcher even though there are still
> messages to post! On my system the "Send E-mail messages" dialog closes
> after having sent, would you believe, 13 messages out of 63 expected.
> 
> I've had a couple of goes at fixing this. Though the fixes have worked for
> me. I failed to persuade the developers and Jenkins to let the fixes through.
> 
> I have another fix that again works for me. Though, I suspect that the
> automatic validation tool that the developers use will find some issue with
> it.

So glad the problem is receiving some attention at last! More strength to your arm!
Comment 30 Cor Nouws 2017-08-27 16:27:09 UTC
Hi,

(In reply to Alex Kempshall from comment #25)
> It's still in 
> 
> Version: 6.0.0.0.alpha0+
> Build ID: 1e3bd9bd15550033ae76012014d631b104ff2008

Yesterday I did a mail merge in Version: 6.0.0.0.alpha0+
Build ID: c84332184a5de3e4180514cf6e3282597ffe5dd6
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-08-24_17:44:14
Locale: nl-NL (nl_NL.UTF-8); Calc: group

- I have an ODB with a linked ODS.
- Start Writer document, open Database Window, add some fields
- Start Wizard, do some steps, close the Wizard and click Send Emails on the tool bar.
- I added a personal email address in BCC.

  > All email, 24 in this case, were properly sent.

So for me, in this set up, it works fine...
Comment 31 Cor Nouws 2017-08-27 16:29:13 UTC
(In reply to Cor Nouws from comment #30)

> - Start Wizard, do some steps, close the Wizard and click Send Emails on the
> tool bar.
> - I added a personal email address in BCC.
> 
>   > All email, 24 in this case, were properly sent.
> 
> So for me, in this set up, it works fine...

Ah, here I missed one thing (sorry!) It's not about sending just email, but about sending merged documents by email.
Will do a test for that too..
Comment 32 worms 2017-08-30 22:06:00 UTC
has said before, current version of libreoffice, has a bug for sending mails with Mail Merge Wizard
It stops to send mail as soon as all merge documents have been created,
currently the only solution I have found is to have 2 versions of libreoffice
the last one to  create documents
an older one (I have choosen V4.4) to do  Mail Merge Wizard

Regards
Comment 33 Alex Kempshall 2017-08-31 07:30:30 UTC
As I mentioned in comment 13

If I start an smtp server on my own machine and send the messages to localhost I don't see this problem as the messages have got less distance to travel and keep pace with the pre-processing.
Comment 34 Cor Nouws 2017-08-31 08:37:30 UTC
(In reply to Alex Kempshall from comment #33)
> As I mentioned in comment 13
> 
> If I start an smtp server on my own machine and send the messages to

Messages with or without a document attached?
Comment 35 Alex Kempshall 2017-09-01 07:47:29 UTC
(In reply to Cor Nous from comment #34)

> Messages with or without a document attached?

I'm sending just plain messages. No attachments.

The test data that I'm using can be found in #tdf106022
Comment 36 Alex Kempshall 2017-09-01 07:51:46 UTC
I submitted a patch for this bug on August 24th.

See https://gerrit.libreoffice.org/#/c/41519/

It is waiting code review.
Comment 37 Cor Nouws 2017-09-01 08:52:12 UTC
(In reply to Alex Kempshall from comment #35)
> (In reply to Cor Nous from comment #34)
> 
> > Messages with or without a document attached?
> 
> I'm sending just plain messages. No attachments.

This issue is about sending merged documents as attachment to the mails.
Comment 38 Cor Nouws 2017-09-01 08:53:20 UTC
(In reply to Alex Kempshall from comment #36)
> I submitted a patch for this bug on August 24th.
> 
> See https://gerrit.libreoffice.org/#/c/41519/
> 
> It is waiting code review.

Thanks!
Comment 39 Alex Kempshall 2017-09-01 10:48:22 UTC
(In reply to Cor Nous from comment #38)

The opening sentence in comment #1 from this bug report states

> When doing a Mail merge for a newsletter, not all mails are sent, although the 
> wizard does create them all.
Comment 40 Alex Kempshall 2017-09-01 10:51:16 UTC
My previous post should have refereed to the comment that opened this bug and not to the first comment.

Apologies.