Bug 103931 - FILEOPEN: DOCX Columns no longer keep their positions/column breaks ignored
Summary: FILEOPEN: DOCX Columns no longer keep their positions/column breaks ignored
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:5.4.0 target:5.3.2
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2016-11-15 10:17 UTC by Xisco Faulí
Modified: 2017-11-06 18:02 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-15 10:17:23 UTC
Steps to reproduce:
1. Open attachment 49435 [details]

Observed behaviour: all columns' text is displayed on the first column
Expected behaviour: every column is displayed on their positions

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-15 10:20:14 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2014-07-17 12:59:19 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-07-17 13:29:40 (GMT)
commit	d185204737031955c56a24356ed003d342548434 (patch)
tree	e4c99398505373577adc0a8c00586e2dc46070b7
parent	256281d8e6259dc1a71624b0f8576e9deb9cdc65 (diff)

DOCX import: set DontBalanceTextColumns=true for the last section ...
... if it has multiple columns.

See wwSectionManager::InsertSegments() for the related binary import
code which already did this.

Adding Cc: to Miklos Vajna

@vmiklos: this is the same commit as in bug 82824 which you have just committed a fix. Does it fix this one too?
Comment 2 Miklos Vajna 2017-02-24 21:37:00 UTC
No, it doesn't fix this bug. The root cause here is that the bugdoc contains 3 sections and the 3rd one is empty. Given that the current DOCX import code creates the new section in the first paragraph of the next section such empty sections are ignored.

As a consequence of this problem the 2nd section is handled as the last section and that's how the above commit made the already existing problem more visible.

I'll look into fixing this if I'm here anyway.
Comment 3 Commit Notification 2017-02-28 09:49:17 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6603947329a7b372a173a3c60e013e532d0bc5cf

tdf#103931 DOCX import: fix lost section break

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2017-03-13 11:25:27 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4605bd46984125a99b0e993b71efa6edb411699f

tdf#103931 writerfilter breaktype: same for implicit and explicit

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2017-03-17 10:09:57 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1e88c10327642e6867db5708e3fd0fb7065bc74c&h=libreoffice-5-3

tdf#103931 DOCX import: fix lost section break

It will be available in 5.3.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 vihsa 2017-05-29 06:43:35 UTC
verified.
version: 5.5.0.0.alpha0+ / build id : ec79f34 / android 5.1
Comment 7 Xisco Faulí 2017-08-01 23:14:43 UTC
Verified in comment 6