Bug Hunting Session
Bug 103942 - EDITING: Character width incorrectly calculated, cursor incorrectly positioned
Summary: EDITING: Character width incorrectly calculated, cursor incorrectly positioned
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 103998 (view as bug list)
Depends on:
Blocks: Font-Rendering HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-11-15 18:06 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2016-11-20 09:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
zip-file with test document and with screenshots showing the document in LO 5.2.3 and in LO 5.3.0 with several zoom factors (1.69 MB, application/zip)
2016-11-15 18:06 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2016-11-15 18:06:28 UTC
Created attachment 128769 [details]
zip-file with test document and with screenshots showing the document in LO 5.2.3 and in LO 5.3.0 with several zoom factors

A document created with LO 5.2 is not correctly presented in LO 5.3.0.0:
- Depending on zoom factor the characters are presented narrower or wider.
- On the other hand the cursor positions seems to be calculated correctly.
Results:
- Text incorrectly formatted: on the right edge it is cut or there ist to much space 
- Cursor position doesn't fit to the character where the cursor stands
- Problems to set cursor correctly or to select certain text for editing

Reproducing the problem:
- open the document "Testdokument.odt" from the attached zip file
- change the zoom factor and look how appearance of the document changes
- place the cursor in any line and move step by step from left to right and look where the cursor stands
- when the cursor stands within a character then try to select certain characters 

Maybe reason for this bug and for bug #103134 is the same.
Comment 1 V Stuart Foote 2016-11-16 08:34:00 UTC
See the effect on Windows 10 Pro 64-bit (1607) en-US with
Version: 5.3.0.0.alpha1+
Build ID: 84f644eee78106f01486098d446d9163b62927eb
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-15_23:52:44
Locale: en-US (en_US); Calc: CL

Both default and OpenGL rendering.
Comment 2 V Stuart Foote 2016-11-18 14:53:34 UTC
*** Bug 103998 has been marked as a duplicate of this bug. ***
Comment 3 V Stuart Foote 2016-11-18 14:55:33 UTC
bug 193998 was for Linux so setting this ALL
Comment 4 V Stuart Foote 2016-11-20 01:53:23 UTC
Seems correct now with application of
https://cgit.freedesktop.org/libreoffice/core/commit/?id=d35b5c8db00afb0316b7ae4c43126a5dad194cbb
Comment 5 Stefan_Lange_KA@T-Online.de 2016-11-20 09:52:48 UTC
I have tested with

Version: 5.3.0.0.alpha1+
Build-ID: 0f3861e65d8e652dcc31cf9a2f2b5c1a0a73b86d
CPU-Threads: 4; BS-Version: Windows 6.2; UI-Render: Standard; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-19_23:33:29
Gebietsschema: de-DE (de_DE); Calc: group

- both Writer and Calc
- with several zoom factors

Result:
The texts are displayed correctly now and the cursor positions fit to the position of the corresponding characters.