Bug 103987 - FILESAVE: DOCX Duplicated custom properties after roundtrip
Summary: FILESAVE: DOCX Duplicated custom properties after roundtrip
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: target:7.1.0 target:7.0.4
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Corrupted File-Properties 80997
  Show dependency treegraph
 
Reported: 2016-11-17 13:16 UTC by Xisco Faulí
Modified: 2020-10-28 07:12 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-17 13:16:40 UTC
1. Open attachment 102363 [details]
2. Save as a new .DOCX file
3. Open then new file in MSOffice

Observed behaviour: file is corrupted

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-17 13:18:21 UTC
Regression introduced by:

author	Heena Gupta <heena.h.gupta@ericsson.com>	2014-09-03 12:27:47 (GMT)
committer	Muthu Subramanian K <muthusuba@gmail.com>	2014-09-07 16:37:59 (GMT)
commit	47c5454ea67632278d69a1ddfe97d74f5cc4449f (patch)
tree	7ddc38fe54a23cb5c009f2cd8436c89ba2509813
parent	1b02831d802ab8327a4b73528c7200289f2a0279 (diff)

fdo#83428: Custom Properties dropped while exporting to docx

Adding Cc: to Heena Gupta
Comment 2 Xisco Faulí 2016-12-21 16:10:24 UTC
Error displayed by Open XML SDK 2.5:
1. CustomDocumentProperty: Attribute 'name' should have unique value.
2. DocGrid: The attribute main:charSpace has invalid value '4294965247'. The string '4294965247' is not a valid 'Int32' value
Comment 3 Bartosz 2017-05-25 14:47:59 UTC
How can I verify OOXML document by using Open XML SDK 2.5?
Do you have any tutorial how to configure it?
Comment 4 Miklos Vajna 2017-05-25 16:07:42 UTC
You just download the GUI program on Windows, open the docx file and there is a "validate" button to see errors.
Comment 5 Bartosz 2017-05-26 19:14:00 UTC Comment hidden (obsolete)
Comment 6 Miklos Vajna 2017-05-29 08:01:37 UTC Comment hidden (obsolete)
Comment 7 Bartosz 2017-05-29 10:31:44 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2018-06-20 02:48:43 UTC Comment hidden (obsolete)
Comment 9 Bartosz 2020-10-14 14:54:31 UTC
The root cause of problem is duplicate entry in /docProps/custom.xml:


    <property fmtid="{D5CDD505-2E9C-101B-9397-08002B2CF9AE}" pid="4" name="ContentType">
        <vt:lpwstr>Document</vt:lpwstr>
    </property>

and

    <property fmtid="{D5CDD505-2E9C-101B-9397-08002B2CF9AE}" pid="11" name="contentType">
        <vt:lpwstr>Document</vt:lpwstr>
    </property>
Comment 10 Commit Notification 2020-10-22 12:43:06 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a87af93ff874a55b81e55b46b63798fde4cefc4f

tdf#103987 Avoid duplication of the Custom Properties during OOXML export

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-10-22 14:49:47 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/5680c09fe38d639e2e0f95df9228cb44fc5db3e6

tdf#103987 Avoid duplication of the Custom Properties during OOXML export

It will be available in 7.0.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.