Download it now!
Bug 104062 - FILESAVE: DOCX File corrupted after roundtrip
Summary: FILESAVE: DOCX File corrupted after roundtrip
Status: RESOLVED DUPLICATE of bug 103988
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
Depends on:
Blocks: DOCX-Corrupted
  Show dependency treegraph
 
Reported: 2016-11-20 17:02 UTC by Xisco Faulí
Modified: 2020-05-19 12:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-20 17:02:03 UTC
1. Open attachment 96556 [details]
2. Save it as a new .DOCX
3. Open the new document in MSOffice

Observed behaviour: Corrupted file after roundtrip

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-20 17:34:06 UTC
Regression introduced by:

author	Markus Mohrhard <markus.mohrhard@googlemail.com>	2015-04-20 04:21:17 (GMT)
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2015-04-21 04:45:26 (GMT)
commit	4c3cfe60ac05d5404e3f2a92fff7af2d2f38628a (patch)
tree	47d5141591f3c93c138d5face9968c287f41ad16
parent	5fa0adf25cfcb71129e05e7218cde46874306c15 (diff)
MSO 2007 vs OOXML default values
includes:

fix data label delete element handling

According to the xsd:

<xsd:choice>
    <xsd:element name="delete" type="CT_Boolean" minOccurs="1" maxOccurs="1"/>
    <xsd:group ref="Group_DLbl" minOccurs="1" maxOccurs="1"/>
</xsd:choice>

which is just insane. Therefore as soon as we hit a non-delete element
we assume that the entry is not deleted.

Adding Cc: to Markus Mohrhard
Comment 2 QA Administrators 2017-12-10 16:44:07 UTC Comment hidden (obsolete)
Comment 3 Aron Budea 2017-12-26 07:25:50 UTC
Still in 6.0.0.1 / Windows 7.
Comment 4 QA Administrators 2018-12-27 03:42:49 UTC Comment hidden (obsolete)
Comment 5 NISZ LibreOffice Team 2020-05-19 12:39:27 UTC
Exported DOCX can be opened in Word since:

https://git.libreoffice.org/core/+/5b97e75589523b3769ec87e27854e2c841d0d79f

author	Balazs Varga <balazs.varga991@gmail.com>	Thu Aug 29 11:08:04 2019 +0200
committer	László Németh <nemeth@numbertext.org>	Fri Aug 30 16:32:47 2019 +0200

tdf#103988 OOXML export: fix bubble chart MSO interoperability

*** This bug has been marked as a duplicate of bug 103988 ***