Bug 103988 - FILESAVE: DOCX with X Y Bubble chart corrupted after roundtrip, cannot open in MSO
Summary: FILESAVE: DOCX with X Y Bubble chart corrupted after roundtrip, cannot open i...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:6.1.0 target:6.0.0.1 target:5....
Keywords: bibisected, filter:docx, regression
Depends on:
Blocks: OOXML-Chart DOCX-Corrupted
  Show dependency treegraph
 
Reported: 2016-11-17 15:39 UTC by Xisco Faulí
Modified: 2019-09-02 12:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bubble chart docx compared in MSO LO 6.2+ (63.78 KB, image/png)
2018-10-17 11:25 UTC, Timur
Details
export before fixing the problem (7.74 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-08-30 14:33 UTC, László Németh
Details
export after fixing the problem (7.74 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-08-30 14:34 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-17 15:39:50 UTC
1. Open attachment 92272 [details]
2. Save it as a new .DOCX
3. Open the new document in MSOffice

Observed behaviour: Corrupted file after roundtrip

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-17 15:42:26 UTC
Regression introduced in this range:
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=1797441c7db545b8f03ed1565d26d296cae5d7ab..5fa0adf25cfcb71129e05e7218cde46874306c15

Adding Cc: to Markus Mohrhard
Comment 2 Markus Mohrhard 2016-11-26 21:14:50 UTC
Corrupted does not tell me anything. The file looks the same after a roundtrip as before.
Comment 3 Timur 2016-11-28 10:31:45 UTC
Open XML SDK Productivity Tool gives 2 errors: 

DocGrid error "attribute charSpace has invalid value 4294965247" in /word/document.xml
Looks like this is added: w:charSpace="4294965247" 

BubbleChartSeries error "invalid child element cat" in /word/charts/chart1.xml


Version: 5.4.0.0.alpha0+
Build ID: 9691cea443a74885b3f81c602efdd3345de1e3f9
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-24_14:26:28


BTW: Please change the Version field after the bibisect, and add the original bug to See Also.
Comment 4 Justin L 2017-04-27 15:53:41 UTC
Corrupted means that MSOffice cannot open the document any more.  Verified that it is still corrupted when roundtripped by 5.4alpha.  Cannot open in MSO2003, MSO2007, MSO2013.
Comment 5 Commit Notification 2017-12-19 16:02:50 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1252f32496193e8ed532de744db31413768b8efa

don't export category info to bubble charts, tdf#103988

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-12-19 19:46:47 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=423addf8bf0bbc7a2e14faffffcdddd035bc145a&h=libreoffice-6-0

don't export category info to bubble charts, tdf#103988

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2017-12-26 20:46:06 UTC
Open XML SDK 2.5 no longer complains about the file being corrupted.
However, MSO 2010 still complains about it.
Putting back to NEW
Comment 8 Xisco Faulí 2017-12-26 20:46:30 UTC
Tested in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 9 Commit Notification 2018-01-16 12:12:57 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eca80d17b9a7d2d8e15c74965de0c78674b00502&h=libreoffice-5-4

don't export category info to bubble charts, tdf#103988

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2018-05-08 09:44:06 UTC Comment hidden (obsolete)
Comment 11 Justin L 2018-07-25 17:40:01 UTC
confirmed that Word 2013 still cannot open the file if round-tripped by LO 6.2alpha.
Comment 12 Timur 2018-10-17 11:25:08 UTC
Created attachment 145775 [details]
bubble chart docx compared in MSO LO 6.2+

Fileopen is not correct. So Filesave doesn't make sense.
Comment 13 Timur 2019-01-22 14:55:47 UTC
Bubble chart is with Power Trendline Element. But it doesn't affect this bug. 
Repro LO 6.3+.
Comment 14 Balázs Varga 2019-08-29 09:17:05 UTC
The problem is the <c:bubble3D/> tag, which according to OOXML standard can be an element of <CT_Dpt>, <CT_BubbleSer> and <CT_BubbleChart>.
Nonetheless MS-Office always export <c:bubble3D/> tag into each
<CT_BubbleSer> tag. Also MS-Office (2010/2013/2016 etc.)
cannot open (maybe it is an MS-Office bug) a file if the <c:bubble3D/>
tag is in the <CT_BubbleChart>, unlike the LibreOffice.

Related patch in progress: https://gerrit.libreoffice.org/#/c/78259/
Comment 15 László Németh 2019-08-30 14:33:58 UTC
Created attachment 153757 [details]
export before fixing the problem
Comment 16 Commit Notification 2019-08-30 14:34:12 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5b97e75589523b3769ec87e27854e2c841d0d79f%5E%21

tdf#103988 OOXML export: fix bubble chart MSO interoperability

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 László Németh 2019-08-30 14:34:21 UTC
Created attachment 153758 [details]
export after fixing the problem
Comment 18 Xisco Faulí 2019-09-02 07:45:41 UTC
Verified in

Version: 6.4.0.0.alpha0+
Build ID: 41cd3e8e817c8c33a13608e62eeb06ce2c6977e4
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Balázs Varga, thanks for fixing this issue!
Comment 19 Commit Notification 2019-09-02 08:35:12 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/55dbf08740ffefd6dd08d4bcea0638a15117dc65%5E%21

tdf#103988 OOXML export: fix bubble chart MSO interoperability

It will be available in 6.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.