Download it now!
Bug 104137 - Spelling correction resets character style to default
Summary: Spelling correction resets character style to default
Status: RESOLVED DUPLICATE of bug 51423
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking Formatting-Text-Diverse
  Show dependency treegraph
 
Reported: 2016-11-24 08:36 UTC by Ulrich Windl
Modified: 2020-08-25 06:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2016-11-24 08:36:14 UTC
For using English phrases in a German document, I have defines a character format named "Englisch" (The German word for "English") that only sets the text language to English. That works.
However the following problem exists: If there is a misspelled word in a phrase tagged with the "Englisch" character format, and I choose the right mouse button to fix the word, the word is fixed, but the character format is lost (it's "Standard" then). The character format shouldn't be changed by spell correction!
Comment 1 Buovjaga 2016-11-29 12:39:13 UTC
Repro.

Win 7 Pro 64-bit, Version: 5.2.3.3 (x64)
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI); Calc: CL
Comment 2 Ulrich Windl 2016-11-29 13:26:54 UTC Comment hidden (off-topic)
Comment 3 Buovjaga 2016-11-29 14:20:20 UTC Comment hidden (off-topic)
Comment 4 Ulrich Windl 2016-11-29 14:45:34 UTC Comment hidden (off-topic)
Comment 5 Buovjaga 2016-11-29 15:07:32 UTC Comment hidden (off-topic)
Comment 6 QA Administrators 2017-11-30 06:26:27 UTC Comment hidden (obsolete)
Comment 7 Thomas Lendo 2019-09-19 19:41:35 UTC
Seems to be one of the problems of 'exchanging' content where LibreOffice in reality deletes content and then inserts new content. This results in losing formatting/style definitions.
Comment 8 Phil Krylov 2020-08-24 21:32:22 UTC
Cannot reproduce in nightly build:

Version: 7.1.0.0.alpha0+
Build ID: a06a83b29a9da770787bffe416b138102aa12531
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; VCL: osx
Locale: en-US (en_RU.UTF-8); UI: en-US
Calc: threaded
Comment 9 Buovjaga 2020-08-25 06:12:52 UTC
Thanks, Phil. I guess it's a duplicate of bug 51423 as well.

*** This bug has been marked as a duplicate of bug 51423 ***
Comment 10 Ulrich Windl 2020-08-25 06:14:05 UTC
Just to be sure: I could reproduce in 6.4.5.2 like this:
(Using German localization, sorry)
Add some random letters and a word "bappel" in the middle.
Then mark the first letter and assign some character style to it (I mean via style sheet).
The right click on that word and accept "Pappel" as correct spelling.
The spelling changes and the assigned character style is gone.
It also happens when I assign the character style directly (not using a style sheet).
Comment 11 Buovjaga 2020-08-25 06:15:34 UTC
Ulrich: you can try with a master build to be sure https://dev-builds.libreoffice.org/daily/master/current.html
The fix is suspected to be a side-effect of fixing bug 135721