Download it now!
Bug 99786 - FORMATTING: Styling not persistent on spell-check
Summary: FORMATTING: Styling not persistent on spell-check
Status: RESOLVED DUPLICATE of bug 51423
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks: Spell-Checking Formatting-Text-Diverse
  Show dependency treegraph
 
Reported: 2016-05-11 22:03 UTC by Matthew Millar
Modified: 2020-08-24 20:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Styling change on spell-check (8.81 KB, application/vnd.oasis.opendocument.text)
2016-05-11 22:03 UTC, Matthew Millar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Millar 2016-05-11 22:03:38 UTC
Created attachment 124991 [details]
Styling change on spell-check

If spell-check corrects a word which borders text with a different style applied, the bordering style is applied to the replacement word.

See attachment. 'Tset' changes to non-italicised when spell-check corrected, whilst 'ital' remains italicised.
Comment 1 Buovjaga 2016-05-13 05:37:11 UTC
Reproduced.

Win 7 Pro 64-bit, Version: 5.1.2.2 (x64)
Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI)
Comment 2 QA Administrators 2017-10-23 14:03:14 UTC Comment hidden (obsolete)
Comment 3 Phil Krylov 2020-08-24 20:51:44 UTC

*** This bug has been marked as a duplicate of bug 51423 ***