Bug Hunting Session
Bug 104219 - FILESAVE: PPTX: Underline in text is lost after RT
Summary: FILESAVE: PPTX: Underline in text is lost after RT
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Bartosz
URL:
Whiteboard: target:5.5.0 target:5.4.0.1
Keywords: bibisected, bisected, filter:pptx, regression
: 91449 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-11-28 11:13 UTC by Xisco Faulí
Modified: 2018-09-03 16:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (38.78 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-11-28 11:13 UTC, Xisco Faulí
Details
Minimal PPTX file on which is possible to reproduce issue with underline (36.58 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-05-23 13:24 UTC, Bartosz
Details
It seems that color of the underline is reverted. It looks like it takes some default value of Underline fill (30.87 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-05-23 15:41 UTC, Bartosz
Details
.xlsx demonstrating automatic color selection, which is not working after RT (9.49 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-05-23 21:45 UTC, Bartosz
Details
.xlsx file which demonstrate the issue and could be used for testing purposes (9.68 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-05-25 11:21 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-28 11:13:34 UTC
Created attachment 129067 [details]
sample

Steps:
1. Open attached document

Observed behaviour: Underline in text is lost after RT

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-28 11:16:06 UTC
Regression introduced by:

author	PriyankaGaikwad <priyanka.gaikwad@synerzip.com>	2015-04-24 12:55:11 (GMT)
committer	Caolán McNamara <caolanm@redhat.com>	2015-05-09 19:56:54 (GMT)
commit	24be7ef5887ec3598b3b34cb4fccff17ed6e1106 (patch)
tree	c1b3b103d595a1da307de7fef6efaee3bf1cc947
parent	3e4d2043e99201ec542186039e3be34d3c226111 (diff)
tdf#90828 FILESAVE:XLSX export of underline color for text inside textbox
Problem Description:
Unable to save .xlsx with underline color for text inside textbox.

Current behavior:
After RT text underline color was not exported

Expected behaviour:
After RT text underline color should export

Added export support for <a:uFill>

Adding Cc: to PriyankaGaikwad
Comment 2 Xisco Faulí 2017-05-23 11:50:49 UTC
*** Bug 91449 has been marked as a duplicate of this bug. ***
Comment 3 Bartosz 2017-05-23 13:24:50 UTC
Created attachment 133479 [details]
Minimal PPTX file on which is possible to reproduce issue with underline
Comment 4 Bartosz 2017-05-23 15:04:37 UTC
Inside pptx file there is an file:
slide1.xml

on original pptx file there is "rPr" run's properties element:
http://officeopenxml.com/WPstyleCharStyles.php

Content:
                            <a:rPr lang="en-US" u="sng" dirty="0" smtClean="0"/>

Atfer export to .pptx by LO, the content is changing dramatically:
                            <a:rPr b="0" lang="en-US" sz="3200" spc="-1" strike="noStrike" u="sng">
                                <a:solidFill>
                                    <a:srgbClr val="000000"/>
                                </a:solidFill>
                                <a:uFill>
                                    <a:solidFill>
                                        <a:srgbClr val="ffffff"/>
                                    </a:solidFill>
                                </a:uFill>
                                <a:latin typeface="Calibri"/>
                            </a:rPr>

after deleting uFill, everything is working correctly:
                                <a:uFill>
                                    <a:solidFill>
                                        <a:srgbClr val="ffffff"/>
                                    </a:solidFill>
                                </a:uFill>
Comment 5 Bartosz 2017-05-23 15:41:34 UTC
Created attachment 133486 [details]
It seems that color of the underline is reverted. It looks like it takes some default value of Underline fill
Comment 6 Bartosz 2017-05-23 21:45:21 UTC
Created attachment 133496 [details]
.xlsx demonstrating automatic color selection, which is not working after RT
Comment 7 Bartosz 2017-05-23 23:26:33 UTC
Review:
https://gerrit.libreoffice.org/#/c/37970/
Comment 8 Bartosz 2017-05-25 11:21:24 UTC
Created attachment 133563 [details]
.xlsx file which demonstrate the issue and could be used for testing purposes
Comment 9 Commit Notification 2017-05-31 09:51:49 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8129ad7b22dceeb2fef13741aa509c2229cf03de

tdf#104219 Don't export color information when color is automatic

It will be available in 5.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2017-06-01 12:09:21 UTC
Bartosz Kosiorek committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b0cc6a3306a03798fdbe766976480160d0d5c22&h=libreoffice-5-4

tdf#104219 Don't export color information when color is automatic

It will be available in 5.4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2017-10-04 08:51:08 UTC
Verified in

Version: 6.0.0.0.alpha0+
Build ID: 6e3e4cd38b56d432c48cd7217885974e3f0519fd
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group