Bug 119649 - Font color isn't imported correctly in Impress after PPTX roundtrip (OK in MSO)
Summary: Font color isn't imported correctly in Impress after PPTX roundtrip (OK in MSO)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, filter:pptx
: 131056 (view as bug list)
Depends on:
Blocks: PPTX-Paragraph
  Show dependency treegraph
 
Reported: 2018-09-02 19:54 UTC by Jens Mildner
Modified: 2022-04-20 17:33 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Original odp file (219.74 KB, application/vnd.oasis.opendocument.presentation)
2018-09-02 19:55 UTC, Jens Mildner
Details
Page 8 how it should look (116.20 KB, application/pdf)
2018-09-02 19:56 UTC, Jens Mildner
Details
Page 8 how it actually looks after pptx roundtrip (45.61 KB, application/pdf)
2018-09-02 19:56 UTC, Jens Mildner
Details
PPTX file, created with Office 365, which is wrongly imported by LibreOffice (55.16 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-09-04 00:33 UTC, Bartosz
Details
PPTX file, created with LibreOffice, which is importing correctly (27.05 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-09-04 02:52 UTC, Bartosz
Details
Minimal ODP doc with wrong roundtrip (12.64 KB, application/vnd.oasis.opendocument.presentation)
2018-09-04 20:04 UTC, Jens Mildner
Details
Minimal PPTX doc wrongly imported (20.73 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-09-04 20:05 UTC, Jens Mildner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Mildner 2018-09-02 19:54:32 UTC
Description:
Open the attached odp file in Impress and export it to PowerPoint 2007-2010 (pptx) format, then reopen the pptx in Impress, compare with the odp. 

On pages 8, 11, 13 and 16, the whole text becomes purple since the first purple character.

Actual Results:
Please see file OrderCore_Brainstorming_Page8_pptx.pdf

Expected Results:
Please see file OrderCore_Brainstorming_Page8_odp.pdf


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Jens Mildner 2018-09-02 19:55:52 UTC
Created attachment 144614 [details]
Original odp file
Comment 2 Jens Mildner 2018-09-02 19:56:31 UTC
Created attachment 144615 [details]
Page 8 how it should look
Comment 3 Jens Mildner 2018-09-02 19:56:58 UTC
Created attachment 144616 [details]
Page 8 how it actually looks after pptx roundtrip
Comment 4 Jens Mildner 2018-09-02 19:57:32 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2018-09-03 16:17:16 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=8129ad7b22dceeb2fef13741aa509c2229cf03de

author	Bartosz Kosiorek <gang65@poczta.onet.pl>	2017-05-24 01:13:26 +0200
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2017-05-31 11:50:42 +0200
commit 8129ad7b22dceeb2fef13741aa509c2229cf03de (patch)
tree bdba1bd9ae93d50451b4f6e65981ef4fd077fe59
parent 2eceb468728088a84ad1a2b192e23e275b4b907a (diff)
tdf#104219 Don't export color information when color is automatic

Bisected with: bibisect-linux64-6.0

Adding Cc: to Bartosz Kosiorek
Comment 6 Bartosz 2018-09-03 23:19:18 UTC
I investigated this issue, and it is not regresion, rather pptx import issue. The same problem will appear after saving by MS Office.
Comment 7 Bartosz 2018-09-03 23:24:16 UTC Comment hidden (obsolete)
Comment 8 Bartosz 2018-09-04 00:33:24 UTC
Created attachment 144649 [details]
PPTX file, created with Office 365, which is wrongly imported by LibreOffice

Generally problem is that the LibreOffice is not restarting colours, when colour is not specified. 
Example in slide1.xml:
 <a:r>
                            <a:rPr lang="de-DE" sz="2200" b="0" strike="noStrike" spc="-1" dirty="0">
                                <a:solidFill>
                                    <a:srgbClr val="800080"/>
                                </a:solidFill>
                                <a:latin typeface="Arial"/>
                            </a:rPr>
                            <a:t>Monat</a:t>
                        </a:r>
                        <a:r>
                            <a:rPr lang="de-DE" sz="2200" b="0" strike="noStrike" spc="-1" dirty="0">
                                <a:latin typeface="Arial"/>
                            </a:rPr>
                            <a:t>)</a:t>
                        </a:r>

The closing bracket <a:t>)</a:t> should have default colour. 
In previous implementation of export, all colours were exported explicetely. It means that information about Default Colour was lost.
Now, when we already have export done properly, we could fix import.
Comment 9 Bartosz 2018-09-04 02:34:48 UTC
@Jens I was tried to reproduce this issue from scratch (by creating new ODP presentation and export to PPTX), but unfortunately after export it opens correctly.

Could you please reproduce this issue on new minimal presentation and provide instruction how to create such wrong presentation?
Comment 10 Bartosz 2018-09-04 02:52:48 UTC
Created attachment 144650 [details]
PPTX file, created with LibreOffice, which is importing correctly
Comment 11 Jens Mildner 2018-09-04 20:04:44 UTC
Created attachment 144678 [details]
Minimal ODP doc with wrong roundtrip
Comment 12 Jens Mildner 2018-09-04 20:05:31 UTC
Created attachment 144679 [details]
Minimal PPTX doc wrongly imported
Comment 13 Jens Mildner 2018-09-04 20:16:27 UTC
Hi Xisco, hi Bartosz,

thanks for caring! :)

Step by step instructions on how to create a minimal bug document:

1) Open Impress

Version: 6.1.0.3
Build-ID: libreoffice-6.1.0.3-snap1
CPU-Threads: 4; BS: Linux 4.4; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group threaded

2) cancel choosing a template

3) type "default_color(colored_text)" in the text box (no headline)

4) select "colored_text" without the brackets

5) choose font color red in the sidebar

6) deselect and save as "PowerPoint 2007-2019 (.pptx)" format

7) use pptx format despite the warning that not everything will be safed in pptx format

8) Reopen in Impress: the last bracket is also red

Thanks,
Jens
Comment 14 Bartosz 2018-09-05 15:13:16 UTC Comment hidden (obsolete)
Comment 15 Xisco Faulí 2018-12-05 09:48:49 UTC Comment hidden (obsolete)
Comment 16 Xisco Faulí 2019-11-26 14:41:57 UTC
So, not a regression, since the issue with attachment 144679 [details] can be reproducible back to LibreOffice 3.3
Comment 17 Xisco Faulí 2020-02-19 13:24:31 UTC Comment hidden (obsolete)
Comment 18 Xisco Faulí 2020-02-21 18:09:59 UTC
(In reply to Xisco Faulí from comment #17)
> (In reply to Bartosz from comment #14)
> > After resave minimal document with MS PowerPoint, the LibreOffice opening
> > PPTX file properly.
> > Unfortunately I was unable to find what exactly causes this wrong import.
> > I will keep investigating it.
> 
> Hi Bartosz,
> Did you find anything interesting when you investigated this issue?
> it seems it affects any property using a colour followed by an auto colour
> 
> @Ilmari, I think it's good to have it in the PPTX team's radar

I think ( not 100% sure ) the problem might be in https://opengrok.libreoffice.org/xref/core/oox/source/drawingml/textrun.cxx?r=a7f28581#78, where aPropSet is not reset properly.
@Mark, since you fixed bug 106638 ( also fixed in that method ) I thought you might be interested in this issue...
Comment 19 Oliver Grimm 2020-03-02 10:12:56 UTC
*** Bug 131056 has been marked as a duplicate of this bug. ***
Comment 20 Timur 2021-05-31 11:54:25 UTC
Sample in this bug is ODP attachment 144678 [details]. 
Another sample with underline color that may be the same issue is attachment 158004 [details].
Comment 21 NISZ LibreOffice Team 2022-04-20 06:41:46 UTC
Verified in:

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a98971ac975e19efa2336b608506eefa85ce2485
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 22 Xisco Faulí 2022-04-20 07:32:27 UTC
The problem with attachment 144679 [details] was fixed by

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2021-08-27 18:10:15 +0300
committer	Thorsten Behrens <thorsten.behrens@allotropia.de>	2021-09-10 12:27:14 +0200
commit 14d299f8f1e19b39dfa81e143762c6b277c1ae9a (patch)
tree e6b97cccfe5d92793bf10f8e30d491eb25e1cce3
parent 3c02fe5ca8e12dc52531367a1ac1c0802518d133 (diff)
tdf#126426: support for hyperlinks in TextParagraphContext
Comment 23 Commit Notification 2022-04-20 09:50:42 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0350c84a5e6bf7c48cd77c7fcb29a3bbdc1d8c8d

tdf#119649: sd_import_tests2: Add unittest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Timur 2022-04-20 12:57:04 UTC
(In reply to Timur from comment #20)
> Sample in this bug is ODP attachment 144678 [details]. 

It's Verified for PPTX but it should also be checked for PPT, which I did and it opens OK both in LO and MSO.

> Another sample with underline color that may be the same issue is attachment
> 158004 [details].

Not the same, not resolved, mentioned in bug 130498 but it didn't belong there. 
Underline differently wrong for PPT and PPTX. 
I reuse bug 65278 for PPT and I'll See Also there PPTX version.
Comment 25 Jens Mildner 2022-04-20 17:33:46 UTC
Wow, thanks to all involved!