Bug 104270 - COMMENTING: Inserting a Comment at the end of paragraph causes it's termination symbol to shift right
Summary: COMMENTING: Inserting a Comment at the end of paragraph causes it's terminati...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All All
: low trivial
Assignee: Mark Hung
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.1 target:5.2.6
Keywords: bibisected, bisected, regression
: 105090 (view as bug list)
Depends on:
Blocks: Writer-comments
  Show dependency treegraph
 
Reported: 2016-11-30 00:00 UTC by Gabriele Ponzo
Modified: 2017-02-24 18:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
EndOfParagraph symbol shifted on the right (5.28 KB, image/png)
2016-11-30 00:10 UTC, Gabriele Ponzo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele Ponzo 2016-11-30 00:00:32 UTC
Seen on
5.1.4.2x64 (build f99d75f39f1c57ebdd7ffc5f42867c12031db97a) Win10home

and on Elementary Linux Freya 0.3 (Ubuntu 14.04):
Version: 5.3.0.0.beta1
Build ID: 690f553ecb3efd19143acbf01f3af4e289e94536
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk2; Layout Engine: new; 
Locale: it-IT (it_IT.UTF-8); Calc: group

1. in Writer type just a word
2. hit CTRL+F10 to enable unprintable symbols visibility
3. leaving keyboard's cursor at the end of paragraph hit CTRL+ALT+C to insert a comment

OUTPUT: the mirrored P reporting the end of paragraph is shifted on the right.
Comment 1 Gabriele Ponzo 2016-11-30 00:10:38 UTC
Created attachment 129145 [details]
EndOfParagraph symbol shifted on the right

See attachment
Comment 2 Aron Budea 2016-11-30 00:17:11 UTC
Confirmed with 5.1.0.3 and 5.2.3.3 / Windows 7.
Doesn't happen in 5.0.0.5.
=> regression
Comment 3 Aron Budea 2017-01-04 22:41:02 UTC Comment hidden (bibisection)
Comment 4 Aron Budea 2017-01-04 22:41:46 UTC
This bug started with the following commit. Adding Cc: to Mark Hung. Please take a look sometimes.

author	Mark Hung <marklh9@gmail.com>	2015-08-07 16:18:20 (GMT)
committer	Norbert Thiebaud <nthiebaud@gmail.com>	2015-08-15 23:07:32 (GMT)

"Fix tdf#82176 CJK: Cursor position, line selection and non-printing
characters do not take account of hanging punctuation. Note that
placing a cursor next to the hanging puncuation is still not possible,
but the selection and the non-printing characters works fine now."
Comment 5 Xisco Faulí 2017-01-05 09:51:45 UTC
*** Bug 105090 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2017-02-02 20:45:01 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=542421402d4e4f32bd9c499673d7a3fa98b00683

tdf#104270 count hanging margin only if there is hanging portion.

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Ulrich Windl 2017-02-06 09:20:13 UTC
(In reply to Commit Notification from comment #6)
> It will be available in 5.4.0.

What I don't understand: Why not fix the problem in the "Still" (5.1) or "Fresh" (5.2) releases, but in the "over-next"? Especially when considering that the fix is like a three-line-change! So will we ever get a stable and bug-free release?
Comment 8 Xisco Faulí 2017-02-06 09:24:13 UTC
it needs to be backported.
@Mark, could you please cherry-pick it to 5.3.X and 5.2.X and close it as RESOLVED WORKSFORME?
Regards
Comment 9 Commit Notification 2017-02-06 22:22:37 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bf357ae90811edc101ff13774c2e28a16bb5420d&h=libreoffice-5-3

tdf#104270 count hanging margin only if there is hanging portion.

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2017-02-10 12:36:16 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e9e63fc49962270b51a4ec6aa2d6b41f5256ac02&h=libreoffice-5-2

tdf#104270 count hanging margin only if there is hanging portion.

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.