Bug 104451 - FILESAVE Regression. Out of memory during resave .xlsx file
Summary: FILESAVE Regression. Out of memory during resave .xlsx file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta1
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.0.1
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-12-06 22:22 UTC by Bartosz
Modified: 2017-01-12 18:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz 2016-12-06 22:22:33 UTC
Description:
In LibreOffice 5.3 there is regression which cause out of memory during resave attachment 129319 [details] from bug 104374

In LibreOffice 5.2 this file is saved correctly

Steps to Reproduce:
1. Open .xlsx file from attachment 129319 [details]
2. Save as .xlsx
3.

Actual Results:  
LibreOffice hangs, and consume all memory

Expected Results:
As it was in LibreOffice 5.2: The .xlsx file is saved.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/53.0.2785.143 Chrome/53.0.2785.143 Safari/537.36
Comment 1 Bartosz 2016-12-06 22:43:57 UTC
From changes which I introduced in .xlsx export it is possible that:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=5239cefff56875c7bb45c046977f1724aace0cfb
could cause that issue.
Comment 2 Bartosz 2016-12-06 23:59:00 UTC
It looks like commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=5239cefff56875c7bb45c046977f1724aace0cfb

is causing performance regression.
Comment 3 Eike Rathke 2016-12-07 17:02:17 UTC
Definitely. I tried without and it works.
I'm going to revert that patch, also on 5-3 branch.
See also https://bugs.documentfoundation.org/show_bug.cgi?id=104434#c5
Comment 4 Commit Notification 2016-12-07 17:07:15 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=00afb44987ccd10bce740aef53861ec53c75c95f

tdf#104434 tdf#104451 Revert "tdf#46738 Fix exporting .xlsx of coloured em"...

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-12-07 20:37:03 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=50d746b78f5600a94830143b1bd5facab4d60c25&h=libreoffice-5-3

tdf#104434 tdf#104451 Revert "tdf#46738 Fix exporting .xlsx of coloured em"...

It will be available in 5.3.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.