Bug 104496 - FILEOPEN DOC/X Table rows are taller than in Word
Summary: FILEOPEN DOC/X Table rows are taller than in Word
Status: RESOLVED DUPLICATE of bug 127368
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Tables
  Show dependency treegraph
 
Reported: 2016-12-08 12:32 UTC by Gabor Kelemen (allotropia)
Modified: 2020-03-12 07:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample DOC (458.62 KB, multipart/mixed)
2018-10-15 15:22 UTC, Timur
Details
Sample DOC with 2 pages (58.00 KB, application/vnd.ms-word)
2018-10-16 14:55 UTC, Timur
Details
Sample DOCX with 2 pages (21.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml)
2018-10-16 14:56 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2016-12-08 12:32:35 UTC
This is about the tables in the document of bug #104494 

See attachment #129394 [details] 
and the screenshot in attachment #129395 [details]

The table rows in Writer seem to be a bit taller than in Word and this - along with a few section breaks - makes the document 36 pages long compared to 28 in Word.
Comment 1 Buovjaga 2016-12-11 17:58:24 UTC
Confirmed.

In LibO 3.3 it is 34 pages.

Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 1fce5b024e9f25c3fcef2537a22474ece0dc416f
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 10th 2016
Comment 2 QA Administrators 2017-12-13 09:29:56 UTC Comment hidden (obsolete)
Comment 3 Timur 2018-10-15 15:22:16 UTC Comment hidden (obsolete)
Comment 4 Timur 2018-10-16 14:55:12 UTC
Created attachment 145761 [details]
Sample DOC with 2 pages

Sample DOC with 2 pages in MSO opens as 3 pages in LO. 
Text height is different so 1st page table doesn't fit. 
Font is Arial. No issue if table font changed to Liberation Serif.
Comment 5 Timur 2018-10-16 14:56:37 UTC
Created attachment 145762 [details]
Sample DOCX with 2 pages

Sample DOCX with 2 pages in MSO opens as 2 pages in LO. So DOC-only issue.
Comment 6 Timur 2019-04-16 08:33:46 UTC
Repro 6.3+.
Comment 7 Justin L 2020-03-12 07:00:45 UTC
(In reply to Timur from comment #5)
> Sample DOCX with 2 pages in MSO opens as 2 pages in LO. So DOC-only issue.
Only true in LO 6.2, but that was a mistake which was reverted for 6.2.8...

commit 49ddaad2f3ba4e17e1e41e94824fb94468d2b680
Author: Justin Luth <justin_luth@sil.org>
Date:   Wed Jul 25 16:33:47 2018 +0300
    tdf#117988 writerfilter: IgnoreTabsAndBlanksForLineCalculation

*** This bug has been marked as a duplicate of bug 127368 ***
Comment 8 Justin L 2020-03-12 07:02:30 UTC
P.S. This has nothing to do with fonts, just CR properties.