Bug Hunting Session
Bug 117988 - FILEOPEN An empty line is too tall in the attached DOCX
Summary: FILEOPEN An empty line is too tall in the attached DOCX
Status: RESOLVED DUPLICATE of bug 127368
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.4.0 target:6.3....
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Styles DOCX-Character
  Show dependency treegraph
 
Reported: 2018-06-04 03:17 UTC by Aron Budea
Modified: 2019-10-11 09:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample DOCX (16.74 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-06-04 03:17 UTC, Aron Budea
Details
Screenshot comparing Word and Writer (38.62 KB, image/png)
2018-06-04 03:19 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-06-04 03:17:31 UTC
Created attachment 142499 [details]
Sample DOCX

Open the attached DOCX, created in Word.

The third (empty) line shows as huge, even though the font size is supposed to be 8 pt.

Observed using LO 6.1beta1 & 4.0.0.3 / Windows 7.
Size is fine in 3.5.0.3.
=> regression
Comment 1 Aron Budea 2018-06-04 03:19:16 UTC
Created attachment 142500 [details]
Screenshot comparing Word and Writer
Comment 3 Xisco Faulí 2018-06-04 13:32:03 UTC
Reproduced in

Version: 6.1.0.0.beta1+
Build ID: b57819201ff89bbde14b4df8c02a0eb4bea2c2bb
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 4 Justin L 2018-07-25 11:39:04 UTC
The offending commit is https://cgit.freedesktop.org/libreoffice/core/commit/?id=355d25eac764713f4d52eac801ade6e2ff1deab0
n#779627: added quite some compat options from the ww8 filter on writerfilter

Specifically xSettings->setPropertyValue( "IgnoreTabsAndBlanksForLineCalculation", uno::makeAny( sal_True ) );
Comment 5 Justin L 2018-07-25 16:01:48 UTC
proposed fix  https://gerrit.libreoffice.org/57991

I used Word2013 to save the file as RTF, but it acts differently (without showing this bug) and seems unaffected by this patch.
Comment 6 Xisco Faulí 2018-07-25 16:06:18 UTC
(In reply to Justin L from comment #4)
> The offending commit is
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=355d25eac764713f4d52eac801ade6e2ff1deab0
> n#779627: added quite some compat options from the ww8 filter on writerfilter
> 
> Specifically xSettings->setPropertyValue(
> "IgnoreTabsAndBlanksForLineCalculation", uno::makeAny( sal_True ) );

Same commit as in bug 70007, are they related ?
Comment 7 Justin L 2018-07-25 18:29:55 UTC
*** Bug 70007 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2018-07-27 07:46:41 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=49ddaad2f3ba4e17e1e41e94824fb94468d2b680

tdf#117988 writerfilter: IgnoreTabsAndBlanksForLineCalculation

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2018-07-30 09:48:15 UTC Comment hidden (obsolete)
Comment 10 Commit Notification 2019-09-25 07:05:56 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/202bee1a819de7b1e8c75dd863c4154f66419400

Revert "tdf#117988 writerfilter: IgnoreTabsAndBlanksForLineCalculation"

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Justin L 2019-09-25 07:32:44 UTC
Reverting as far back as I can go since I did not have the proper fix, as proved by bug 127617.

This probably is a duplicate of bug 127368. Since that is a clean report, I'll mark this one as a duplicate.
The third (empty) paragraph has this definition:
<w:pPr>
  <w:pStyle w:val="BodyText"/>
  <w:rPr>
    <w:sz w:val="16"/>
  </w:rPr>
</w:pPr>

so, the paragraph char property size of 16pt should override BodyText style's 48pt.

*** This bug has been marked as a duplicate of bug 127368 ***
Comment 12 Commit Notification 2019-09-25 09:57:33 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/b0c5bc47d0d170df1384dd48cee9291ce6044083

Revert "tdf#117988 writerfilter: IgnoreTabsAndBlanksForLineCalculation"

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-09-26 12:36:28 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/commit/35d3f2bdc820bce8bfb98cfe942e9e91a338973b

Revert "tdf#117988 writerfilter: IgnoreTabsAndBlanksForLineCalculation"

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.