Bug 104577 - FILEOPEN DOCX: SAXParseException attribute w:eastAsiaTheme redefined
Summary: FILEOPEN DOCX: SAXParseException attribute w:eastAsiaTheme redefined
Status: RESOLVED DUPLICATE of bug 96878
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.2.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-11 11:55 UTC by Telesto
Modified: 2020-03-08 18:47 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-11 11:55:23 UTC
Description:
I suppose it's bug 99227, but for the record I'm reporting it. 




Steps to Reproduce:
1. Open attachment 128605 [details]

Actual Results:  
File format error found at 
SAXParseException: '[word/document.xml line 2]: Attribute w:eastAsiaTheme redefined
', Stream 'word/document.xml', Line 2, Column 3014(row,col).

Expected Results:
No error


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in
Version: 5.4.0.0.alpha0+
Build ID: 84f2ff67a7e404febf710b1dc7f66d06745c503f
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-09_23:20:01
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 5.2.2.1 
Build ID: 3c2231d4aa4c68281f28ad35a100c092cff84f5d
CPU Threads: 4; Versie besturingssysteem:Windows 6.2; UI Render: standaard; 
Locale: nl-NL (nl_NL); Calc: CL

but not in:

Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Mike Kaganski 2016-12-11 12:46:19 UTC
The file's document.xml is indeed ill-formed. According to ECMA-376, attribute w:eastAsiaTheme may appear at least 0 times, at most 1 time in w:rFonts. Actually the file contain 2 places where w:rFonts have 2 such attributes: for text runs "Illeték: 160.000.-" and "fizetve 2016. 10. 24.".

The document generator is LibreOffice 5.2.1.2. So, it is not a bug of input filter, but rather this could be a bug of output filter.
Comment 2 MM 2016-12-11 14:39:10 UTC
Could be a dup from bug 96878
Comment 3 Mike Kaganski 2016-12-11 15:03:15 UTC
(In reply to MM from comment #2)
> Could be a dup from bug 96878

Most probable!
The only thing left is for someone to confirm that bug.
Comment 4 Mike Kaganski 2016-12-12 06:45:03 UTC

*** This bug has been marked as a duplicate of bug 96878 ***