Download it now!
Bug 96878 - FILESAVE: duplicate attributes inserted into docx on save
Summary: FILESAVE: duplicate attributes inserted into docx on save
Status: RESOLVED DUPLICATE of bug 113790
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
: 97063 101287 102131 104577 (view as bug list)
Depends on:
Blocks: DOCX-Corrupted
  Show dependency treegraph
 
Reported: 2016-01-03 22:55 UTC by Peter Jentsch
Modified: 2018-01-09 17:08 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Original document, not broken. (10.44 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-01-03 22:55 UTC, Peter Jentsch
Details
broken document after editing and saving as docx. (10.45 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-01-03 22:56 UTC, Peter Jentsch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Jentsch 2016-01-03 22:55:50 UTC
Created attachment 121705 [details]
Original document, not broken.

- edit the document "Seminar Plan.docx" (inserting content into two previously empty table rows)
- save as docx
- close document
- try to open again -> Error, "Attribute w:eastAsiaTheme redefined" (see 2nd attachment, "Seminarplan Broken.docx"

there's another duplicate attribute below the on shown in the error message. 

Opening the "word/document.xml" file an manually removing the duplicate attributes recovers the file.
Comment 1 Peter Jentsch 2016-01-03 22:56:34 UTC
Created attachment 121706 [details]
broken document after editing and saving as docx.
Comment 2 Peter Jentsch 2016-01-03 22:57:57 UTC
LibO Version: 5.0.4.2
Build-ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Gebietsschema: de-DE (de.UTF-8)
MacOSX 10.11.2
Comment 3 Buovjaga 2016-01-04 13:49:15 UTC
(In reply to Peter Jentsch from comment #0)
> Created attachment 121705 [details]
> Original document, not broken.
> 
> - edit the document "Seminar Plan.docx" (inserting content into two
> previously empty table rows)
> - save as docx
> - close document
> - try to open again -> Error, "Attribute w:eastAsiaTheme redefined" (see 2nd
> attachment, "Seminarplan Broken.docx"

I don't reproduce this.

I do confirm that attachment 121706 [details] is broken.

Win 7 Pro 64-bit, Version: 5.0.4.2 (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: b4082bed2de12cd576a06a9f456a71101809f3ed
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-01-02_00:47:38
Locale: fi-FI (fi_FI)
Comment 4 Xisco Faulí 2016-12-11 15:36:03 UTC Comment hidden (obsolete)
Comment 5 Mike Kaganski 2016-12-12 06:45:03 UTC
*** Bug 104577 has been marked as a duplicate of this bug. ***
Comment 6 Mike Kaganski 2016-12-12 06:48:49 UTC
I also cannot reproduce generation of the ill-formed document.
It's normal that LO emits the error on opening such ill-formed documents, but it's really important to find out why it generates them in the first place.

Seeing a duplicate makes me believe that (at least some version and possibly on some platform) LO does generate them. Could it be a MacOS-only problem?
Comment 7 Buovjaga 2016-12-15 15:13:17 UTC
(In reply to Mike Kaganski from comment #6)
> Seeing a duplicate makes me believe that (at least some version and possibly
> on some platform) LO does generate them. Could it be a MacOS-only problem?

No repro

Version: 5.3.0.0.alpha0+
Build ID: 4c70a1a6666a079872b8f1966bd398e924dc1d1a
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-09-22_06:57:11
Locale: en-US (en_FI.UTF-8); Calc: group
Comment 8 Telesto 2016-12-15 19:07:48 UTC
No repro with
Version: 5.4.0.0.alpha0+
Build ID: b52167df08511239c3d08904a3d12a3c92141f38
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-12-09_23:41:33
Locale: nl-NL (nl_NL.UTF-8); Calc: group

and also not with:
Version: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Locale: nl-NL (nl_NL.UTF-8)
Comment 9 Buovjaga 2016-12-15 20:13:05 UTC
Adding Mike, so he can see the previous results.
Comment 10 Timur 2016-12-16 15:39:44 UTC
*** Bug 101287 has been marked as a duplicate of this bug. ***
Comment 11 Buovjaga 2016-12-16 17:22:30 UTC
Let's change status to NEW as it will otherwise rot.
Comment 12 Xisco Faulí 2017-10-27 11:22:18 UTC
*** Bug 97063 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2017-10-28 18:21:19 UTC
*** Bug 102131 has been marked as a duplicate of this bug. ***
Comment 14 Aron Budea 2018-01-09 17:08:33 UTC
Let's assume it's a duplicate of bug 113790, and is thus fixed.

*** This bug has been marked as a duplicate of bug 113790 ***