Bug 97063 - File format error found at SAXParseException: '[word/document.xml line 2]: Attribute w:cstheme redefined ', Stream 'word/document.xml', Line 2, Column 89341(row,col).
Summary: File format error found at SAXParseException: '[word/document.xml line 2]: A...
Status: RESOLVED DUPLICATE of bug 96878
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta3
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-01-12 10:20 UTC by Sadikh
Modified: 2018-11-07 07:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
thesis for my graduation from MBA (5.20 MB, application/zip)
2016-01-12 10:20 UTC, Sadikh
Details
Opened the file with v4.4.7 and saved again with docx. Should work now (698.27 KB, application/zip)
2016-01-12 11:03 UTC, MM
Details
Thesis file unpacked (4.90 MB, application/x-7z-compressed)
2016-01-12 15:02 UTC, MM
Details
Corrected file. (5.20 MB, application/zip)
2016-01-12 15:45 UTC, MM
Details
It shows the same error as mentioned above (52.71 KB, text/plain)
2017-07-27 08:40 UTC, EL
Details
This is a scientific paper (29.08 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-11-07 07:57 UTC, fernandamattosdesouza@yahoo.com.br
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sadikh 2016-01-12 10:20:20 UTC
Created attachment 121873 [details]
thesis for my graduation from MBA

i started my work on microsoft office, then when i changed my computer i started using libreoffice. i was writing my thesis for MBA graduation. i finished, saved and exited. then i uploaded it to my university page, and when i get back to open a file it shows File format error found at 
SAXParseException: '[word/document.xml line 2]: Attribute w:cstheme redefined
', Stream 'word/document.xml', Line 2, Column 89341(row,col). It is very urgent as i have to deliver my work now. please contact with me
Comment 1 MM 2016-01-12 11:03:31 UTC
Created attachment 121876 [details]
Opened the file with v4.4.7 and saved again with docx. Should work now
Comment 2 MM 2016-01-12 11:06:19 UTC
Confirmed with v5.0.4.2 & v5.1.0.1 under ubuntu 14.04 x64.

Looks like a dup from bug 92157
There is a patch, which isn't implemented yet, which could work.
For now you can try to downgrade to v4.4.7, which opens the file correctly.
Always remember when using LO, to save to native (odt) format first.
I've added a docx which I saved with v4.4.7, this should be imported with v5 again.
Comment 3 Sadikh 2016-01-12 11:11:50 UTC
(In reply to MM from comment #1)
> Created attachment 121876 [details]
> Opened the file with v4.4.7 and saved again with docx. Should work now

my file was 17.000 word long. this is only a small part of it. the rest it missing.
Comment 4 Sadikh 2016-01-12 11:15:57 UTC
(In reply to MM from comment #2)
> Confirmed with v5.0.4.2 & v5.1.0.1 under ubuntu 14.04 x64.
> 
> Looks like a dup from bug 92157
> There is a patch, which isn't implemented yet, which could work.
> For now you can try to downgrade to v4.4.7, which opens the file correctly.
> Always remember when using LO, to save to native (odt) format first.
> I've added a docx which I saved with v4.4.7, this should be imported with v5
> again.

how do i downgrade the program? please could anyone send me the full version of recovered file please. it is really urgent
Comment 5 Sadikh 2016-01-12 11:39:28 UTC
(In reply to Sadikh from comment #4)
> (In reply to MM from comment #2)
> > Confirmed with v5.0.4.2 & v5.1.0.1 under ubuntu 14.04 x64.
> > 
> > Looks like a dup from bug 92157
> > There is a patch, which isn't implemented yet, which could work.
> > For now you can try to downgrade to v4.4.7, which opens the file correctly.
> > Always remember when using LO, to save to native (odt) format first.
> > I've added a docx which I saved with v4.4.7, this should be imported with v5
> > again.
> 
> how do i downgrade the program? please could anyone send me the full version
> of recovered file please. it is really urgent

i opened it with v4.4.7 but there are only 2000 words instead of 17.000. where did they dissapear
Comment 6 Sadikh 2016-01-12 12:38:40 UTC
please i am kindly ask to to help me with the problem. the IT department of my university could extract some graphs and pictures from the file, and file i 5mb, however it has only 2 thousand words and no pictures when i open it with libre office v4.4.7. the file weight is the same as at the moment i saved it, and if IT deprtment could extraxt some picture that means the text should also be somewhere. PLEASE I NEED HELP URGENTLY
Comment 7 MM 2016-01-12 15:02:06 UTC
Created attachment 121878 [details]
Thesis file unpacked

Your pics & doc is here, unpacked. You can get your text from document.xml.
Might take some work though.
Comment 8 MM 2016-01-12 15:45:14 UTC
Created attachment 121880 [details]
Corrected file.

Was interested, so I investigated a bit more. In the end I removed all 'w:cstheme="majorBidi" in document.xml and replaced it in the docx. Now you should be able to see everything again.
Comment 9 Caolán McNamara 2016-08-08 16:28:05 UTC

*** This bug has been marked as a duplicate of bug 101287 ***
Comment 10 Timur 2016-11-28 16:30:04 UTC
*** Bug 102131 has been marked as a duplicate of this bug. ***
Comment 11 Timur 2016-11-28 16:40:55 UTC
I don't know why this bug was marked as a duplicate of bug 101287. Those errors are mostly different. 
Sadikh, do you have source document, some version from MSO, before saving with LO? If yes, please attach. If no, it will probably never be fixed without it.
Comment 12 EL 2017-07-27 08:40:37 UTC
Created attachment 134897 [details]
It shows the same error as mentioned above

Please fix it 
It is my assessment 
Got to submit it tonight
Comment 13 Xisco Faulí 2017-10-27 11:22:18 UTC

*** This bug has been marked as a duplicate of bug 96878 ***
Comment 14 ked 2017-11-06 00:12:22 UTC
Perhaps, in the mean time try converting the file with a some pdf converter tools online, software, it works well until the issue is being solved, apologized for the inconvenience.
Comment 15 frank 2017-12-15 22:59:01 UTC
Just wanted to confirm this issue existing under the following circumastances:

1. .docx file initially having been worked on in Microsoft Office (versions unknown, probably all across the board)

2. The document is edited in LibreOffice Writer 5.3.x (Up to 5.3.6.1) under Windows Vista

3. At some point after lots of editing and multiple saves, if the user closes the document and opens it again, the user gets the same error message (the one with w:cstheme redefined) and then will not open again. I know my way around XML, so I am able to fix these errors with mostly no losses, as far as i can tell.

Unfortunately I cannot attach a sample of this, as those are legal documents of a friend of mine, who I am trying to turn from MS Office to LibreOffice... 

These problems do not help though...


UPDATE: I just checked opening such a document with a freshly installed LO 5.4.3.2 and it will open it, despite the warnings, and allow a fresh save (which seems to fix the issue, as no other warnings are thrown afterwards)
Comment 16 frank 2017-12-15 23:00:39 UTC
Just wanted to confirm this issue existing under the following circumastances:

1. .docx file initially having been worked on in Microsoft Office (versions unknown, probably all across the board)

2. The document is edited in LibreOffice Writer 5.3.x (Up to 5.3.6.1) under Windows Vista

3. At some point after lots of editing and multiple saves, if the user closes the document and opens it again, the user gets the same error message (the one with w:cstheme redefined) and then will not open again. I know my way around XML, so I am able to fix these errors with mostly no losses, as far as i can tell.

Unfortunately I cannot attach a sample of this, as those are legal documents of a friend of mine, who I am trying to turn from MS Office to LibreOffice... 

These problems do not help though...


UPDATE: I just checked opening such a document with a freshly installed LO 5.4.3.2 and it will open it, despite the warnings, and allow a fresh save (which seems to fix the issue, as no other warnings are thrown on subsequent openings of the same file)
Comment 17 fernandamattosdesouza@yahoo.com.br 2018-11-07 07:57:07 UTC
Created attachment 146378 [details]
This is a scientific paper

The error message from the version from LibreOffice is:-
File format error found at
SAXParseException: '[word/document.xml line 2]: Attribute w:themeColor redefined
', Stream 'word/document.xml', Line 2, Column 76545(row,col).