Bug 102131 - docx file got corrupted after saving, and doesn't open (SAXParseException, w:cstheme, Complex Script Theme Font)
Summary: docx file got corrupted after saving, and doesn't open (SAXParseException, w:...
Status: RESOLVED DUPLICATE of bug 96878
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: dataLoss, filter:docx, needsDevAdvice
Depends on:
Blocks:
 
Reported: 2016-09-12 21:20 UTC by honzahladky
Modified: 2017-11-14 11:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
does not open with any version of MS Word, Libreoffice, or GoogleDocs. (223.71 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-09-12 21:20 UTC, honzahladky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description honzahladky 2016-09-12 21:20:19 UTC
Created attachment 127288 [details]
does not open with any version of MS Word, Libreoffice, or GoogleDocs.

This is originally a Word document which I worked on (using LibreOffice) in several sessions (open/saved without problems). Now, the file does not open with Libreoffice, with Word, or with GoogleDocs. (I would be grateful if the file could be recovered for me).
Comment 1 Aron Budea 2016-09-13 04:58:12 UTC
This is the error message:

---
File format error found at 
SAXParseException: "No namespace defined for a"
SAXParseException: '[word/footnotes.xml line 2]: Namespace prefix a on fontRef is not defined
', Stream 'word/footnotes.xml', Line 2, Column 61843
SAXParseException: '[word/document.xml line 2]: Extra content at the end of the document
', Stream 'word/document.xml', Line 2, Column 31368(row,col).
---

Looks somewhat similar to bug 92840.
This seems to be a serious data loss issue, it would be great if someone could look into it.
Comment 2 kosmas sofronidis 2016-10-03 08:43:25 UTC
Βρέθηκε σφάλμα μορφής αρχείου στο 
SAXParseException: '[word/document.xml line 2]: Attribute w:cstheme redefined
', Stream 'word/document.xml', Line 2, Column 8733 (γραμμή,στήλη).
Comment 3 Julien Nabet 2016-10-27 20:29:21 UTC
Would you have a previous version which opens well?
Comment 5 Julien Nabet 2016-11-02 08:22:38 UTC
Response received by email in private:
"...no unfortunately, I do not have such a copy..."
Comment 6 Timur 2016-11-28 16:30:04 UTC
This looks like Bug 97063 that was first duplicated to Bug 99227, but which I marked as Invalid because it's a different error and there's no source.
The real issue is that all those bugs don't have source documents nor the steps required to reproduce so it's unlikely they'll be fixed.

*** This bug has been marked as a duplicate of bug 97063 ***
Comment 7 Xisco Faulí 2017-10-27 11:08:50 UTC

*** This bug has been marked as a duplicate of bug 101287 ***
Comment 8 Xisco Faulí 2017-10-28 18:21:19 UTC

*** This bug has been marked as a duplicate of bug 96878 ***